+ Responder ao Tópico



  1. #1
    eicke
    Visitante

    Padrão Instalar gcc

    Galera estou tentando instalar o gcc mas ta dando o seguinte erro:

    # ./configure
    Configuring for a i686-pc-linux-gnu host.
    Created "Makefile" in /root/gcc-3.3.3 using "mt-frag"
    ./configure: cc: command not found
    *** The command 'cc -o conftest -g conftest.c' failed.
    *** You must set the environment variable CC to a working compiler.

    alguem pode me ajudar???
    Valeu.

  2. #2
    jamba
    Visitante

    Padrão Instalar gcc

    Qual distribuicao vc esta usando????



  3. #3
    eicke
    Visitante

    Padrão Instalar gcc

    Red Hat 9

  4. #4
    nafre
    Visitante

    Padrão Instalar gcc

    cara, instalar o gcc e uma coisa compplicada mais vamos ver se consiguo te ajudar.

    http://gcc.gnu.org/install/

    entra ai e da uma olhada qualquer coisa perguntar, se vc for iniciante aconselho vc a instalar novamente o SO ou uma versao mais atualizada.



  5. #5

    Padrão Instalar gcc

    Cara vc ta tentando compilar o gcc com sem o gcc instalado !!!!!!!! primeiro vc tera que instalar o pacote do gcc e não compilar senão vc não tera compilador para compilar o pacote !!!!!! entendeu ???


    :wink:

  6. #6
    eicke
    Visitante

    Padrão Instalar gcc

    Pois eh...quando tento instalar o pacote via rpm acontece o seguinte...

    # rpm -i gcc-2.96-113.i386.rpm
    error: failed dependencies:
    glibc-devel is needed by gcc-2.96-113

    Bom ai tento instalar o glibc-devel entao...
    # rpm -i glibc-devel-2.2.5-43.i386.rpm
    error: failed dependencies:
    glibc = 2.2.5 is needed by glibc-devel-2.2.5-43
    Verifiquei a versao do glibc e tentei instalar uma versao do glibc-devel
    # rpm -qva | grep glibc
    glibc-common-2.3.2-11.9
    glibc-kernheaders-2.4-7.16
    glibc-2.3.2-11.9

    # rpm -i glibc-devel-2.3.2-11.9.i386.rpm
    error: failed dependencies:
    binutils < 2.13.90.0.16-5 conflicts with glibc-devel-2.3.2-11.9

    Ao tentar atualizar o binutils...
    # rpm -Uvh binutils-2.13.90.0.8-1.i386.rpm
    Preparing... ########################################### [100%]
    Segmentation fault

    Ou seja nao consigo fazer nada! E a maquina esta em producao...alguem por favor pode me ajudar????

    Eicke.



  7. #7
    jamba
    Visitante

    Padrão Instalar gcc

    Mesmo com esssa falha de segmentacao depois de atualizar o binutils tentou instalar o resto???
    C nao der certo tenta desinstalar o binutils e instalar de novo. Cuidado ao autalizar pacotes rpms sempre da esse pau.

  8. #8
    eicke
    Visitante

    Padrão Instalar gcc

    O binutils nao é atualizado com o rpm -U se tento desisntalar o binutils tb da erro:

    # rpm -e binutils-2.11.93.0.2-11
    Segmentation fault



  9. #9
    jigabo0
    Visitante

    Padrão Instalar gcc

    Nao sei se no Red Hat 9, existe essa opção... mas no conectiva roda normalmente, como o red hat 9 usa rpm tbm, eu imagino que funcione

    usa o :
    apt-get install glib*

    (ele vai construir uma arvore de dependencia, e vai instalar todos os pacotes glib*, glib-devel e etc) se der algum erro do tipo Erro: Nao foi possivel encontrar o pacote (nome do pacote) vc usa rpm -ivh (nome do pacote) se der erro de dependencia ,
    vc usa rpm -ivh (nome do pacote) --nodeps (vai instalar o pacote forcado, nao vai ligar pras depedencias, ele vai instalar ... mas nao se sabe se vai funcionar )

    espero ter ajudado ! qualquer coisa..

  10. #10
    eicke
    Visitante

    Padrão Instalar gcc

    # rpm -ivh glibc-devel-2.2.5-43.i386.rpm --nodeps
    Preparing... ########################################### [100%]
    Segmentation fault


    Mesmo com o nodeps da erro....



  11. #11

    Padrão Instalar gcc

    Este pacote é para RedHat ??? estranho !!!!!!!

  12. #12
    jigabo0
    Visitante

    Padrão Instalar gcc

    realmente estranho , vai no http://rpm.pbone.net/index.php3 e baixa o glib pra redhat

    tenta instalar qualquer outro pacote ! qualquer um ! se der o mesmo erro, eh o seu rpm que está com problema !

    se for possivel... reinstale sua distro, e instala pacientemente escolhendo os pacotes... aproveita e ja instala o gcc e etc !



  13. #13
    muganga
    Visitante

    Padrão Instalar gcc

    o pacote gcc é um pacote meio delicado de instalar...nunca utilize a opcao --force --nodeps.....tive esse problema quando fui instalar uma placa wireless....aconselho instalar o gcc pelo comando
    rpm -hiv gcc....
    e se ele pedir que precisa de outros pacotes instalados o melhor caminho é ir instalando um a um..

    Abraço a todos

    Muganga
    ICQ: 314528019