+ Responder ao Tópico



  1. #1
    Visitante

    Padrão help!

    kras.. to com um problema.. eu quero roda um simples scritp em php
    esse:

    <?php if(empty($page)) {
    include("news.php");
    }
    else {
    include("$page.php");
    }
    ?>

    ele ta funcionando de boa no servidor pago e tals... dae resolvi montar um servidor aque ... uso o slackware.. instalei os pacotes apache, php e mysql de boa ta funcionando ... so q ele nao ta executando esses tipo de script ... creio que tem q mudar alguma configuração no php.ini ou seja no php ... mas nao sei o q mudar... esse é o problema... se alguem souber aee como faz isso eu agradeço. =]

  2. #2
    narwen
    Visitante

    Padrão Re: help!

    Citação Postado originalmente por Anonymous
    kras.. to com um problema.. eu quero roda um simples scritp em php
    esse:

    <?php if(empty($page)) {
    include("news.php");
    }
    else {
    include("$page.php");
    }
    ?>

    ele ta funcionando de boa no servidor pago e tals... dae resolvi montar um servidor aque ... uso o slackware.. instalei os pacotes apache, php e mysql de boa ta funcionando ... so q ele nao ta executando esses tipo de script ... creio que tem q mudar alguma configuração no php.ini ou seja no php ... mas nao sei o q mudar... esse é o problema... se alguem souber aee como faz isso eu agradeço. =]

    Olá ...

    muito provavelmente seu apache não está configurado pra rodar seus scripts php ...
    vc editou alguma coisa no httpd.conf ???
    já testou se o script roda na sua máquina pelo shell ??? Seria legal ver primeiro se o php está funcionando. Uma vez que o script rodou eu recomendo que você leia está página http://www.php.net/manual/pt_BR/install.apache2.php , nela vc encontrará as linhas que deve adicionar no httpd.conf (arquivo de configuração do Apache).


    []'s

    ______________________
    nw



  3. #3
    hez4el
    Visitante

    Padrão help!

    Dentro da própria instalação do php o arquivo README tem uma breve explicação de como fazer a instalção em servidores apache.
    Se for apache 2 e php4.x talvez vc deva dar uma olhada na conf do php tmb para não acontecer como no case anterior:

    https://under-linux.org/modules.php?...wtopic&t=12303

    Abraços