+ Responder ao Tópico



  1. #1
    Visitante

    Padrão Problemas com Profiles

    Pessoal, estou com uma maquina linux configurada com o samba como dominio de uma rede. Ate ai tudo as maquinas XP estao logando certinho no dominio samba. O problema e o seguinte configurei o profiles para 15 usuarios, toda vez que um usuario entra no samba ele carrega seu perfil perfeitamente o unico problema e que estou utilizando o Menu Iniciar - Programas - Inicializar, para carregar um bat e mapear a unidade de rede para cada usuario, mas nao esta funcionando ou seja ele loga carrega todo seu perfil certinho mas o inicializar parece nao estar funcionando ou seja nao carrega o bat com o mapeamento da rede, eu estou achado estranho pois numa maquina anterior configurado com a mesma versao do saba e o fedora core1, funcionava normalmente.
    Alguem sabe como resolver este problema

  2. #2

    Padrão Problemas com Profiles

    O seu logon script está certinho?

    logon script = logon.bat ou %U

    e

    [netlogon]
    comment = Serviço de Logon da Rede
    path = /home/netlogon
    guest ok = no
    writeable = no
    write list = douglas
    browseable = no

    e o seu arquivo .bat esta ni diretório indicado?

    Dá uma olhada nisso e nos retorna, OK?
    Valeu...



  3. #3
    Visitante

    Padrão Problemas com Profiles

    De uma olhada no meu smb.conf, alguém pode me ajudar?

    # Global parameters
    [global]
    ; Identificação da máquina e domínio
    workgroup = server
    netbios name = server81
    netbios aliases = server81
    server string = servidor de logon - samba server %v
    ;grupos autorizados e senhas
    hosts allow = 172.16.0. 172.16.1. 172.16.7. 127.
    min password length = 4
    smb passwd file = /etc/samba/smbpasswd
    passwd program = /usr/bin/passwd %u
    security = user
    encrypt passwords = yes
    ; senhas criptografadas

    log level = 3
    log file = /var/log/samba_log.%u
    max log size = 100
    keepalive = 20
    socket options = IPTOS_LOWDELAY TCP_NODELAY
    character set = ISO8859-1
    add user script = useradd -g server -c server81 -s /bin/false -d /dev/null %u
    logon script = \\%L\scripts\%U.bat
    logon path = \\%L\profiles\%U
    logon drive = U:
    logon home = \\%L\arquivos
    preserve case = yes
    short preserve case = yes
    case sensitive = no

    ;scripts
    domain logons = yes
    os level = 100
    preferred master = yes
    domain master = yes
    wins support = yes
    remote announce = 172.18.0.0
    comment = Servidor Samba
    admin users = root, francisco, luis
    printing = lprng
    password server = None
    time server = Yes
    [homes]
    comment = Pastas dos Usuarios
    valid users = %S
    writeable = Yes
    create mask = 0664
    directory mask = 0777
    browseable = No

    [printers]
    comment = Impressoras Linux
    path = /var/spool/samba
    create mask = 0700
    printable = Yes
    browseable = No

    [netlogon]
    comment = Compartilhamento de Scripts
    path = /etc/samba/netlogon
    writeable = Yes
    profile acls = Yes
    browseable = No
    locking = No

    [usuarios]
    path = /usuarios
    writeable = yes
    create mask = 0700
    guest ok = yes
    browseable = No
    vfs objects = recycle

    [info]
    comment = francisco
    path = /home/francisco
    writeable = Yes
    create mask = 0700
    guest ok = Yes
    browseable = No



















    [profiles]
    comment = profiles
    path = /etc/samba/profiles
    public = no
    writeable = yes
    guest ok = yes
    create mask = 0777
    force create mode = 0770
    profile acls = yes
    browseable = yes
    printable = no
    locking = No

  4. #4

    Padrão Problemas com Profiles

    Tenta fazer o seguinte:

    Coloque o seu arquivo .bat dentro do diretório netlogon (q no seu caso está em /etc/samba/netlogon). E a linha logon script coloque ela desse jeito:
    logon script = %U.bat

    Faça esse teste e ve se funciona, pois aki uso desse jeito e funciona legal.

    Aguardo retorno
    Valeu...



  5. #5
    Visitante

    Padrão Problemas com Profiles

    Não funcionou, na verdade eu estava fazendo o seguinte colocava o arquivo dentro do inicializar de cada usuário e configura o profile como no smb.conf acima e quando ele carregava o perfil no xp ele executava o que estava no inicializar tanto .bat como outros arquivos.
    Só que precisei formatar e instalar de novo porque minha máquina deu pau e agora ele carrega todos os atalhos salva, mas o teclado vem desconfigurado e ele não executa o que está no Inicializar. O que acho estranho pois se eu executar o arquivo .bat ele mapeia a rede.

  6. #6

    Padrão Problemas com Profiles

    No /etc/samba/netlogon vc colocou o arquivo nomedousuario.bat, esse arquivo tem q ter o nome igualzinho ao do usuário. Esse arquivo tb tem q ser criado no windows (de preferencia no bloco de notas).

    Vc falou q coloca isso no windows, não vejo muita lógica pois assim vc terá um trabalhão além de não poder personalizar os login dos usúarios.
    Mas pelo q vc falou parece q o windows não esta executando o arquivo .bat no seu inicializar. Faz um teste e ve se o iniciar esta funcionando diteritnho. Edite um arquivo no próprio bloco de nota, com um pequeno texto ou um palavra e coloque no inicializar e ve se ele será aberto qdo o windows carregar.



  7. #7
    Visitante

    Padrão Problemas com Profiles

    Foi feito tudo isso mas nada deu certo, ele carrega os ícones mas não carrega o arquivo .bat, nem no menu iniciar nem no nelgon com o nomedousuario.bat, e quando logo com um usuário o teclado vem desconfigurado. Não sei o que pode estar acontecendo pois cadastrei o root no domínio samba e o mesmo carrega o arquivo .bat e vem com o teclado normal. Não sei mais o que fazer.

  8. #8
    edisonlcp
    Visitante

    Padrão Coloque o arquivo smb.conf completo.....

    :? O erro pode estar no seu share scripts ou nas permissões no share ou do diretorio no OS.....



  9. #9
    Visitante

    Padrão Problemas com Profiles

    Onde eu vejo estas configurações?

  10. #10
    Visitante
    Visitante

    Padrão Logon Script

    Meu amigo, duas perguntas cretinas mas necessárias:
    - vc está com o XP home edition? O home não loga no domínio do NT
    - vc está criando um domínio para logar?



  11. #11

    Padrão Problemas com Profiles

    Cara, parece meio idiota... mas tenta fazer o teu smb.conf novamente, mas utilizando um arquivo com as outras tags.

    E o cara criou um domínio sim (é o que parece).