+ Responder ao Tópico



  1. #1
    Visitante

    Padrão Malditas placas de rede

    Olá pessoal, estou tentando configurar um firewall mas estou tendo problemas com duas placas de rede realtek 8139.
    Uma placa está respondendo pelo ip das duas, o q será isso???

    Estou usando o RH 9.

    no /etc/rc.d/rc.local levanto o modulo e configuro os ips- - - -

    modprobe 8139too
    ifconfig eth0 up
    ifconfig eth0 10.2.20.161 netmask 255.255.255.0 up
    ifconfig eth1 up
    ifconfig eth1 10.2.30.161 netmask 255.255.255.0 up

    no /etc/modules.conf faço os aliases - - - -


    alias eth0 8139too
    alias eth1 8139too


    Valew...........................

  2. #2

    Padrão Malditas placas de rede

    Como assim respondendo pelo Ip das duas...?
    Tenho duas placas dessas no meu servidor e funcionam muito bem...
    Qaul a sua configuração de rede? dá pra passar?



  3. #3

    Padrão Malditas placas de rede

    mete com IP's 192.168.0.x ...
    n se pode escolher IP's há toa

  4. #4

    Padrão Malditas placas de rede

    vc tem q criar uma rota pra segunda placa de rede... vc soh ta com a rota default



  5. #5
    Visitante

    Padrão Malditas placas de rede

    1c3_m4n

    Por que eu teria q criar uma rota, se eu estou pingando de outra maq da rede, só uma placa responde, e ela responde pelos dois ips.



    The-shadow


    Não entendi, o q os ips tem haver???
    A única coisa q mudei nos ips foi colocar eth1 para 10.2.30.161 pois antes era 10.2.20.161, por q me falaram q com isso resolveria o problema por que o linux não faz bridge.


    Pedro0278


    plugo eth0 na rede e ela pinga todo mundo e responde pelo ip 10.2.20.160 e pelo ip 10.2.30.161 q configurei para eth1, desplugo eth0 e plugo eth1, ela não pinga ninguem, e tb nao responde nada pra ninguem.

    Estou testando essa maq q está ligada em um hub.




    Será q está faltando alguma coisa em algum arquivo de configuração???



    Obrigado pelas respostas.

  6. #6

    Padrão Malditas placas de rede

    pq outra rota? pense assim sao 2 placas de rede com faixas de ip diferentes.. na hora de sair no seu servidor ele vai prokurar
    tem rota pra mim?
    naum
    ae ele usa a rota default q eh de uma das placas de rede...



  7. #7

    Padrão Malditas placas de rede

    Ai deve ter duas interfaces, eth0 e eth1 responda.
    Qual o ip de eth0?
    Qual o ip de eth1?
    Qual o ip do seu servidor de net? (geralmente algum começado com 192.168 x.x) qual a sua máscara de rede? (geralmente 255.255.255.0) o broadcast? (geralmente o ultimo numero da rede ex.:192.168.0.255 ou coisa semelhante)
    Porque voce está usando ips classe "A" para se conectar a net?
    Lembre-se que eth0 e eth1 não podem ter a mesma classe de ips como vc colocou.

  8. #8
    NeoRamza
    Visitante

    Padrão Re: Malditas placas de rede

    Citação Postado originalmente por Anonymous
    Olá pessoal, estou tentando configurar um firewall mas estou tendo problemas com duas placas de rede realtek 8139.
    Uma placa está respondendo pelo ip das duas, o q será isso???

    Estou usando o RH 9.

    no /etc/rc.d/rc.local levanto o modulo e configuro os ips- - - -

    modprobe 8139too
    ifconfig eth0 up
    ifconfig eth0 10.2.20.161 netmask 255.255.255.0 up
    ifconfig eth1 up
    ifconfig eth1 10.2.30.161 netmask 255.255.255.0 up

    no /etc/modules.conf faço os aliases - - - -


    alias eth0 8139too
    alias eth1 8139too


    Valew...........................
    Eu tive esse mesmo problema quando montei meu primeiro firewall. O que acontesse é o seguinte: os dois ips mostrados (10.2.20.161 e 10.2.30.161 ) são de uma mesma subrede. Eu sei que voce esta mudando a maskara padrao (de 255.0.0.0 para 255.255.255.0) mas mesmo assim dá esse problema, quando coloca-se ips de uma mesma subrede em duas placas de rede a primeira responde pelos dois ips e a segunda nao responde por nenhuma.

    Para resolver seu problema faca o seguinte: use ips da faixa 192.168.x.x e nao indique a netmask pois ela vai ser colocada sozinha.

    Nao sei porque isso acontesse ou se tem jeito de contornar, mas na epoca que eu tive esse problema eu nao procurei o porque disso acontecer.



  9. #9
    Visitante

    Padrão Malditas placas de rede

    Pedro0278


    Os ips e netmask eu já passei quando fiz a pergunta, essa máquina não está conectada na internet, só estou testando, portanto não estou me conectanto com ips da classe "A", e como eu posso configurar essas placas para a mesma classe de ip?


    NeoRamza

    Cara, será q não tem jeito não??? Vc configurou rotas adicionais???



    Obrigado pelas respostas!!!!!!!!!!!!!



    Flw........

  10. #10

    Padrão Malditas placas de rede

    Mesma classe de ips?
    Rapaz... o ideal é que vc tenha duas classes ja que vc tem duas placas de rede... nao complique as coisas pra sua cpu...
    como o Camarada ai falou acima porque vc não faz o esquema
    eth0 192.168.x.x 255.255.255.0
    eth1 10.0.0.1 255.255.0.0
    ou vice-versa?
    Ja entendi o que vc quer fazer, mas tenha em mente que vc quer que duas placas de rede tenham acesso a mesma rota.... ou seja se vc pede um dado no compuitador tal, qual é a placa que vai receber? por isso que não ta dando certo o pc ta em dificuldades para descobrir que é a queridinha do papai....



  11. #11
    edson_penna
    Visitante

    Padrão Companheiro...

    Todos deram suas opiniões, e com certeza elas partem de cabeças previlegiadas, eu poderia dar uma que pode ou não se adequar a sua situação, eu aconcelho vc a ler um bom tutorial sobre arquitetura tcp/ip, e com certeza vc vai resolver este problema de configuração, não se esqueça que este é apenas um problema de rota, sendo assim suas reposta está clara se vc aplicar as regras de protocolo, dá uma olhada em algum conteudo explicativo para o assunto, e vc saberá com mais clareza do que estou falando, caso vc queira comprar um bom conteudo minha sugestão é REDES DE COMPUTADORES onde o autor é o Gabriel Torres.

    Um Abraço.