+ Responder ao Tópico



  1. #1
    climber
    Visitante

    Padrão SOCORRO!

    Pessoal, o seguinte:

    To compilando o apache+mysql+php+gd+freetype1+freetype2+libpng+libjpeg.

    To usando a última versão do PHP e compilar o apache com suporte php é barbada.

    O único problema é: Eu não consigo fazer o gd e o freetype e demais bibliotecas gráficas funcionarem com o php. Já vasculhei mais de 10 receitas na NET, todas são falhas, e não funcionam.

    O mais curioso é que eu tenho 1 apache (1.3.x), padrão do debian 3.0 r1 e ao dar um phpinfo(php4.1) ele diz que tem suporte a freetype e a gd e as demais biliotecas básicas. O gd nesse apache funciona, mas o freetype não dá sinal de vida, mesmo dizendo que já tá instalado.

    Alguém tem uma luz, que seja?

    As versões que eu to utilizando do apache(que eu to instalando por fora, pra fazer funcionar) e do php são, respectivamente: 1.3.31 e 4.3.6.

  2. #2

    Padrão SOCORRO!

    Uma dica que posso te dar eh em foruns use nos topicos descricoes exatas doq vc quer... com SOCORRO, 90% da pessoas que vem isso nem abrem pra ver o q eh... suas chances de obter respostas sao reduzidas... :roll:



  3. #3
    climber
    Visitante

    Padrão Problemas com gd+freetype+php

    okies.

    Podes me dar alguma ajuda?

    Obrigado pela observação.

  4. #4

    Padrão SOCORRO!

    antes de mais nada....que erro ta acontencendo...sem isso eu simplesmente lhe diria pra executar o ./configure;make;make install pra ver se funciona...mesmo sabendo q nao vai funcionar....por isso, vc tem q falar quais passos vc executou, onde parou e qual erro deu.... :wink:



  5. #5
    edson_penna
    Visitante

    Padrão amigo...

    dá uma chegadinha no site da fundação apache e veja se existe algo que pode te ajudar, talves alguém por lá já passou pelo mesmo problema que vc mencionou...

    Um abraço.

  6. #6
    climber
    Visitante

    Padrão gd+freetype...

    Pessoal, o código que eu to usando para testar o gd e o freetype é:

    <?php

    function test ($string, $test)
    {
    echo $string . '... ';

    if ($test)
    echo "success.\n";
    else
    echo "fail.\n";
    }

    $token = "Testing GD!";

    // Create image

    $pic = ImageCreate (300, 300);

    test ('Creating image', $pic);

    $col2 = ImageColorAllocate ($pic, 0, 0, 100);
    $col1 = ImageColorAllocate ($pic, 200, 200, 200);

    // Test PNG/JPG functionality

    ob_start();
    $res1 = @ImagePNG ($pic);
    $res2 = @ImageJPEG ($pic);
    ob_clean();

    test ('Testing PNG output', $res1);
    test ('Testing JPEG output', $res2);

    // Test TrueType functionality

    $ttfont = trim (`locate -n 1 .ttf`);

    test ('Testing FreeType', @ImageTTFText
    ($pic, 30, 0, 10, 40, $col1, $ttfont, $token));
    test ('Testing FreeType2', @ImageFTText
    ($pic, 30, 0, 10, 40, $col1, $ttfont, $token, array()));

    // Test Type1 functionality

    $font = @ImagePsLoadFont (trim (`locate -n 1 .pfb`));

    if ($font)
    $res = @ImagePsText ($pic, $token, $font, 10, $col1, $col2, 0, 0);

    test ('Testing the Type1 library', ($font && $res));

    test ('Destroying image', ImageDestroy($pic));

    ?>

    Eu acabo tendo a seguinte resposta do teste:

    Creating image... success. Testing PNG output... success. Testing JPEG output... success. Testing FreeType... fail. Testing FreeType2... fail.

    Na compilação eu consegui acertar, to configurando o php pra achar as coisas do freetype no /usr/include/freetype2/freetype(--with-freetype-dir=/usr/include/freetype2/freetype

    O phpinfo diz:

    GD Support enabled
    GD Version bundled (2.0.22 compatible)
    FreeType Support enabled
    FreeType Linkage with freetype
    GIF Read Support enabled
    JPG Support enabled
    PNG Support enabled
    WBMP Support enabled
    XBM Support enabled

    O que eu faço agora? Corto os pulsos? hehe

    Preciso de ajuda urgente!



  7. #7
    epf
    Visitante

    Padrão SOCORRO!

    Se vc esta em perigo, tenho boas opcoes para voce:

    disca ai:

    190
    147

    abracos
    atenciosamente
    epf

  8. #8

    Padrão SOCORRO!

    Citação Postado originalmente por epf
    Se vc esta em perigo, tenho boas opcoes para voce:

    disca ai:

    190
    147

    abracos
    atenciosamente
    epf
    pplz, plz no flamez

    :P



  9. #9

    Padrão SOCORRO!

    Pelo que vc tem ae o seu Freetype esta ativo mas o Freetype2 num ta!!!!!!!!
    verifica a instalaçao dele q deve ter dado algum problema

  10. #10
    climber
    Visitante

    Padrão SOCORRO!

    Eu to querendo compilar só com o Freetype2 e é o que que tá achando....
    o Freetype1 tá dando pau na instalação, pq não acha um tal de lX11, que eu pesquisei e é as bibliotecas do X, mas o X eu instalei infelizmente, instalei as bibliotecas e nada!



  11. #11

    Padrão SOCORRO!

    qual eh a lib? pega o nome dela certinho
    as vezes eh soh problema de num ter o path dela no ld.so.conf
    primeiro verifica se ela ta no sistema
    find / -name LIB
    se ele achar inclua o path dela no /etc/ld.so.conf e depois rode ldconfig e tente instalar denovo

  12. #12
    climber
    Visitante

    Padrão Valeu!

    Pessoal!

    Obrigado a todos que ajudaram!
    Mas eu resolvi o problema usando "ln -s /usr/X11R6/lib/lib* /lib" que eu achei perdido numa documentação na internet!

    Então já sabem: se o XFree86-dev tá instalado e ele continua dando erro do tipo "-lX11 not found", tasca um "ln -s /usr/X11R6/lib/lib* /lib".

    Linkagem radical, mas funcionou a compilação do Freetype.

    Mais uma vez obrigado!



  13. #13

    Padrão SOCORRO!

    era soh ter incluido o path dele no ld.so.conf como te falei q num precisava fazer isso... 8O

  14. #14
    climber
    Visitante

    Padrão SOCORRO!

    eu já havia incluído, mas não funcionou...

    botei as entradas
    /usr/X11R6/lib/X11
    /usr/X11R6/lib
    /usr/X11R6/include/X11

    e dei um ldconfig depois e mesmo assim não obtive sucesso.



  15. #15

    Padrão SOCORRO!

    estranho.. pelo seupost anterior o path dele eh: /usr/X11R6/lib/lib

  16. #16
    climber
    Visitante

    Padrão SOCORRO!

    Problemas de novo.

    O Freetype2 encrenca com o Freetype1, pq o freetype.h já está carregado.

    Isso acontece quando eu dou um make no php.

    o GD é 2.0
    o Freetype1 é 1.3.1
    o Freetype2 é 2.1.8

    Posso colar o erro pra vcs se quiserem, mas dá algo como "freetype.h of Freetype 1 has been loaded!"

    Só o Freetype1 tá funcionando, mas não me adianta muito.