Página 2 de 2 PrimeiroPrimeiro 12
+ Responder ao Tópico



  1. Creio eu que sim!

    Vou responder pergunta por pergunta, ok?

    1 - O seu servidor possui três placas de rede, correto? Está cada uma em uma rede diferente:

    eth0 - internet
    eth1 - rede 192.168.0.0
    eth2 - rede 172.168.0.0

    OK! Então você tem que antes de mais nada, habilitar o roteamento com o comando:

    # echo 1 > /proc/sys/net/ipv4/ip_forward

    OK! Agora nós vamos criar as tabelas de roteamento do servidor:

    * Para acessarmos a rede 192.168.0.0, devemos utilizar essa regra:
    # route add -net 192.168.0.0/24 gw 192.168.0.1

    * Para acessarmos a rede 172.168.0.0, devemos utilizar essa regra:
    # route add -net 172.168.0.0/24 gw 172.168.0.1

    Para acessar a internet, eu já não sei, porque eu não sei que tipo de conexão é a sua, e se for ADSL, eu também não sei em que rede o seu roteador (modem da empresa de ADSL) está funcionando, mas eu estou julgando que tudo esteja funcionando na máscara de rede 255.255.255.255 (24). Também não sei os IP's que você está utilizando, por isso você tenta encaixar aí nos seus conformes.

    Rotas dos clientes WinXP

    Nos clientes WinXP da rede 192.168.0.0, você adiciona a seguinte regra:
    # route -p ADD 172.168.0.0 MASK 255.255.255.0 192.168.0.1

    ***IMPORTANTE: NA MERDA DO WINDOWS XP, VOCÊ PRECISA DAR UM TAB DEPOIS QUE TERMINOU DE DIGITAR O ENDEREÇO DE IP DA REDE QUE VOCÊ QUER ACESSAR PARA DIGITAR A MÁSCARA, SENÃO DÁ ERRO***

    Nos clientes WinXp da rede 172.168.0.0, você adiciona a seguinte regra:
    # route -p ADD 192.168.0.0 MASK 255.255.255.0 172.168.0.1

    Teste o roteamento do servidor utilizando o utilitário _traceroute_ do GNU/Linux e o _tracert_ do Windows. Tente pingar as duas redes também.

    Aqui eu não irei explicar como você compartilha algo no Windows XP, acho que não tem necessidade.

    Espero que com isso você consiga se virar ai!

    Abraços

  2. Citação Postado originalmente por xstefanox
    Creio eu que sim!

    Vou responder pergunta por pergunta, ok?

    1 - O seu servidor possui três placas de rede, correto? Está cada uma em uma rede diferente:

    eth0 - internet
    eth1 - rede 192.168.0.0
    eth2 - rede 172.168.0.0

    OK! Então você tem que antes de mais nada, habilitar o roteamento com o comando:

    # echo 1 > /proc/sys/net/ipv4/ip_forward

    OK! Agora nós vamos criar as tabelas de roteamento do servidor:

    * Para acessarmos a rede 192.168.0.0, devemos utilizar essa regra:
    # route add -net 192.168.0.0/24 gw 192.168.0.1

    * Para acessarmos a rede 172.168.0.0, devemos utilizar essa regra:
    # route add -net 172.168.0.0/24 gw 172.168.0.1

    Para acessar a internet, eu já não sei, porque eu não sei que tipo de conexão é a sua, e se for ADSL, eu também não sei em que rede o seu roteador (modem da empresa de ADSL) está funcionando, mas eu estou julgando que tudo esteja funcionando na máscara de rede 255.255.255.255 (24). Também não sei os IP's que você está utilizando, por isso você tenta encaixar aí nos seus conformes.

    Rotas dos clientes WinXP

    Nos clientes WinXP da rede 192.168.0.0, você adiciona a seguinte regra:
    # route -p ADD 172.168.0.0 MASK 255.255.255.0 192.168.0.1

    ***IMPORTANTE: NA MERDA DO WINDOWS XP, VOCÊ PRECISA DAR UM TAB DEPOIS QUE TERMINOU DE DIGITAR O ENDEREÇO DE IP DA REDE QUE VOCÊ QUER ACESSAR PARA DIGITAR A MÁSCARA, SENÃO DÁ ERRO***

    Nos clientes WinXp da rede 172.168.0.0, você adiciona a seguinte regra:
    # route -p ADD 192.168.0.0 MASK 255.255.255.0 172.168.0.1

    Teste o roteamento do servidor utilizando o utilitário _traceroute_ do GNU/Linux e o _tracert_ do Windows. Tente pingar as duas redes também.

    Aqui eu não irei explicar como você compartilha algo no Windows XP, acho que não tem necessidade.

    Espero que com isso você consiga se virar ai!

    Abraços
    Mandou bem irmão...para finalizar...eu uso um ADSL da BrasilTelecom com ip dinamico o ip do eth0 é 10.0.0.1 dado pelo proprio modem..

    Eu digito estes comandos do winXP no prompt????....e de pois q eu desligar a maquina tem q fazer de novo qndo liga-lá????

    Grato a atenção



  3. Não, não precisa, por isso que nós utilizamos o parâmetro -p, que deve ser "permanent" ou algo do gênero.

    Para fazer uma máquina WinXP ter acesso à internet, você deve definir uma rota do mesmo jeito, seguindo o mesmo exemplo, só que você coloca:

    # route -p ADD 0.0.0.0 MASK 255.255.255.0 192.168.0.1 (os números se alteram dependendo do caso da máquina e em qual rede ela está).

    Se o seu servidor já estiver navegando, creio eu que ele não vai precisar de qualquer outra mudança. Mas em tese é só ajustar as rotas!

    Posso te fazer uma pergunta? Existe mesmo a necessidade de você utilizar três redes diferentes?

    Abraços

  4. #9
    Citação Postado originalmente por xstefanox
    Não, não precisa, por isso que nós utilizamos o parâmetro -p, que deve ser "permanent" ou algo do gênero.

    Para fazer uma máquina WinXP ter acesso à internet, você deve definir uma rota do mesmo jeito, seguindo o mesmo exemplo, só que você coloca:

    # route -p ADD 0.0.0.0 MASK 255.255.255.0 192.168.0.1 (os números se alteram dependendo do caso da máquina e em qual rede ela está).

    Se o seu servidor já estiver navegando, creio eu que ele não vai precisar de qualquer outra mudança. Mas em tese é só ajustar as rotas!

    Posso te fazer uma pergunta? Existe mesmo a necessidade de você utilizar três redes diferentes?

    Abraços
    HAHAHAH...já fiz está pergunta para meu chefe umas 10 vezes mas ele viu assim não sei onde e quer imitar...coisa de velho Gaga...
    Desculpe está criando este encomodo é pq ele está enchedo o saco..

    Valeu pelas dicas...






Tópicos Similares

  1. Como fazer para os usuários não se veem no ambiente de rede.
    Por lacierdias no fórum Servidores de Rede
    Respostas: 9
    Último Post: 13-05-2005, 23:00
  2. vpn resolução de nomes no ambiente de rede
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 18-12-2004, 13:35
  3. windows nao mostra estacoes no Ambiente de Redes
    Por mcclaudio no fórum Servidores de Rede
    Respostas: 6
    Último Post: 05-06-2004, 12:05
  4. Nome das Estacoes nao aparecem no Ambiente de Rede
    Por Rurouni_Kenshin no fórum Servidores de Rede
    Respostas: 5
    Último Post: 02-06-2004, 09:09
  5. Respostas: 5
    Último Post: 23-01-2003, 21:00

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L