+ Responder ao Tópico



  1. #1
    antelo
    Visitante

    Padrão Erro Fatal: cache_effective_user

    Quando eu tento criar a cache, me dá esse erro.

    2004/07/07 14:42:23| parseConfigFile: line 1085 unrecognized: 'rule.'
    2004/07/07 14:42:23| squid.conf line 1726: http_access allow
    2004/07/07 14:42:23| aclParseAccessLine: Access line contains no ACL's, skipping
    2004/07/07 14:42:23| Squid is not safe to run as root! If you must
    2004/07/07 14:42:23| start Squid as root, then you must configure
    2004/07/07 14:42:23| it to run as a non-priveledged user with the
    2004/07/07 14:42:23| 'cache_effective_user' option in the config file.
    FATAL: Don't run Squid as root, set 'cache_effective_user'!
    Squid Cache (Version 2.5.STABLE3): Terminated abnormally.
    CPU Usage: 0.100 seconds = 0.050 user + 0.050 sys
    Maximum Resident Size: 0 KB
    Page faults with physical i/o: 365
    Abortado


    Alguém sabe me explicar?

  2. #2
    guardian_metal
    Visitante

    Padrão Erro Fatal: cache_effective_user

    Como estão seu squid.conf e as permissões de cache?



  3. #3

    Padrão Erro Fatal: cache_effective_user

    O Squid não permite que ele seja executado como usuário root, e para consertar o erro, você precisa editar a tag cache_effective_user para um outro usuário. É aí que você decide com qual usuário o Squid irá rodar...


    Abraços!

  4. #4
    guardian_metal
    Visitante

    Padrão Erro Fatal: cache_effective_user

    Procure a linha cache_effective_user em seu squid .conf e com certeza, ela deve estar assim: "cache_effective_user root" mude para "cache_effective_user nobody" e mude tb "cache_effective_group" para "cache_effective_group nobody" e tente iniciar o squid mas antes crie o cache com "squid -z".



  5. #5
    antelo
    Visitante

    Padrão Onde é que eu edito o cache, em qual lugar?

    Amigos, onde é que eu edito o cache? em qual lugar daqui?

    NO TAG OU NO DEFAULT?


    # TAG: cache_effective_user É AQUI???????
    # TAG: cache_effective_group
    #
    # If you start Squid as root, it will change its effective/real
    # UID/GID to the UID/GID specified below. The default is to
    # change to UID to "squid". If you define cache_effective_user,
    # but not cache_effective_group, Squid sets the GID the
    # effective user's default group ID (taken from the password
    # file).
    #
    # If Squid is not started as root, the cache_effective_user
    # value is ignored and the GID value is unchanged by default.
    # However, you can make Squid change its GID to another group
    # that the process owner is a member of. Note that if Squid
    # is not started as root then you cannot set http_port to a
    # value lower than 1024.

    #cache_effective_user
    #cache_effective_group


    #Default:
    # cache_effective_user É AQUI??????
    # cache_effective_group

    # TAG: visible_hostname
    # If you want to present a special hostname in error messages, etc,
    # then define this. Otherwise, the return value of gethostname()
    # will be used. If you have multiple caches in a cluster and
    # get errors about IP-forwarding you must set them to have individual
    # names with this setting.
    #

    agradeço a ajuda de vcs.

    Obrigado

  6. #6
    guardian_metal
    Visitante

    Padrão Erro Fatal: cache_effective_user

    Descomenta essas duas linhas:

    #cache_effective_user
    #cache_effective_group

    e deixa elas assim:

    cache_effective_user nobody
    cache_effective_group nobody



  7. #7
    antelo
    Visitante

    Padrão Nada Ainda

    Deixei o meu squid .conf assim:

    # TAG: cache_effective_user
    # TAG: cache_effective_group
    #
    # If you start Squid as root, it will change its effective/real
    # UID/GID to the UID/GID specified below. The default is to
    # change to UID to "squid". If you define cache_effective_user,
    # but not cache_effective_group, Squid sets the GID the
    # effective user's default group ID (taken from the password
    # file).
    #
    # If Squid is not started as root, the cache_effective_user
    # value is ignored and the GID value is unchanged by default.
    # However, you can make Squid change its GID to another group
    # that the process owner is a member of. Note that if Squid
    # is not started as root then you cannot set http_port to a
    # value lower than 1024.

    cache_effective_user nobody
    cache_effective_group nobody


    #Default:
    #cache_effective_user
    #cache_effective_group

    # TAG: visible_hostname
    # If you want to present a special hostname in error messages, etc,
    # then define this. Otherwise, the return value of gethostname()
    # will be used. If you have multiple caches in a cluster and
    # get errors about IP-forwarding you must set them to have individual
    # names with this setting.
    #


    aí, fui, no meu diretório e deu o comando

    cd /usr/local/squid/bin

    squid -z

    [[email protected] bin]# squid -z
    2004/07/14 16:14:13| parseConfigFile: line 1085 unrecognized: 'rule.'
    2004/07/14 16:14:13| squid.conf line 1726: http_access allow
    2004/07/14 16:14:13| aclParseAccessLine: Access line contains no ACL's, skipping
    2004/07/14 16:14:13| Squid is not safe to run as root! If you must
    2004/07/14 16:14:13| start Squid as root, then you must configure
    2004/07/14 16:14:13| it to run as a non-priveledged user with the
    2004/07/14 16:14:13| 'cache_effective_user' option in the config file.
    FATAL: Don't run Squid as root, set 'cache_effective_user'!
    Squid Cache (Version 2.5.STABLE3): Terminated abnormally.
    CPU Usage: 0.070 seconds = 0.040 user + 0.030 sys
    Maximum Resident Size: 0 KB
    Page faults with physical i/o: 365
    Abortado

    ---------------------------------------------------------------------------------
    eu tenho que dar este comando dentro deste diretório?

    cd /usr/local/squid/bin/cache ( pq minha pasta cache está aquí )?

    COMO QUE EU SEI QUE O USUÀRIO QUE EU ESTOU LOGADO TEM PERMISSÃO PARA DAR ESTE COMANDO SQUID -Z ????


    Obrigado pela ajuda