+ Responder ao Tópico



  1. #1
    mandi
    Visitante

    Padrão squid 2.4 para 2.5

    [[email protected] squid-2.5.STABLE5]# ./configure --enable-arp-acl
    loading cache ./config.cache
    checking for a BSD compatible install... /usr/bin/install -c
    checking whether build environment is sane... yes
    checking for mawk... no
    checking for gawk... gawk
    checking whether make sets ${MAKE}... yes
    checking whether to enable maintainer-specific portions of Makefiles... no
    checking for gcc... no
    checking for cc... no
    configure: error: no acceptable cc found in $PATH
    [[email protected] squid-2.5.STABLE5]# pwd
    /ins/squid-2.5.STABLE5

    nao desinstalei o squid 2.4 e estou instalando o 2.5. esta correto ou nao

  2. #2
    grilo
    Visitante

    Padrão squid 2.4 para 2.5

    bom kra... coloca o linux q vc usa ae... no meu uso o kurumin e ele é baseado em debian..
    eu tinha o 2.4 tb, dai eu dei o comando apt-get install squid
    dai ele instala tudim sozinho, depois vc so tem q configurar o squid.conf



  3. #3
    Visitante

    Padrão squid 2.4 para 2.5

    mas tenho que habilitar ./configure --enable-arp-acl

    como fazer? executando via apt-get install

  4. #4
    grilo
    Visitante

    Padrão squid 2.4 para 2.5

    Citação Postado originalmente por Anonymous
    mas tenho que habilitar ./configure --enable-arp-acl

    como fazer? executando via apt-get install

    vc vai no modo texto e digita apt-get install squid


    depois posta aqui se deu certo



  5. #5
    Visitante

    Padrão squid 2.4 para 2.5

    não deu certo!

    [[email protected] squid]# apt-get install squid
    Reading Package Lists... Done
    Building Dependency Tree... Done
    squid is already the newest version.
    0 packages upgraded, 0 newly installed, 0 removed and 9 not upgraded.
    ***
    Generated Sat, 10 Jul 2004 00:03:47 GMT by linux.saocamilo-es.br (Squid/2.4.STABLE7)
    ***

    ainda tenho a mesma versão

    preciso passar da versão 2.4 para 2.5, MAS habilitando -arp-acl, para trabalhar com endereço MAC, OK?

  6. #6

    Padrão squid 2.4 para 2.5

    Primeiro tira a versão que você está utilizando, mas antes faça um backup do seu squid.conf, para que você não perca nada. Depois você pega o source no site oficial do Squid http://www.squid-cache.org, provavelmente vai ter a versão que você está utilizando. Depois é só compilar...



    Abraços!



  7. #7
    mandi
    Visitante

    Padrão squid 2.4 para 2.5

    rpm -e squid
    baixei a versão 2.5-stable5 e descompactei
    ./configure --enable-arp-acl
    ./make clean
    ./make install

    Correto?
    Vc aconselha a instalar especificando um local, usando --prefix... ou não?

    Obs.: O squid pediu dependencia do sarg, desinstalo o sarg tb? e instalo novamente?

  8. #8



  9. #9

    Padrão Re: squid 2.4 para 2.5

    Citação Postado originalmente por mandi
    [[email protected] squid-2.5.STABLE5]# ./configure --enable-arp-acl
    loading cache ./config.cache
    checking for a BSD compatible install... /usr/bin/install -c
    checking whether build environment is sane... yes
    checking for mawk... no
    checking for gawk... gawk
    checking whether make sets ${MAKE}... yes
    checking whether to enable maintainer-specific portions of Makefiles... no
    checking for gcc... no
    checking for cc... no
    configure: error: no acceptable cc found in $PATH
    [[email protected] squid-2.5.STABLE5]# pwd
    /ins/squid-2.5.STABLE5

    nao desinstalei o squid 2.4 e estou instalando o 2.5. esta correto ou nao


    na boa, voces tao tudo pirando, o problema do cara eh claro.

    b]configure: error: no acceptable cc found in $PATH[/b]

    tem que instalar um compilador C na maquina, ponto final. agora dependendo da distro dele ou ele vai catar rpm, ou vai usar pkg-tarball ou entao .deb


    bom voce jah sabe, instale um compilador C.

  10. #10
    Mandi
    Visitante

    Padrão squid 2.4 para 2.5

    Minha Distro é RedHat 8
    Chegamos então a um veridito?

    01) Posso instalar via RPM e habilitar a opção de arp-acl, para controle por MAC?
    02) Caso não? Como faço para achar este compilador? baixar e instalar?



  11. #11
    Mandi
    Visitante

    Padrão squid 2.4 para 2.5

    Primeiro:
    apt-get update
    Vai atualizar os pacotes pendentes da distro
    Segundo:
    apt-get install gcc
    Vai baixar todos pacotes e suas dependências (instalando/atualizando)

    beleza, tudo ok, compilador instalado, e fonte do squid-2.4 mesmo.

    ./configure --enable-arp-acl
    make clean
    make install

    não está dando certo esta parte, não habilita a opção controle por MAC
    meus arq. squid estão em /etc/squid

  12. #12
    Visitante

    Padrão squid 2.4 para 2.5

    Citação Postado originalmente por Anonymous
    mas tenho que habilitar ./configure --enable-arp-acl

    como fazer? executando via apt-get install