+ Responder ao Tópico



  1. #1
    Poppe
    Visitante

    Padrão Problemas com o Squid

    Instalei o proxy squid em uma máquina, a qual vai funcionar como servidor de proxy, mas depois de configurar os arquivos necessários, tentei iniciar o proxy, mas está aparecendo a seguinte mensagem:

    internet /var/run]# /etc/init.d/squid stop
    Interrompendo squid squid: ERROR: No running copy
    [FALHOU]
    internet /var/run]# /etc/init.d/squid start
    squid (pid 14049 13105) está rodando...

    Sendo assim, verifiquei o arquivo /var/run/squid.pid, o mesmo está em branco, ou seja sem nada dentro dele, também verifiquei as permições com outro servidor proxy que tenho e estão iguais. Se puderem me ajudar fico grato po isso.

    Att.
    Cristiano Poppe

  2. #2
    guardian_metal
    Visitante

    Padrão Problemas com o Squid

    Você criou os diretórios de swap com squid -z?



  3. #3
    Visitante

    Padrão Problemas com o Squid

    Citação Postado originalmente por guardian_metal
    Você criou os diretórios de swap com squid -z?
    Sim eu executei o squid -z

  4. #4
    pflamellas
    Visitante

    Padrão Problemas com o Squid

    Amigo,
    que distro vc tah usando???
    dependendo da distro vc terá que criar o usuário squid....



  5. #5
    Poppe
    Visitante

    Padrão Re:

    Citação Postado originalmente por pflamellas
    Amigo,
    que distro vc tah usando???
    dependendo da distro vc terá que criar o usuário squid....
    Estou usando Conectiva 8.0, kernel 2.4.18

  6. #6
    pflamellas
    Visitante

    Padrão Problemas com o Squid

    Amigo,
    De uma olhadinha no squid.conf...
    vê para onde está apontando o cache do squid...... e os logs

    o cache (cache_dir) deve estart setado para ...

    cache_dir ufs /var/spool/squid 8100 64 64

    e os logs para .....

    cache_access_log /var/log/squid/access.log
    cache_log /var/log/squid/cache.log
    cache_store_log /var/log/squid/store.log