+ Responder ao Tópico



  1. #1
    Bolinhazin
    Visitante

    Padrão Help nat iniciante

    fala ai galera...

    eu tava querendo compartilhar a internet aqui mas naum consigo..

    ja tentei alguns comando de iptables.. mas nenhum funcionou... a minha coniguração eh a seguinte

    eth0 = ip valido (virtua)
    eth1 = ip invalido (192.168.102.10)
    ja estou com o samba funcionando perfeitamente e o servidor de dhcp esta configurado da seguinte maneira..

    subnet 192.168.102.0 netmask 255.255.255.0 {

    option routers 192.168.0.10
    option netmask 255.255.255.0

    range dynamic-bootp 192.168.102.100 192.168.102.240
    defaul-lease-time 21600
    max-lease-time 43200

    eu ja coloquei a seguinte linha no /etc/rc.local

    echo 1 > /proc/sys/net/ipv4/ip_forward


    qual o comando de nat q eu tenho q fazer no iptables pra funcionar ....

    att.
    Guilherme Faria
    ------------------------------------------------------------------------------
    still a noob a future pro

  2. #2

    Padrão Help nat iniciante

    # iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE



  3. #3

    Padrão Help nat iniciante

    no rc.local falta a linha do nat:

    iptables t nat -A POSTROUTING -o eth0 -j MASQUERADE

  4. #4
    Bolinhazin
    Visitante

    Padrão Help nat iniciante

    eh naum funcionou...

    o iptables esta adcionado no ntsysv.. tem algo mais q eu tenha q fazer???



  5. #5

    Padrão Help nat iniciante

    Pode ser que o módulo do NAT não esteja erguido:

    # modprobe iptables_nat (É isso mesmo o nome? Qualquer coisa dá uma olhada no seu /lib/modules/...).

  6. #6

    Padrão Help nat iniciante

    amigo...

    pra compartilhar a internet, teóricamente é isso...

    Adicionar no rc.local

    echo 1 > /proc/sys/net/ipv4/ip_forward
    iptables -t nat -A POSTROUTING -o eth_de_saida -j MASQUERADE

    tem certeza que teu rc.local tá sendo executado na inicialização?

    dáum cat no arquivo ip_forward pra ver se pegou 1 mesmo



  7. #7
    Bolinhazin
    Visitante

    Padrão Help nat iniciante

    hehe.. pequeno erro ..
    eu errei a plçaca de saida....

    mas ja arrumei ... mas agora eu tenho outro problema ...

    o webdesigner nao consegue entrar no ftp da embresa ele mostra o seguinte erro ,....

    Erro ao abriresta pasta no servidor FTP.Certifique-sede que voçê tem permissão para acessar esta pasta.

    Detalhes.
    200 TYPE is now ASCII
    500 i won´t open a connection to 192.168.102.240 (only to 201.6.x.x) (meu ip valido)
    500 unknow command

    qq eu faço??

    Grato .
    Guilherme Faria
    ----------------------------
    Noob desatento...

  8. #8

    Padrão Help nat iniciante

    Citação Postado originalmente por Bolinhazin
    hehe.. pequeno erro ..
    eu errei a plçaca de saida....

    mas ja arrumei ... mas agora eu tenho outro problema ...

    o webdesigner nao consegue entrar no ftp da embresa ele mostra o seguinte erro ,....

    Erro ao abriresta pasta no servidor FTP.Certifique-sede que voçê tem permissão para acessar esta pasta.

    Detalhes.
    200 TYPE is now ASCII
    500 i won´t open a connection to 192.168.102.240 (only to 201.6.x.x) (meu ip valido)
    500 unknow command

    qq eu faço??

    Grato .
    Guilherme Faria
    ----------------------------
    Noob desatento...

    O problema pode ser tanto de relay nesse caso quanto das permissões. Edite o seu arquivo de configuração do servidor de FTP pra liberar o acesso para a rede interna ou manda o Webdesigner se conectar por meio do IP externo ou então dê uma olhada nas permissões do diretório que ele quer acessar.


    Abraços!



  9. #9

    Padrão Help nat iniciante

    Amigo...

    tenta dar esses comandos:

    insmod ip_nat_ftp
    insmod ip_conntrack_ftp

    Posta o resultado

  10. #10
    Bolinhazin
    Visitante

    Padrão Help nat iniciante

    Funcionou...

    Valew.. galera....

    qquer coisa eu posto de novo....

    Abraços e valew de novo

    Guilherme Faria
    -----------------------------

    um pouco menos noob