+ Responder ao Tópico



  1. #1
    augusto y.
    Visitante

    Padrão DUAL BOOT - WINXP e Linux

    Ola,
    Realizei os procedimentos abaixo para ter Dual boot no meu sistema porem nao eh apresentado o menu do boot loader do windows para que eu escolha o sistema. Adotei os seguintes passos:

    No Slackware 9.1:

    1) dd if=/dev/hda2 of=/bootsect.lnx bs=512 count=1
    2) mount -t vfat /dev/hda2 /mnt
    3) dd if=/dev/hda2 of=/mnt/bootsect.lnx bs=512 count=1 (possuo uma particao FAT32 em /dev/hda2)


    No Windows xp pro:

    1) copiado bootsect.lnx para pasta C:\
    1) cd \windows\pss ==> (onde encontra-se meu arquivo boot.ini)
    2) attrib -s -r c:\boot.ini.backup
    3) adicionado C:\bootsect.lnx na ultimo linha do arquivo "boot.ini.backup"
    4) attrib -s -r c:\boot.ini.backup
    5) Shuttdown no windows.


    Agradeco desde ja!
    Augusto Y. :?:

  2. #2
    dB
    Visitante

    Padrão DUAL BOOT - WINXP e Linux

    Q boot loader vc ta usando??



  3. #3
    Visitante

    Padrão DUAL BOOT - WINXP e Linux

    Desculpe a minha igonorancia, mas como vejo isso?
    Estou usando o Windows XP Pro.

    Obrigado
    Augusto Y.

  4. #4
    dB
    Visitante

    Padrão DUAL BOOT - WINXP e Linux

    Caro Augusto

    Quando vc instala o linux ele normalmente instala o boot loader Lilo ou Grub (particularmente prefiro o lilo), sendo assim deixando Dual boot...

    http://www.linuxit.com.br/modules.ph...icle&artid=199

    De uma olhada neste artigo pode ser o q vc ta querendo...

    Qualquer coisa grita ae!!



  5. #5
    Visitante

    Padrão DUAL BOOT - WINXP e Linux

    Opa,
    Instalei no super block no LILO e fiz exatamente o que foi descrito no link abaixo, a unica diferenca que o arquivo boot.ini estava em outro caminho (C:\windows\pss\boot.ini.backup) mas mesmo assim nao esta apresentado o menu do boot loader do win xp.

    http://www.linuxit.com.br/modules.ph...icle&artid=199


    Agradeco a paciencia.
    Augusto Y.

  6. #6
    Visitante

    Padrão DUAL BOOT - WINXP e Linux

    Mais precisamente segui o tutorial abaixo, porem ainda nao tive exito.

    http://brlinux.linuxsecurity.com.br/...as_ntlinux.htm


    Tks
    Augusto Y.



  7. #7
    garupeiro
    Visitante

    Padrão DUAL BOOT - WINXP e Linux

    Caro amigo vc nao precisa seta nada nao apenas no grub.conf ou no lilo.conf as configurações do boot mas quando vc isntala o linux isto ja vem definido, o q da pra vc faze e aperfeiçoa a seu gosto apenas isso!!!!!

  8. #8
    Visitante

    Padrão DUAL BOOT - WINXP e Linux

    Se eu utilizasse o GRUB em lugar do LILO, serao necessarios algumas configuracoes adicionais ou ele ja detectara meu Win XP (NTFS)?


    [ ]´s
    Augusto Yamazaki



  9. #9
    dB
    Visitante

    Padrão DUAL BOOT - WINXP e Linux

    Citação Postado originalmente por Anonymous
    Mais precisamente segui o tutorial abaixo, porem ainda nao tive exito.

    http://brlinux.linuxsecurity.com.br/...as_ntlinux.htm


    Tks
    Augusto Y.

    Vc consegue entrar em algum Sistema Operacional??

    Siga este artigo, http://www.linuxit.com.br/section-viewarticle-281.html , ele te da os passos de configuração/instalação do lilo...

    Qualquer coisa tamo na escuta!! :lol:

  10. #10
    Visitante

    Padrão DUAL BOOT - WINXP e Linux

    Opa,
    Instalei o LILO no super block, o mesmo nao eh carregado no boot. Pelo pouco que conheco, somente seria visto caso tivesse instalado no MBR, que nao eh o caso.
    Como disse, o tutorial abaixo eh de extrema ajuda porem nao estou usando o LILO na MBR mas sim pretendo utilizar o Boot Loader do Windows XP.


    Agradeco muito pela ajuda mas ainda nao tive exito.
    Augusto Y.



  11. #11
    Visitante

    Padrão DUAL BOOT - WINXP e Linux

    Respondendo a pergunta, acesso normalmente o Windows XP (NTFS).


    [ ]´s
    Augusto Y.

  12. #12
    Super_Diaulas
    Visitante

    Padrão DUAL BOOT - WINXP e Linux

    bom........sem ser chato...mas v6 estão viajando.....
    eu utilizo isso em casa.....é ótimo...funciona sempre
    já coloquei com windows 200o pro e o server.....acredito que para o xp seja igual

    no começo tive algumas dificuldades...mas peguei a manha



    3) dd if=/dev/hda2 of=/mnt/bootsect.lnx bs=512 count=1 (possuo uma particao FAT32 em /dev/hda2)

    acho que foi esse um erro...o passo 3 no slackware 9.......
    pule esse comando...pelo que entendi...vc criou o arquivo certo.....e depois sobreescreveu ele com o boot do winxp, ou seja, deixou tudo igual
    só use esse comando para a partição linux que tenha o boot.
    El será feito somente uma vez.

    um segundo erro eu acho......normalmente o boot.ini fica no c:
    ele já tem as entradas do winxp.....apenas adicione o linux

    o terceiro erro é pq.........vc deve ter alterado somente no boot.ini.backup
    o boot.ini original tem que ser modificado..............
    resumo......crie o backup com a cópia do orginal...e altere o original


    Uma outra dica........deixe o arquivo .lnx como somente leitura
    não sei se é pq quando passa o desfragmentador ou qualquer outra coisa
    o arquivo corrompe......quando fiz isso nunca mais tive problemas

    Quanto ao attrib se eu não me engano tens que botar a opção -h e +h
    pq senão dá um errp quando vai carregar o slack.....acho que a msg era faltando o arquivo netskernel........... alguma coisa assim
    Qualquer problema posta aí....se puder eu te ajudo