Página 3 de 3 PrimeiroPrimeiro 123
+ Responder ao Tópico



  1. #11
    Super_Diaulas
    bom.....a minha idéia era botar as duas opções já citadas.......
    depois posta aí os resultados!

  2. #12
    gmlinux
    Citação Postado originalmente por gmlinux
    olha as opcões de uid, gid, fmask e dmask do fat no manual do mount:
    http://www.die.net/doc/linux/man/man8/mount.8.html
    Galera, o Linux possui uma camada chamada VFS que permite as aplicações lidarem com os sietamas de arquivos, sejam quais forem, de uma (quase) mesma maneira.
    No caso da fat, ela não possui diversos elementos de um sistema de arquivo *nix, como dono, grupo, e permissões, desta forma, o VFS assume valores default.
    As opções indicadas em meu post anterior, permitem alterar estes valores padrões, assim, do man:

    uid=value and gid=value
    Set the owner and group of all files. (Default: the uid and gid of the current process.)
    umask=value
    Set the umask (the bitmask of the permissions that are not present). The default is the umask of the current process. The value is given in octal.
    dmask=value
    Set the umask applied to directories only. The default is the umask of the current process. The value is given in octal. Present since 2.5.43.
    fmask=value
    Set the umask applied to regular files only. The default is the umask of the current process. The value is given in octal. Present since 2.5.43.

    estas opções podem ser passadas na linha de comando (mount -o ) ou no campo do fstab reservado a isto.
    Observe que em uma fat não é possível ter arquivos com donos diferentes, etc., por isto é quase da mesma maneira



  3. #13
    andkaiser
    Citação Postado originalmente por Super_Diaulas
    bom.....a minha idéia era botar as duas opções já citadas.......
    depois posta aí os resultados!
    Seguindo as dicas do pessoal por aqui, usei os comandos: gid e umask. Coloquei no fstab e configurei da seguinte forma:

    /dev/hda1 /fatc vfat auto,gid=users,umask=002 0 0

    Depois disso reiniciei e a partição veio montada com as seguintes permissões: drwxrwxr-x
    Como para "outros" eu não preciso que tenha permissão de escrita, da forma que foi montada está muito bom. Testei com todos usuários cadastrados em minha máquina e todos conseguiram acessar os dados sem problemas.
    Valeu pela ajuda.






Tópicos Similares

  1. Continua o problema com rota
    Por redoctober no fórum Servidores de Rede
    Respostas: 13
    Último Post: 08-11-2002, 13:04
  2. Problema com os log do Apache
    Por Good_speed no fórum Servidores de Rede
    Respostas: 1
    Último Post: 28-10-2002, 08:51
  3. Problemas com Perl
    Por adcorp no fórum Servidores de Rede
    Respostas: 1
    Último Post: 17-08-2002, 11:52
  4. Problema com o ssh pelo windows !!!
    Por embbr no fórum Servidores de Rede
    Respostas: 1
    Último Post: 01-07-2002, 18:10
  5. problemas com o IMP
    Por marlonfuchs no fórum Servidores de Rede
    Respostas: 0
    Último Post: 27-06-2002, 08:13

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L