Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1
    grilo
    Visitante

    Padrão ifconfig

    bom galera nao se c é o lugar certo pra postar mas la vai..

    instalei o debian 3.0, (kernel 2.2).
    instalei a placa de rede rtl8139
    fiz o seguinte:
    modprobe rtl8139
    update-modules

    dai fui configurar
    ifconfig eth0 10.48.0.8 netmask 255.255.255.0 up
    dai deu esse erro:
    SIOCSIFFLAGS: Resource temporaly unavailable

    lodo dou ifconfig pra ver o status e me aparece

    lo link encap: Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    ........................

    SL0 link encap:Serial Line IP
    inet addr:192.168.0.1 Mask:255.255.255.255
    ........................


    entao dai nao aparece nada na eth0
    mas qd dou ifconfig eth0 aparece:

    eth0 link encap: Ethernet HWaddr 00:E0:7D:9A:45:84
    inet addr:10.48.0.9 Bcast: 10.48.0.255 Mask:255.255.255.0
    ........................




    entao eu nao tou conseguindo configurar essa minha rede...
    alguem pode me ajudar :?:

  2. #2

    Padrão ifconfig

    Rapá kernel default do debian sempre me dava uns traumas com a SiS900, no 2.2 (default) funciona legal, mas no 2.4 (bf24) nao funcionava de jeito nenhum, tente o seguinte:

    recompile um kernel com suporte a sua placa, e veja se funciona, reoslveu para mim.



  3. #3
    grilo
    Visitante

    Padrão ifconfig

    Citação Postado originalmente por mistymst
    Rapá kernel default do debian sempre me dava uns traumas com a SiS900, no 2.2 (default) funciona legal, mas no 2.4 (bf24) nao funcionava de jeito nenhum, tente o seguinte:

    recompile um kernel com suporte a sua placa, e veja se funciona, reoslveu para mim.

    o bf24 é no no rc3 ?
    eu tenho apenas o rc1 vou baixar em um cd o kernel e recompila ele

  4. #4

    Padrão ifconfig

    E cara, sou da mesma opinião do mist, tive problemas com placas de rede em várias distro... inclusive esta rtl não funcionou com o kernel bf2.4



  5. #5
    grilo
    Visitante

    Padrão ifconfig

    Citação Postado originalmente por vonlinkerstain
    E cara, sou da mesma opinião do mist, tive problemas com placas de rede em várias distro... inclusive esta rtl não funcionou com o kernel bf2.4
    Pois é kra. mas eu tou é com o kernel 2.2 mas vou tentar compilar ele pra 2.4 e ve o q da...

  6. #6
    philosophus
    Visitante

    Padrão ifconfig

    Sugiro que vc liste os módulos carregados

    #lsmod

    Posso estar equivocado mas o módulo da Realtek não é o 8139too?

    #insmod 8139too

    #lsmod

    Se o módulo aparecer então tente configurar a rede.

    #ifconfig eth0 seu_ip broadcast seu_broadcast netmask sua_netmask up

    Acho que é isso. Se isso não funcionar ... compile um novo kernel. Mas a última versão já é a 2.6.9 ...

    Boa sorte



  7. #7
    grilo
    Visitante

    Padrão ifconfig

    Bom galera eu baixei o debian 3.0r3 dai eu instalei ele com o boot:bf24


    bom oks.. bom ele nao tem o modulo para rtl8139too.o, dai eu baixei do site da realtek e acontece o seguinte:
    contem o arquivo Makefile e 8139too.c

    #./Makefile o bash retorna o erro:

    ./Makefile: line 13: NEW_INCLUDE_PATH: command not found
    ./Makefile: line 19: MODCFLAGS: command not found
    ./Makefile: line 23: all:: command not found
    ./Makefile: line 25: 8139too:: command not found
    ./Makefile: line 1: CC: command not found
    ./Makefile: line 1: MODCFLAGS: command not found
    ./Makefile: line 1: NEW_INCLUDE_PATH: command not found
    ./Makefile: line 26: -I: command not found
    ./Makefile: line 28: .: filename argument required
    .: usage: . filename

    abaixo esta o readme que veio com o arquivo

    8139too.c release note
    2001/10/31 by ShuChen Shao

    1.This driver was originally based on 8139too.c version "0.9.15".

    2.It has been enhanced to support RTL8139C+ PCI ethernet controller.

    3.RTL8139C+ PCI ethernet chips is set to support C+ mode by default.
    If FORCE_C_Mode below is enabled, the RTL8139C+ chip will be forced to support C mode
    after reboot.


    4.This program can be compiled using the attached Makefile.
    Please remember to SPECIFY "NEW_INCLUDE_PATH" in Makefile according to your linux environment.
    The object file named 8139too.o should be moved to the directory
    /lib/modules/<linux-version>/kernel/drivers/net/
    The driver could be brought up by the following steps:
    'insmod 8139too'
    'ifconfig eth0 up'

    5.It can support Auto-Negotiation ability,that is
    10-half 0x01
    10-full 0x02
    100-half 0x04
    100-full 0x08
    If 10-half mode is expected, it can be achieved by the following steps:
    #ifconfig eth0 down
    #rmmod 8139too
    #insmod 8139too media=0x01

    6.If the "Install Type", selected during the Linux install procedure, is "laptop",
    this driver can work normally for CardBus application without any modification.
    Otherwise, reinstall Linux and select "Install Type" as "laptop".
    Then this driver can also work.


    bom se alguem poder me da uma ajuda pra configurar esta plca eu agradeço



    valeus....

  8. #8
    Visitante

    Padrão ifconfig

    nesse dir digite
    # make
    # mv 8139too.o /lib/modules/<linux-version>/kernel/drivers/net/
    # modprobe 8139too



  9. #9
    grilo
    Visitante

    Padrão ifconfig

    Citação Postado originalmente por Anonymous
    nesse dir digite
    # make
    # mv 8139too.o /lib/modules/<linux-version>/kernel/drivers/net/
    # modprobe 8139too
    fiz o q me disse:

    net254:/home/net254# make
    Makefile:28: *** missing separator. Stop.


    deu isto...
    meu arquivo ta defeituoso?
    ou o q?
    valeus

  10. #10

    Padrão ifconfig

    Realtek 8139 já vem compilada junto com o Kernel bf24. Nunca tive problema ALGUM configurando essa placa. Para certificar-se que sua placa foi reconhecida, rode um:

    Código :
    # dmesg |grep eth

    Também nunca tive zica com sis900...



  11. #11
    Visitante

    Padrão ifconfig

    cara acho que o 1 erro só fazendo ifconfig eth0 up resolvia
    tente
    ifconfig eth0 up
    ifconfig eth0 ip netmask
    route add default gw seu-gw

  12. #12
    grilo
    Visitante

    Padrão ifconfig

    xstefanox fiz o q me disse

    rodei :
    # dmesg |grep eth
    eth0: Realtek RTL8201 PHY tranceiver found at address 1.
    eth0: Using transceiver found at address 1 as default
    eth0: SiS 900 PCI Fast Ethernet at 0x9800, IRQ 0, 00:0c:6e:4c:9d:c5.
    eth1: Realtek RTL8139 Fast Ethernet at 0xd081a000, 00:e0:7d:9a:45:84, IRQ 0
    eth1: Identified 8139 chip type 'RTL-8139C'

    dai eu tentei :
    ifconfig eth0 10.48.0.5 broadcast 10.48.0.255 netmask 255.255.255.0 up
    dai retorna um erro:
    SIOCSIFFLAGS: Device or resource busy

    a mesma coisa qd tento com o eth1.. oq pode ser isto ?

    valeus...



  13. #13

    Padrão ifconfig

    É, ele reconheceu as tuas placas. Dá uma olhada se os módulos necessários estão levantados (eu acho que o da sis900 ele reconhece por módulo) com o lsmod. Altere as configurações da sua placa de rede no seu /etc/network/interfaces e reinicia o serviço.


    Abraços.

  14. #14
    grilo
    Visitante

    Padrão ifconfig

    Citação Postado originalmente por xstefanox
    É, ele reconheceu as tuas placas. Dá uma olhada se os módulos necessários estão levantados (eu acho que o da sis900 ele reconhece por módulo) com o lsmod. Altere as configurações da sua placa de rede no seu /etc/network/interfaces e reinicia o serviço.


    Abraços.
    dei uma olhada nos modulos e a placa rtl8139 nao ta carregada:

    lsmod

    apm
    keybdev
    usbkbd
    input
    usb-ohci
    usbcore


    Se eu nao tou enganado pra carregar um modulo e modprobe, eu tentei dar modprobe rtl8139 e nao foi possivel carregar este modulo..
    Se dou dmesg eu vejo q a placa realtek esta reconhecida mas nao consigo levantar os modulos cestos..
    xstefanox tem outra dica?
    valeu kra.



  15. #15
    Visitante

    Padrão ifconfig

    cara vc tem duas placas de rede ?
    se sim desabilita essa sis no setup , se ela for on-board e tente denovo.

    depois tente ifconfig eth0 down
    ifconfig eth0 up
    ifconfig eth0 ip mask

  16. #16
    Visitante

    Padrão ifconfig

    pq se vc perceber elas estao com conflito de irq
    eth0: SiS 900 PCI Fast Ethernet at 0x9800, IRQ 0, 00:0c:6e:4c:9d:c5.
    eth1: Realtek RTL8139 Fast Ethernet at 0xd081a000, 00:e0:7d:9a:45:84, IRQ 0
    dÊ um cat /proc/interrupts
    e veja em qual irq elas estao , estranho estar pegando na irq 0 mas td bem.



  17. #17
    grilo
    Visitante

    Padrão ifconfig

    Citação Postado originalmente por Anonymous
    cara vc tem duas placas de rede ?
    se sim desabilita essa sis no setup , se ela for on-board e tente denovo.

    depois tente ifconfig eth0 down
    ifconfig eth0 up
    ifconfig eth0 ip mask
    certo eu desabilitei a sis e deixei a realtek

    fiz o q disse:
    ifconfig eth0 down
    ifconfig eth0 up
    dai deu a seguinte msg:
    SIOCSIFFLAGS: Device or resource

    essa msg é o q ?
    eu dou ifconfig e a eth0 nao aparece
    valews

  18. #18
    garupeiro
    Visitante

    Padrão ifconfig

    O seu ip esta errado para essa mascara de rede

    IP = 10.48.0.8
    Mask = 126.255.255.255

    O seu outro problema a galera ja resolveu!!!!![/quote]



  19. #19

  20. #20
    Visitante

    Padrão ifconfig

    cara desabilitana bios do computador a opção pnp(plug&play)
    e poste os resultados