+ Responder ao Tópico



  1. #1
    Ivoregis
    Visitante

    Padrão Winxp com Samba. Não consigo de jeito nenhum...

    Olá

    Tenho uma rede com Samba e estações Win98.
    Só que estou mudando as estações para Winxp. Mas tô apanhando na hora de configurar o winxp no Samba.
    Pesquisei um monte. Segui os seguintes passos:

    Criei um grupo para as máquinas XP
    # groupadd clientesxp

    depois cadastrei as máquinas no linux
    # useradd -d /dev/null -s /dev/null -g clientesxp máquinaxp$

    cadastrei no samba
    # smbpasswd -am maquinaxp$

    cadastrei o root como usuário do samba:
    # smbpasswd -a root

    O meu smb.conf possui a linha
    [Global]
    Workgroup = AlconLinux

    -------
    Autenticação do Windows XP no Samba:

    Editei a seguinte linha no Regedit:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters\requiresignorseal
    mudei o valor para 0

    Alterei o computador para:
    Nome completo do computador: maquinaxp #cadastrado no Samba.
    grupo de trabalho: clientesxp #cadastrado no Samba.

    Cliquei em painel de controle e depois em sistema;
    Cliquei em Nome do Computador;
    Cliquei em ID da rede.
    Cliquei em avançar, selecione a opção "Este computador faz parte de uma rede corporativa ...";
    Cliquei em avançar, "Minha empresa usa uma rede com um domínio";
    Cliquei em avançar 2 x;
    No campo nome do usuário digitei um usuário cadastrado no Samba, digitei a senha e o domínio ALCONLINUX;
    Cliquei em avançar, digitei o nome do meu computador maquinaxp (que foi cadastrado no samba sem o $) e o domínio da rede novamente ALCONLINUX;

    Cliquei em avançar e apareceu a seguinte msg:
    "Não pôde ser contatado um controlador de dominio para o domínio ALCONLINUX.
    Certifique-se de que o nome de domínio foi digitado corretamente."

    Alguém pode me dizer o que está errado?

  2. #2
    whinston
    Visitante

    Padrão tutorial

    No XP é foda mesmo, rs.. Eu apanhei pra kct!!! Tive que ficar testando num servidor em produção, oq eh pior.. Pq chegaram várias estações XP e tive que por na rede, não deu pra montar ambiente de teste.
    Seus procedimentos tão bem parecidos com os meus, segue abaixo:


    - Diretórios de configuração: mkdir /home/profilesNT; /home/profiles; /home/netlogon

    - Máquinas XP/W2K/NT devem ser cadastradas:

    - groupadd pcs;

    - useradd -g pcs -d /dev/null -s /bin/false nomedopc$;

    - passwd -l nomedopc$;

    - /usr/local/samba/bin/smbpasswd -a -m nomedopc;

    - Forçando o cadastro manualmente da máquina com:

    - useradd -d /dev/null -s /bin/false usuario;

    - passwd -l usuario;

    - /usr/local/samba/bin/smbpasswd -a usuarios;

    - É necessário cadastrar a senha do root no samba com: /usr/local/samba/bin/smbpasswd -a root

    - Executar o .reg WinXP_SignOrSeal.reg

    - smb.conf: www.europanet.com.br/pcmaster/edicao85



  3. #3
    Visitante

    Padrão Winxp com Samba. Não consigo de jeito nenhum...

    Agradeço a atenção whinston.
    Mas, mexi na configuração do Samba e consegui fazer a conexão. 8) Inclui 4 linhas:
    domain logons = yes
    preferred master = yes
    domain master = yes
    local master = yes

    []'s

  4. #4
    Super_Diaulas
    Visitante

    Padrão Winxp com Samba. Não consigo de jeito nenhum...

    buenas!
    o que vcs fizeram eu fiz tb!
    porém eu quero uma coisa mais
    usuário da rede puxando profiles!
    iso eu não consegui....só consegui com usuário local.........cadastrado na máquina
    com usuário da rede ele dá um erro dizendo que não achou o path para profile.............

    acredito que seja algum script para inicializar. mas eunão tenho....



  5. #5

    Padrão Winxp com Samba. Não consigo de jeito nenhum...

    Citação Postado originalmente por Super_Diaulas
    buenas!
    o que vcs fizeram eu fiz tb!
    porém eu quero uma coisa mais
    usuário da rede puxando profiles!
    iso eu não consegui....só consegui com usuário local.........cadastrado na máquina
    com usuário da rede ele dá um erro dizendo que não achou o path para profile.............

    acredito que seja algum script para inicializar. mas eunão tenho....
    Cara, eu acho que para máquinas com o Kernel baseado em NT, você tem que trocar o [profiles] por [profilesNT].


    Abraços.

  6. #6
    Super_Diaulas
    Visitante

    Padrão Winxp com Samba. Não consigo de jeito nenhum...

    ow!!!!!!!!!!!!!!!

    ainda não botei para funcionar...mas é isso mesmo!
    pesquisei no oráculo (google), e achei informações adicionais

    caso alguém queira ler tb aí vai o link.

    http://www.dimap.ufrn.br/~aguiar/Foc...h-s-samba.html