Página 1 de 4 1234 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1
    silmar
    Eu tinha um link só no servidor de internet e funcionava as regras do bloqueio do MSN, mas agora por ter colocado mais um link

    não esta mais funcionando..
    meu linux e red hat 9.0

    e aee esta as regras se alguem ja teve esse mesmo problema e puder me ajudar fico grato

    #!/bin/sh
    IF_LAN='eth0'
    IF_ADSL2='eth2'
    GW_ADSL2='200.xxx.xxx.xx2'
    /sbin/iptables -F INPUT
    /sbin/iptables -F FORWARD
    /sbin/iptables -P INPUT DROP
    /sbin/iptables -P FORWARD DROP
    /sbin/iptables -t nat -F
    /sbin/iptables -t mangle -F

    /sbin/iptables -A INPUT -m state --state RELATED,ESTABLISHED -j ACCEPT
    /sbin/iptables -A INPUT -s 192.168.0.0/24 -j ACCEPT
    /sbin/iptables -A INPUT -p tcp --dport 22 -j ACCEPT
    /sbin/iptables -A FORWARD -m state --state RELATED,ESTABLISHED -j ACCEPT
    /sbin/iptables -A FORWARD -s 192.168.0.0/24 -j ACCEPT

    route add default gw 200.xxx.xxx.xxx
    route add default gw 200.xxx.xxx.xx2

    iptables -t mangle -A PREROUTING -i $IF_LAN -p tcp --dport 80 -j MARK --set-mark 2
    iptables -t mangle -A PREROUTING -i $IF_LAN -p tcp --dport 443 -j MARK --set-mark 2
    iptables -t mangle -A PREROUTING -i $IF_LAN -p tcp --dport 8080 -j MARK --set-mark 2
    iptables -t mangle -A OUTPUT -p tcp --dport 80 -j MARK --set-mark 2
    iptables -t mangle -A OUTPUT -p tcp --dport 443 -j MARK --set-mark 2
    iptables -t mangle -A OUTPUT -p tcp --dport 8080 -j MARK --set-mark 2
    ip rule add fwmark 2 table 30 prio 30
    ip route add default via 200.xxx.xxx.xx2 dev $IF_ADSL2 table 30

    CHATPORT="1863,5190"
    /sbin/iptables -I INPUT -p tcp -m multiport --dport ${CHATPORT} -j DROP
    /sbin/iptables -A FORWARD -p tcp -m multiport --dport ${CHATPORT} -j DROP
    /sbin/iptables -A FORWARD -p tcp -s 192.168.0.0/24 -d 207.46.110.0/24 -j DROP
    /sbin/iptables -A FORWARD -p tcp -s 192.168.7.0/24 -d 207.46.104.0/24 -j DROP
    /sbin/iptables -A FORWARD -p tcp -s 192.168.7.0/24 -d 64.4.13.0/24 -j DROP
    /sbin/iptables -A FORWARD -p tcp --dport 1863 -j REJECT --reject-with tcp-reset
    /sbin/iptables -t mangle -A PREROUTING -p tcp --dport 1863 -j DROP
    /sbin/iptables -t mangle -A PREROUTING -d 63.208.13.126 -j DROP
    /sbin/iptables -t mangle -A PREROUTING -d 64.4.12.200 -j DROP
    /sbin/iptables -t mangle -A PREROUTING -d 64.4.12.201 -j DROP
    /sbin/iptables -t mangle -A PREROUTING -d 65.54.131.249 -j DROP
    /sbin/iptables -t mangle -A PREROUTING -d 65.54.194.118 -j DROP
    /sbin/iptables -t mangle -A PREROUTING -d 65.54.211.61 -j DROP
    /sbin/iptables -t mangle -A PREROUTING -d 207.46.104.20 -j DROP
    /sbin/iptables -t mangle -A PREROUTING -d 207.46.110.2 -j DROP
    /sbin/iptables -A FORWARD -d 64.4.13.0/24 -j REJECT
    /sbin/iptables -t nat -A POSTROUTING -j MASQUERADE

    /sbin/modprobe ip_nat_ftp
    /sbin/modprobe ip_conntrack_ftp

    ip route flush cache

    .. aee esta ele .. sempre funcionou .. quando era apenas um link mas agora por estar dois links não bloqueia mais

  2. explica melhor, que eu n to entendendo, que link eh esse que vc ta falando?



  3. #3
    silmar
    Bom antes eu tinha apenas um speedy bussines.
    E tinha essas regras que bloqueava o uso e acesso ao msn.
    Agora houve uma necessidade de ter mais um link porem na
    mesma maquina e ao colocar esse link(speed bussines) deixou de funcionar essas regras.
    Do resto esta tudo funcionando normal
    acesso de ssh
    saida pelas duas placas

    pode entender ?

  4. cara vc usa redhat e n usa RH-Lokkit?

    bom, bora tenta resolver teu pro, vc agora ta com 2 ip fixo?
    vc tem quantas interfaces na sua maquina?
    qual interface vc ta usando pra compartilha a internet?
    a interface local eh eth0?

    responde isso que posso te ajudar



  5. #5
    silmar
    isso mesmo ..a interface local é eth0
    meu eu nunca usei esse RH-Lokkit..






Tópicos Similares

  1. convite de video do msn nao funciona
    Por tamanho no fórum Redes
    Respostas: 4
    Último Post: 15-05-2012, 07:05
  2. Respostas: 7
    Último Post: 17-03-2010, 10:17
  3. WebCam do MSN não funciona no Mikrotik
    Por cliforsouza no fórum Redes
    Respostas: 11
    Último Post: 13-05-2009, 22:29
  4. Bloqueio do MSN não está 100%
    Por luizhumberto no fórum Servidores de Rede
    Respostas: 21
    Último Post: 09-12-2005, 23:04
  5. O bloqueio do MSN
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 15-01-2003, 12:05

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L