Consegui instalar o courier-imap com o suporte ao mysql.

Só que agora quando vou iniciar o pop3d, ele da erro de AUTHFAILURE.