+ Responder ao Tópico



  1. #1
    mrpicolo
    Visitante

    Padrão Problemas com a Rede

    Ao iniciar a máquina com linux, ele carrega as duas placas de rede. Coloco o cabo de rede na Eth0 e funciona normal na rede, mas quando troco para a Eth1, não funciona nada, não pinga e nem entra na rede, mas se eu der um ifdown Eth0 a Eth1 começa a funcionar, entrando na rede e pingando... As placas são uma VIA e uma Realteck e uso os ips 192.168.143.200 para Eth0 e 192.168.143.201 para Eth1. Estou usando o Conectiva 10. Se alguem poder me ajudar eu agradeço...

  2. #2
    gl
    Visitante

    Padrão Problemas com a Rede

    vc está com problema de rota sabe ?

    para adicionar uma rota --->>>
    route add default eth0
    route add default gw 200.166.223.155
    Onde 200.166.223.155 e o IP de seu gateway ou roteador.

    para excluir uma rota

    route del default
    route del default

    para listar as rotas use apenas route



  3. #3
    mrpicolo1
    Visitante

    Padrão Problemas com a Rede

    pode ser, a minha eth0 é a saida pra minha rede interna com ip 192.168.143.200 e a eth1 é a saída pra internet com ip 192.168.143.2001

  4. #4
    Visitante

    Padrão Problemas com a Rede

    Citação Postado originalmente por mrpicolo1
    pode ser, a minha eth0 é a saida pra minha rede interna com ip 192.168.143.200 e a eth1 é a saída pra internet com ip 192.168.143.2001
    justamente... dois ips da mesma rede. vc só vai conseguir acessar a rede por um ip desses de cada vez.
    ex: se vc dá um ping pra qq outra máquina dessa rede (digamos 192.168.143.1), os pacotes do ping irão sair da sua máquina por uma rota (veja com o comando route). Pra vc usar a outra placa terá de mudar a rota.

    Geralmente se coloca duas placas de rede em uma máquina para que ela se conecte a duas redes com IPs diferentes... e se for no mesmo meio físico nem precisa de duas placas, vc pode colocar mais de um IP na mesma (eth0, eth0:1, etc.)



  5. #5
    mrpicolo1
    Visitante

    Padrão Problemas com a Rede

    e o que fazer então? trocar o ip da placa com entrada de internet para outro como 192.168.0.1? e outra vou fazer uma vpn, tenho que usar o ip da placa (no caso se eu alterar 192.168.0.1) ou uso o ip q o servidor terra me dar 200.....? valeu pelas respostas....

  6. #6
    APS
    Visitante

    Padrão Problemas com a Rede

    Cara,

    Acho que vc tem um conflito de endereçamento fisico (irq, i/o). Dê uma olhada nos arquivos pci,interrupts e ioports no /proc e veja se as duas placas de rede não estão utilizando o mesmo irq. Tente também trocá-las de slot.
    Espero ter ajudado.

    [],



  7. #7

    Padrão Problemas com a Rede

    As duas placas com o endereço na mesma rede só funciona se o linux estiver rodando em modo bridge.

    A nao ser que vc esteja apenas exemplificando, seu IP NAO PODE SER DE FORMA ALGUMA 192.168.143.2001, sendo que cada octeto vai apenas até 255