+ Responder ao Tópico



  1. #1
    Alexandre_Catanduva
    Visitante

    Padrão Tempo Esgotado - Fapesp

    Boa tarde pessoal.

    To tentando configurar meu dominio na fapesp mas está dando "Tempo Esgotado" quando faço o teste de DNS (http://registro.br/cgi-bin/nicbr/dnscheck).

    O meu dominio hoje está configurado no servidor de um colega meu... mas como já montei minha rede (firewall + servidor dns/web) gostaria de passar o master para o meu servidor e deixar o secundário como está, ou seja, no servidor do meu colega.

    O "tempo esgotado" pode ser falha na minha configuração do bind ? Ou será meu firewall que não está permitindo a que requisição chegue ao servidor DNS ??

  2. #2
    Alexandre_Catanduva
    Visitante

    Padrão Tempo Esgotado - Fapesp

    Detalhe: Executei de uma das estações o comando nslookup, vejam o resultado.

    ---------------------------------- Inicio ---------------------------------------
    C:\>nslookup 192.168.1.1
    DNS request timed out.
    timeout was 2 seconds.
    *** Não é possível encontrar o nome de servidor para o endereço 200.204.0.138: T
    imed out
    *** Os servidores padrão não estão disponíveis
    Servidor: UnKnown
    Address: 200.204.0.138

    *** UnKnown não é possível encontrar 192.168.1.1: Non-existent domain
    --------------------------------------- Fim ---------------------------------------

    Obs:
    1) As estações rodam Windows XP Profissional
    2) 200.204.0.138 é o DNS que coloquei nas estações (é do terra).



  3. #3

    Padrão Tempo Esgotado - Fapesp

    O firewall tem de permitir qq requisiçao tanto udp quanto tcp de qq lugar na porta 53, apos feito isso tenta de novo na fapesp, se nao der certo posta seu named.conf ae.

    falows

  4. #4
    Alexandre_Catanduva
    Visitante

    Padrão Tempo Esgotado - Fapesp

    Opa, e ai Ruy, blz ?

    Meu firewall ta assim:
    ------------------------------------------------------------------------------------
    iptables -t nat -A PREROUTING -p tcp -d 200.x.x.x --dport 80 -j DNAT --to 192.168.1.1:80
    iptables -t nat -A PREROUTING -p tcp -d 200.x.x.x --dport 53 -j DNAT --to 192.168.1.1:53
    iptables -t nat -A PREROUTING -p udp -d 200.x.x.x --dport 53 -j DNAT --to 192.168.1.1:53

    iptables -t nat -A POSTROUTING -p tcp -s 192.168.1.1 --sport 80 -j SNAT --to 200.x.x.x
    iptables -t nat -A POSTROUTING -p tcp -s 192.168.1.1 --sport 53 -j SNAT --to 200.x.x.x
    iptables -t nat -A POSTROUTING -p tcp -s 192.168.1.1 --sport 53 -j SNAT --to 200.x.x.x
    -------------------------------------------------------------------------------------
    Foi isso que você se refiriu ???

    Meu named.conf

    ----------------------------- Inicio named.conf ----------------------------------
    // generated by named-bootconf.pl

    options {
    directory "/var/named";
    /*
    * If there is a firewall between you and nameservers you want
    * to talk to, you might need to uncomment the query-source
    * directive below. Previous versions of BIND always asked
    * questions using port 53, but BIND 8.1 uses an unprivileged
    * port by default.
    */
    // query-source address * port 53;
    dump-file "/var/named/dump/named_dump.db";
    statistics-file "/var/named/dump/named.stats";
    memstatistics-file "/var/named/dump/named.memstats";
    // remove this next line if you want named to listen on
    // all available interfaces, or adjust add new ones as
    // you see fit
    listen-on { 127.0.0.1;192.168.1.1;200.x.x.x; };

    };

    controls {
    inet * port 953 allow { 127.0.0.1; }; //Para usar o rndc apenas em localhos
    t
    };

    //
    // a caching only nameserver config
    //
    zone "." IN {
    type hint;
    file "named.ca";
    };

    zone "0.0.127.in-addr.arpa" {
    type master;
    file "named.local";
    };

    zone "localhost" {
    type master;
    file "localhost.zone";
    };

    zone "x.x.x.200.in-addr.arpa" IN {
    type master;
    file "dominio.rev";
    };

    zone "1.168.192.in-addr.arpa" IN {
    type master;
    file "local.rev";
    };

    zone "kardecbooks.com.br" IN {
    type master;
    file "kardecbooks.zone";
    };

    zone "espiritanet.com.br" IN {
    type master;
    file "espiritanet.zone";
    };
    ----------------------------- Fim named.conf ------------------------------------

    Inclusive o slave vai ser no servidor de um colega meu ou então no twisted4life, eu já até configurei o secundário lá.



  5. #5

    Padrão Tempo Esgotado - Fapesp

    cara faz o seguinte de um computador na internet da um telnet no seu ip na porta 53, se funcionar tenta dar um nslookup usando o ip do seu servidor, se nao funciona o primeiro provavelmente eh problema no seu firewall se o serviço tiver rodando ok.

    falows

  6. #6
    rafaelmr77
    Visitante

    Padrão Tempo Esgotado - Fapesp

    Como estão as regras de INPUT e FORWARD ?
    O firewall pode estar barrando os pacotes.

    Outra coisa:
    Sem esses domínios apenas com named.conf padrão para servidor DNS. Ele consegue funcionar como servidor DNS de sua intranet?

    Rafael



  7. #7
    Alexandre_Catanduva
    Visitante

    Padrão Tempo Esgotado - Fapesp

    Ruy, o telnet não funciona no ip fixo... só no ip interno 192.168.1.1 .. ou seja da estação direto para o servidor dns
    Passando pelo firewall trava .. o problema deve ser lá mesmo.

    Rafael, postei meu firewall e todas as alterações que fiz nele no forum de Proxy/NAT/Firewall.

    Tem jeito de você dar uma olhada lá e ver o que você acha, veja se como está ta certo ou eu to errando em algum lugar.

  8. #8

    Padrão Tempo Esgotado - Fapesp

    Citação Postado originalmente por Alexandre_Catanduva
    Ruy, o telnet não funciona no ip fixo... só no ip interno 192.168.1.1 .. ou seja da estação direto para o servidor dns
    Passando pelo firewall trava .. o problema deve ser lá mesmo.

    Rafael, postei meu firewall e todas as alterações que fiz nele no forum de Proxy/NAT/Firewall.

    Tem jeito de você dar uma olhada lá e ver o que você acha, veja se como está ta certo ou eu to errando em algum lugar.
    Eh deve ser firewall mesmo.

    falows