Página 3 de 4 PrimeiroPrimeiro 1234 ÚltimoÚltimo
+ Responder ao Tópico



  1. #11
    Citação Postado originalmente por Atos
    Se vc estiver usando conectiva 10 tenho a resposta pra vc.
    Slackware 10.0

  2. Tem certeza de que está rodando o named nesta máquina?

    Para resolver nomes para a rede basta rodar ele mesmo... no slack tenta:

    /usr/sbin/named start

    Testa depois postae...



  3. #13
    Citação Postado originalmente por EduLucas
    eth0 = 10.3.46.1
    eth1 = 200.xxx.xxx.xxx

    Estou montando um servidor de internet c/ um IP valido, consegui compartilhar ele como Iptables:
    iptables -t nat -A POSTROUTING -s 10.3.46.0/24 -o eth1 -j MASQUERADE
    echo "1" >/proc/sys/net/ipv4/ip_forward

    bem a internet foi compartilhada porem nas maquinas da rede eu tenho de colocar um dns externo (200.199.252.72) para que as maquinas da rede possam resolver dns, mais gostaria que meu servidor tmb servisse DNS, ja que do servidor eu consigo resolver os endereços e navegar normalmente.

    Desde ja agradeço a atenção.



    Cara configura teu resolv.conf como está abaixo....:

    #vi /etc/resolv.conf

    search dominio.com.br
    nameserver 200.96.255.194


    i ip em questão é da Brasiltelecom...


    flw té +

  4. #14
    Atos
    Cara nem acreditei, mas resolvi esse problema, segue as instruções.

    edite o arquivos /etc/named.conf

    Vc vai ver a seguinte instrução:

    // uou see fit
    listen-on { 127.0.0.0/32; }

    vc deve alterar o 127.0.0.0/32 para any, ou seja, ficaria assim:

    // uou see fit
    listen-on { any; }

    Pronto, problema resolvido.
    Detalhe no CL 9 não precisava, por isso precisamos quebrar tanto a cabeça.



  5. #15
    Obrigado a todos pelas sugestões, dar um start no named ja resolveu parte dos meus problemas, agora consigo navegar na minha rede local usando como DNS o ip do servidor, porém não consegui acessar os dominios da minha intranet na minha rede local. acredito q devo criar uma nova zona p/ a intranet no meu named.conf, mais não sei ainda como fazer isso, por isso conto c/ a ajuda de vcs.

    meu named.conf:

    options {
    directory "/var/named";
    /*
    * If there is a firewall between you and nameservers you want
    * to talk to, you might need to uncomment the query-source
    * directive below. Previous versions of BIND always asked
    * questions using port 53, but BIND 8.1 uses an unprivileged
    * port by default.
    */
    // query-source address * port 53;
    };

    //

    // a caching only nameserver config
    //
    zone "." IN {
    type hint;
    file "caching-example/named.ca";
    };

    zone "localhost" IN {
    type master;
    file "caching-example/localhost.zone";
    allow-update { none; };
    };

    zone "0.0.127.in-addr.arpa" IN {
    type master;
    file "caching-example/named.local";
    allow-update { none; };
    };

    preciso agora fazer com q minha rede local acesse os endereços da minha intranet q são:

    192.168.10.119 hub01.webcenter.com.br
    192.168.10.116 www.webcenter.com.br
    192.168.10.117 mail.webcenter.com.br

    No servidor eu acesso os mesmo, porém tive de por essas entradas na tabela hosts (/etc/hosts), agora minha intenção é criar uma zona no named.conf p/ q esses endereços sejam acessados pela minha rede local, mais não sei c minha analogia esta correta.

    Desde ja agradeço a atenção e muito obrigado pela ajuda.






Tópicos Similares

  1. Respostas: 9
    Último Post: 21-01-2016, 19:53
  2. Respostas: 15
    Último Post: 26-07-2011, 21:47
  3. Hotspot não resolve DNS e nao redireciona
    Por JonasMT no fórum Redes
    Respostas: 8
    Último Post: 24-03-2011, 03:12
  4. dns nao resolve alguns
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 27-11-2003, 16:33
  5. DNS nao resolve 2 dominios.
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 21-11-2003, 11:58

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L