+ Responder ao Tópico



  1. #1
    sady
    Visitante

    Padrão Descobrir versão de pacotes

    galera... peguei um server novo na mão... é um Mandrake 10.1.

    preciso saber das versões do PHP, MYSql e APACHE q estão instaladas... me disseram que tinha, mas executei

    rpm -q nos 3 e me disse q não estava instalado o pacote...

    mas entrei no mysql e consegui pegar a versão....

    como devo proceder????

  2. #2

    Padrão Descobrir versão de pacotes

    se nao me engano, no mandrake vc deve usar o rpmdrake

    pode tbm dar um

    php -i q ele mostra a versao do php e do resto da galera

    e apachectl -v q ele mostra a versao do apache

    []'s



  3. #3
    sady
    Visitante

    Padrão Descobrir versão de pacotes

    valeu cara.... só q o seguinte... ou eu sou burro ou sei la...

    eu dei um php -i e ele falou q não achou o comando php....

    dai dei um apachectl extendedstatus e ele me traz a versão do apache e a versão do PHP?????? qq isso... não entendi

  4. #4

    Padrão Descobrir versão de pacotes

    tenta localizar o seu php

    find / -name 'php'

    dae, pega o caminho absoluto dele e executa o php -i

    quanto ao lance do apache... sei q eh isso nao hehehe

    mas o apachectl pode ser usado asim:

    apachectl -v ou
    apachectl -V

    []'s



  5. #5
    sady
    Visitante

    Padrão Descobrir versão de pacotes

    cara.. se eu te fala que não consigo localizar nada nesse server vc acredita? rs

    eu dou locate, dou find... ele não encontra esses comandos... esse servidorzinho ta ficando complicado....

    mas valeu pela ajuda... acho q vo baixa uma versão boa do PHP e instala independente se tenha ou não na máquina!

    []'s

  6. #6

    Padrão Descobrir versão de pacotes

    blz...

    mas eh estranho ele nao encontrar nem pelo find...

    tenta colocar assim:

    find / -name *php*

    alguma coisa deve achar ehhehe

    []'s



  7. #7
    sady
    Visitante

    Padrão Descobrir versão de pacotes

    e olha q achou....

    mas achou uns arquivos perdidos só....

    27_ldap.ini
    php.ini
    php.d


    certeza q vo te q instala tudo denovo....

    agora só me explica uma coisa... pq ele não acha com o Locate e o FIND mesmo???

  8. #8

    Padrão Descobrir versão de pacotes

    provavelmente vc nao tem o arquivo..

    pq tem q encontrar com o find... e com o locate, vc deve atualizar seu .db pra q ele encontre tdos os seus arquivos

    []'s



  9. #9
    sady
    Visitante

    Padrão Descobrir versão de pacotes

    blza valeu cara!

  10. #10

    Padrão Descobrir versão de pacotes

    disponha