Página 4 de 9 PrimeiroPrimeiro 12345678 ... ÚltimoÚltimo
+ Responder ao Tópico



  1. Na primeira pergunta deste topico vc mostrou no exemplo que vc utilizava dois subdominios.... ou seja, se vc tem subdominio tem que usar VirtualHosts, caso seja somente o dominio.com.br/Docs então não precisa....

    para usar o Proxy reverse somente pra 1 dominio, ache e comente as linhas:

    Código :
    <IfModule mod_proxy.c>
    ProxyRequests On
    ProxyDomain .zenisys.com.br
    </IfModule>

    vá ao final do httpd2.conf e adicione as linhas:

    Código :
       ProxyRequests Off
     
       <Proxy *>
          Order deny,allow
          Allow from all
        </Proxy>
     
        ProxyPass /docs/ http://192.168.0.3/
        ProxyPassReverse /docs/ http://192.168.0.3:80/
        Redirect Permanent /docs http://192.168.0.3/

    certifique-se que a maquina que ta com apache tem acesso ao IP 192.168.0.3 na intranet...

    vc usa o seu servidor web como proxy de compartilhamento de internet? caso não, muda estas linhas:

    Código :
    <IfDefine APACHEPROXIED>
        Listen 8080
    </IfDefine>
    <IfDefine !APACHEPROXIED>
        Listen 80
    </IfDefine>

    para esta:

    Código :
    Listen 80

    não sei se vc usa mais vc poderia comentar estas linhas:

    Código :
    <IfDefine PERLPROXIED>
    <IfModule mod_rewrite.c>
        RewriteEngine on
        RewriteRule ^proxy:.*  -  [F]
        RewriteRule ^(.*\/perl\/.*)$  http://%{HTTP_HOST}:8200$1 [P]
        RewriteRule ^(.*\/cgi-perl\/.*)$  http://%{HTTP_HOST}:8200$1 [P]
    </IfModule>
    </IfDefine>

  2. vc poderia por a variavel "UseCanonicalName Off" como " On" , isto faz com que uma url direcionada a uma apsta se complete.. ex: www.lala.com.br/teste -> www.lala.com.br/teste/



  3. #18
    Nossa, cara, valeu mesmo.. te dei mo transtorno ops:

    Vou fazer isso amanhã assim q chegar no trampo !!!

    Orra, valeu mesmo o help e atenção!!!

  4. pow pitsa....

    agora eh minha vez... d pedir um help com o lance do proxy...

    tenho um apache 2.0.40 rodando na porta 80 no meu server... dae, tenho um outro apache 1.3.33 rodando na porta 8000 no mesmo server...

    tenho um dominio soh...

    to aplicando as regras d proxy assim dentro do apache 2.0.40:

    Código :
    ProxyRequests Off
     
       <Proxy *>
          Order deny,allow
          Allow from all
        </Proxy>
     
        ProxyPass /test http://192.168.200.112:8000/isosystem/administration/wwwroot/
        ProxyPassReverse /test http://192.168.200.112:8000/isosystem/administration/wwwroot/
        Redirect Permanent /test http://192.168.200.112:8000/isosystem/administration/wwwroot/

    mas nao vai nem com porrada!!! kkkkkk

    eu reparei q o meu Alias criado no 1.3 parece nao funcionar... to usando ele assim:
    Código :
    Alias /administration "/usr/max/apache/htdocs/isosystem/administration/wwwroot"

    e tento acessa usando:
    Código :
    http://192.168.200.112:8000/administration

    nao vai nem a pau, dah pagina nao encontrada... e quando eu acesso via proxy... ele ateh encontra a tela d login... mas parece perder tdos os paths e talz :roll: :roll: :roll:

    pode me dar help, plz?

    []'s



  5. Citação Postado originalmente por demiurgo
    Código :
    ProxyRequests Off
     
       <Proxy *>
          Order deny,allow
          Allow from all
        </Proxy>
     
        ProxyPass /test http://192.168.200.112:8000/isosystem/administration/wwwroot/
        ProxyPassReverse /test http://192.168.200.112:8000/isosystem/administration/wwwroot/
        Redirect Permanent /test http://192.168.200.112:8000/isosystem/administration/wwwroot/
    Quer erro que da aki? o que aparece no navegador?
    ta habilitado o mod_proxy, mod_proxy_httpd?

    Citação Postado originalmente por demiurgo

    eu reparei q o meu Alias criado no 1.3 parece nao funcionar... to usando ele assim:
    Código :
    Alias /administration "/usr/max/apache/htdocs/isosystem/administration/wwwroot"

    e tento acessa usando:
    Código :
    http://192.168.200.112:8000/administration
    Pq vc não cria um link simbolico no file system do linux.....isso contornaria o problema.... ta habilitado o mod_alias? caso esta pasta não esteja dentro do diretorio publico do apache, vc tem que dar as permissões a ela:

    Código :
        <Directory "/usr/max/apache/htdocs/isosystem/administration/wwwroot">
            Options Indexes MultiViews
            AllowOverride None
            Order allow,deny
            Allow from all
        </Directory>

    Citação Postado originalmente por demiurgo
    pode me dar help, plz?
    Claro!






Tópicos Similares

  1. Redirecionamento do MK para o Speedr
    Por marcello91 no fórum Servidores de Rede
    Respostas: 0
    Último Post: 07-08-2013, 02:20
  2. Migrar certificado do apache para tomcat
    Por jorgejp19 no fórum Servidores de Rede
    Respostas: 0
    Último Post: 29-07-2010, 12:45
  3. Documentação do Apache para estudos LPIC 2
    Por sender no fórum Servidores de Rede
    Respostas: 0
    Último Post: 25-02-2010, 09:33
  4. Redirecionamento do cliente para pagina invÁlida
    Por Diangellys no fórum Redes
    Respostas: 1
    Último Post: 13-08-2008, 01:20
  5. Apache para de funciona do NADA!!!!
    Por Rafael RL no fórum Servidores de Rede
    Respostas: 5
    Último Post: 13-04-2005, 15:01

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L