+ Responder ao Tópico



  1. #1
    replicante
    Visitante

    Padrão VPN - fecha conexão mas nao pinga

    minha vpn (slackware 10.1, freeswan 2.06) conecta mas nao consegue pingar, alguem pode ter ideia d q pode ser???

    valeu

  2. #2
    DataForce
    Visitante

    Padrão Re: VPN - fecha conexão mas nao pinga

    Será que não tem a ver com o Firewall estar negando respostas de PING com ICMP ???



  3. #3
    replicante
    Visitante

    Padrão VPN - fecha conexão mas nao pinga

    nao, o firewall esta ok..
    =(

    estou achando q é problema de rota...

    valeu

  4. #4
    DataForce
    Visitante

    Padrão VPN - fecha conexão mas nao pinga

    Será cara ??? não vejo muito sentido em ser rota se você consegue conectar, algum roteador no meio do caminho negando o ping???



  5. #5

    Padrão VPN - fecha conexão mas nao pinga

    Cara,

    Nao sou especialista em vpn, mas tive o mesmo problema. Eutou usando vpn por pptp e o problema esta na configuracao do pptpd e do Firewall (apesar de parecer ja estava ok).

    Vc esta montando vpn pelo que, digo com o q pptp, ipsec, openvpn???

    [] Dotta :twisted:

  6. #6

    Padrão VPN - fecha conexão mas nao pinga

    Fala Dotta, grande amigo.

    Bom, como o carinha disse acima, ele está usando FreeSwan, mas creio eu que o problema dele devem ser as rotas mesmo, mas de qualquer jeito, recomendo também a procura por bloqueios em firewall.


    Abraços!



  7. #7
    replicante
    Visitante

    Padrão VPN - fecha conexão mas nao pinga

    bom dia! =)

    entao.. as firewall estão down.. pq essas duas maquinas estão e ambiente de teste aqui. entao nao preciso me preocupar com firewall e tals...

    está assim:

    Maquina1
    eth0 10.8.1.0/24 (10.8.1.3)
    eth0:0 10.8.21.0/24 (10.8.21.1)
    eth1 200.x.x.242

    Maquina2
    eth0 10.8.22.0/24 (10.8.22.1)
    eth1 200.x.x.130

    como fica:

    10.8.21.0/24 -> 200.x.x.242 => 200.x.x.241 <> 200.x.x.129 => 200.x.x.130 -> 10.8.22.0/24

    alguem pode dar uma ideia? =)

    valeu[/code]

  8. #8

    Padrão VPN - fecha conexão mas nao pinga

    Replitante,

    Se vc me permite, deixa eu ter dar uma sugestao. Tente usar o pptp, e o q eu estou usando e funciona muito bem. Ja tentei usar Freeswn e so tive dor de cabeca. Eu ate sei q todo mundo diz e e o melhor, mas o bagulho e meio loco para configurar.

    Casa vc nao precise de nivel absurdo de seguranca, posso te passar a receita de bolo e bem facil.

    [] Dotta :twisted:



  9. #9

    Padrão VPN - fecha conexão mas nao pinga

    eu to passando pelo mesmo problema, uso pptp-linux q eh client, ele fexa coneccao mas n pinga, eu dei um traceroute e ele ta procurando o ip pelo ppp0 que eh velox, e n pela ppp1 que ah vpn, como to fazendo isso da maquina firewall, então concerteza não eh meu firewall q ta bloquiando, isso acho q tem a ver com rota, e o outro problema e q ele fica derrubando a coneccao sozinho.. PUTZ

  10. #10
    replicante
    Visitante

    Padrão VPN - fecha conexão mas nao pinga

    opa! =)

    ae gente valeu pelas dicas! ja resolvi...

    a treta era a seguinte.. os dois servidores nao consguiam pingar por problemas de rota..
    mas quando coloco um cliente neles vai tranquilo! =)

    muito obrigado a todos!! =)

    valeu! =)



  11. #11

    Padrão VPN - fecha conexão mas nao pinga

    Citação Postado originalmente por replicante
    opa! =)

    ae gente valeu pelas dicas! ja resolvi...

    a treta era a seguinte.. os dois servidores nao consguiam pingar por problemas de rota..
    mas quando coloco um cliente neles vai tranquilo! =)

    muito obrigado a todos!! =)

    valeu! =)
    clintes nels, explica melhor ae brother.. to com mesmo pro.. fora essa parada de cai coneccao

  12. #12
    replicante
    Visitante

    Padrão VPN - fecha conexão mas nao pinga

    Citação Postado originalmente por Brenno
    Citação Postado originalmente por replicante
    opa! =)

    ae gente valeu pelas dicas! ja resolvi...

    a treta era a seguinte.. os dois servidores nao consguiam pingar por problemas de rota..
    mas quando coloco um cliente neles vai tranquilo! =)

    muito obrigado a todos!! =)

    valeu! =)
    clintes nels, explica melhor ae brother.. to com mesmo pro.. fora essa parada de cai coneccao
    a conexão do meu nao estava caindo.. ela nao esta pingando...
    pq eu tava pingando server --> server...

    mas depois de testes eu percebi q se tento pingar a partir do server nao rola pq da problema de rota, mas liguei meu notebook no server e dei um ip 10.8.21.10 e pinguei 10.8.22.1 e rolou

    ou seja: TA FUNCIONANDO!!!! heheheh.

    =)

    qquer duvida pergunta ae! =)

    falow



  13. #13

    Padrão VPN - fecha conexão mas nao pinga

    Citação Postado originalmente por replicante
    Citação Postado originalmente por Brenno
    Citação Postado originalmente por replicante
    opa! =)

    ae gente valeu pelas dicas! ja resolvi...

    a treta era a seguinte.. os dois servidores nao consguiam pingar por problemas de rota..
    mas quando coloco um cliente neles vai tranquilo! =)

    muito obrigado a todos!! =)

    valeu! =)
    clintes nels, explica melhor ae brother.. to com mesmo pro.. fora essa parada de cai coneccao
    a conexão do meu nao estava caindo.. ela nao esta pingando...
    pq eu tava pingando server --> server...

    mas depois de testes eu percebi q se tento pingar a partir do server nao rola pq da problema de rota, mas liguei meu notebook no server e dei um ip 10.8.21.10 e pinguei 10.8.22.1 e rolou

    ou seja: TA FUNCIONANDO!!!! heheheh.

    =)

    qquer duvida pergunta ae! =)

    falow
    entao se tu pingar da tua maquina que criou a coneccao, nao rola? tem q ser de uma outra maquina cliente? eh isso?

  14. #14
    replicante
    Visitante

    Padrão VPN - fecha conexão mas nao pinga

    vc pode pigar o server, nao pode pingar a partir dele..
    =)



  15. #15

    Padrão VPN - fecha conexão mas nao pinga

    o Brenno, mas a conexão continua caindo sozinha?

  16. #16

    Padrão VPN - fecha conexão mas nao pinga

    Citação Postado originalmente por w00dy
    o Brenno, mas a conexão continua caindo sozinha?
    continua, quando passa 2 minutos e 1 segundo ele cai. isso q eu notei no logs

    log[pptp_conn_closeptp_ctrl.c:307]: Closing PPTP connection
    Apr 1 11:10:45 firewall pptp[6473]: log[call_callbackptp_callmgr.c:88]: Closing connection
    Apr 1 11:10:47 firewall pppd[6476]: Hangup (SIGHUP)
    Apr 1 11:10:47 firewall pppd[6476]: Modem hangup
    Apr 1 11:10:47 firewall pppd[6476]: Connection terminated.
    Apr 1 11:10:47 firewall pppd[6476]: Connect time 2.1 minutes.
    Apr 1 11:10:47 firewall pppd[6476]: Sent 1253649271 bytes, received 61 bytes.
    Apr 1 11:10:47 firewall pppd[6476]: Exit.
    ALGUEM ME AJUDA PELA AMOR DE DEUS, já não sei mais oq fazer...



  17. #17

    Padrão VPN - fecha conexão mas nao pinga

    olha so que estranho, do meu debian quando conecto a vpn ele me da um ip pela interface ppp1

    172.16.100.20
    e minha rede eh 192.168.0.*

    entao da minha maquina cliente, eu do ping nesse 172.16.100.20, ele me responde, mas quando eu pingo o ip de outra maquina q ta dentro da vpn
    ex:
    ping 172.16.100.22, a coneccao morre, entao eu dei tracert 172.16.100.22

    ai ele vai busca isso na ppp0 que eh velox, tem algo errado, to achando que eh o servidor deles, que alem de bloquiar o servidor quando passa 2 minutos derruba minha vpn..

    oq vcs acham?