Página 2 de 2 PrimeiroPrimeiro 12
+ Responder ao Tópico



  1. Pode ser tanto o initrd, como os amigos falaram, mas quando eu tive problemas assim, tive que habilitar o suporte à cramfs no Kernel.


    Abraços!

  2. Verifique se vc compilou seu Kernel com suporte ao tipo de formato dos arquivos que vc ta usando ext2, ext3 etc.... Então habilite-o e recompile novamente!!!



  3. Seguinte.

    Eu tinha o suporte ao filysystem Ext3 como built-in no kernel. E mesmo assim continua dando problema.

    Daí agora eu pus isso tbm:

    <*> ATA/ATAPI/MFM/RLL support │ │
    │ │<*> Enhanced IDE/MFM/RLL disk/cdrom/tape/floppy support │ │
    │ │--- Please see Documentation/ide.txt for help/info on IDE drives │ │
    │ │[ ] Support for SATA (deprecated; conflicts with libata SATA driv│ │
    │ │[ ] Use old disk-only driver on primary interface │ │
    │ │<*> Include IDE/ATA-2 DISK support │ │
    │ │[ ] Use multi-mode by default │ │
    │ │<*> Include IDE/ATAPI CDROM support │ │
    │ │<*> Include IDE/ATAPI TAPE support (EXPERIMENTAL) │ │
    │ │<*> Include IDE/ATAPI FLOPPY support
    │<*> VIA82CXXX chipset support │ │
    │ │[ ] Other IDE chipset support

    Pq o suporte à via tava como modulo. Daí resolveu um problema.
    Agora o que está acontecendo é o seguinte:

    RAMDISC: Couldnt find a valid RAM disc image starting at 0
    Kernel panic - Not syncing: VFS : Unable to mount root fs on unknow black (3,3)

    Acho que o problema é o initrd. Eu criei ele com:

    splash -s -f /etc/bootsplash/themes/killbilltux-yellow/config/bootsplash-1024x768.cfg >> /boot/initrd.img-2.6.10

    E no grub ta assim:
    title Debian GNU/Linux, kernel 2.6.10
    root (hd0,2)
    kernel /boot/vmlinuz-2.6.10 root=/dev/hda3 ro vga=791 splash=silent
    initrd /boot/initrd.img-2.6.10
    savedefault
    boot


    Será que é o modo como eu criei o initrd que está errado? Se for... como é o modo correto?

  4. Cara ja tive este problema em outro linux, nao no debain (foi no RH Enterprise 3.0).

    E o seguinte, deve ter algum modulo q vc nao colocou (ou esta errado) no Kernel na hora de compitar tipow: ext3, riserFS, alguma controladora, etc. Verifique isso e recompile o kerne.

    Bom, o que eu disse acima nao e certeza, claro, nao conheco seu sistema, mas eh uma possibilidade ebm provavel.


    [] Dotta :twisted:



  5. Bom pessoal, consegui aqui.

    Desde o começo o que eu corrigi foi:

    1) Coloquei a parte de IDE como built-in no kernel
    2) Coloquei o suporte ao sistema de arquivos Ext3 como built-in
    3) Retirei o modulo da placa 3dcom(ele tava pau na propria compilacao).
    4) Criei outro intird com o comando:

    splash -s -f /etc/bootsplash/themes/killbilltux-yellow/config/bootsplash-1024x768.cfg >> /boot/initrd.img-2.6.10

    Só postei isso pra caso alguem tenha o mesmo erro que eu.

    Vlws a todos que me deram a luz ae(n... n me referi a minha mãe).

    Vlws mesmo.






Tópicos Similares

  1. Problemas com AC97 no Debian Sarge !
    Por Matra no fórum Sistemas Operacionais
    Respostas: 3
    Último Post: 20-04-2005, 18:50
  2. Mouse maluco no debian Sarge ???
    Por no fórum Servidores de Rede
    Respostas: 0
    Último Post: 17-02-2005, 07:08
  3. kernel panic: no init found
    Por no fórum Sistemas Operacionais
    Respostas: 13
    Último Post: 12-02-2005, 04:10
  4. kernel panic: no init found
    Por Mechanix no fórum Servidores de Rede
    Respostas: 4
    Último Post: 12-09-2004, 18:21
  5. Erro no Kernel 2.6.5 --> kernel panic : no init found
    Por aspenbr no fórum Servidores de Rede
    Respostas: 5
    Último Post: 17-06-2004, 07:45

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L