+ Responder ao Tópico



  1. #21
    Eu testei o que vc passou MAJOR.. recopilei o courierpassd com o comando passado... mas o outro comando nao sei como fazer.. pois eu instalei o courier-imapd pelo apt-get....

    A conclusao é que continua nao funcionando...

    Um detalhe que eu reparei eh o seguinte.. qdo tento acessar pelo telnet ele da a seguinte mensagem:

    server2:/etc/init.d# telnet localhost 106
    Trying 127.0.0.1...
    Connected to localhost.
    Escape character is '^]'.
    Connection closed by foreign host.

    O que seria isso? rodei o nmap e a porta 106 esta aberta...

    Outra coisa li na documentaçao do squirrel que precisa da versao 1.4.4 ou superior e a que tenho instalada é a 4.1.2 ... pode ser isso o problema?


  2. #22
    caticiane
    opa! esqueci de logar.....




  3. Olha só Caticiane,
    você tem toda razão, para Slackware, Debian e sistemas que usam inetd e não o xinet.d temos que editar o /etc/inetd.conf e adicionar :

    "courierpassd stream tcp nowait root /usr/local/sbin/courierpassd -s imap"
    sem aspas.

    troque o directorio acima pelo qual o seu courierpassd se encontra.

    tambem de uma verificada se em seu
    /etc/services
    se existe a linha
    courierpassd 106/tcp #

    restarta ele ai:

    /etc/rc.d/init.d/inetd restart

    Caso funcione, foi facil =] mas se não funcionar vamos testar varias alternativas, assim caso algum "Debianzista" tenha dificuldade no futuro, possa consultar o topico =]
    Vamos lá que tem coisa pra k** pra fazer...

    Vamos começar pela alternativa mais simples:
    Encontrei uns pacotes pré compilados do courierpassd pro Debian,
    de um cara que diz ter essa mesma dificuldade, então
    vamos terntar instala-lo

    o link onde está o pacote do courierpassd é:
    http://wtf.dk/~mbp/my_debs/courierpassd/1.0.1/
    a veja tambem se você tem instalado o courier-imap-ssl
    se não tiver :
    apt-get install courier-imap-ssl
    e mesmo se tiver, remova ele e instale novamente.

    Veja como ficou seu /etc/courier/imapd

    se a tag estiver
    AUTHMODULES="authdaemon"
    mude para:
    AUTHMODULES="authvchkpw"
    e tambem se
    AUTHMODULES_ORIG="authdaemon"
    mude para:
    AUTHMODULES_ORIG="authvchkpw"

    restarta tudo:
    /etc/init.d/courier-imap stop
    /etc/init.d/courier-authdaemon stop
    /etc/init.d/courier-imap-ssl stop
    /etc/init.d/courier-imap start
    /etc/init.d/courier-authdaemon start
    /etc/init.d/courier-imap-ssl start

    Caso funcione blz... agora se não funfar, ai vamos por a mão na massa.

    vou pedir para você instalar o Courier-imap pelo source e não pelo apt.
    pois acho que o pacote pré compilado do Debian, deve estar sem alguma opção:
    Então remova o pacote pré compilado ai, e faça o download do source:
    http://ufpr.dl.sourceforge.net/sourc...-3.0.8.tar.bz2

    eu gosto de usar /usr/local/ , porem isso é gosto.
    tar -jxvf courier-imap-3.0.8.tar.bz2

    cd courier-imap-3.0.8
    ./configure --prefix=/usr/local/ --exec-prefix=/usr/local/ --with-authvchkpw --without-authdaemon --without-authldap --disable-root-check --with-ssl --with-authchangepwdir=/usr/local/libexec/authlib

    make
    make install-strip
    make install-configure

    de uma olhada se em /usr/local/etc/ existe imapd e o imapd-ssl

    se não existir copie eles para lá:

    cp imapd.dist /usr/local/etc/imapd
    cp imapd-ssl.dist /usr/local/etc/imapd-ssl

    blz, agora temos que criar as chaves ssl, antes remova o arquivo /usr/local/share/imapd.pem
    Crie as chaves ssl para o imap.
    /usr/local/sbin/mkimapdcert

    removemos o arquivo pois caso ele já existisse ele não iria substituir.
    por isso removemos e recriamos.
    veja se existe...
    /usr/local/share/imapd.pem

    até aqui blz???
    então vamos nessa...

    Olha só Caticiane, não uso Debian e sim Slackware, sei que o Debian usa o directorio init.d para os scripts de inicialização ser rodado.

    não sei se isso ira funcionar, porem existem 2 scripts de inicialização que funfam aqui no Slack, então de uma olhada ai, vou dar uma olhada melhor no meu trampo... no caso estou em casa agora.
    /usr/local/libexec/imapd.rc
    /usr/local/libexec/imapd-ssl.rc

    Copie-os para o local onde são executados os scripts de inicialização do Debian.

    tenha certeza que seu imap esteja funcionando.
    Teste um telnet no courierpassd (106) e veja se ele retorna:

    200 courierpassd v1.1.0 hello, who are you?
    User admin@intranet.com.br
    200 Your password please.

    se ele retornar isso tá feito...
    se não...

    continuamos eheheh

    ---------------------------------------------------
    Pessoal, desculpe por qualquer ignorância...
    o intuito é apenas ajudar...
    Valew :good:

  4. #24
    alvaro_rs
    Não tem mto haver com o Tópico que estão discutindo mas é só uma idéia louca.

    Alterei o arquivo .php do frame esquerdo do squirrel e criei um link para um script que tinha em .cgi para alterar a senha.

    Lembrando que a senha que ele altera é a dos usuário locais do servidor.

    Com certeza não eh a melhor solução em termos de segurança entro outros aspectos, mas eh uma alternativa.

    E Desculpe se atrapalhei a discução de vcs



  5. #25
    caticiane
    ufa! qta coisa pra fazer....

    bom.. so vai dar pra testar na prox semana... qdo eu tiver no trabalho.. mas mesmo assim muito obrigada pela ajuda...

    eqto as linhas do inetd.conf e services... ja estavam do jeito que vc passou...

    vou reinstalar novamente o imapd e o courier pelo fonte...

    So uma pergunta ... qdo tento acessar pelo telnet ... eu logo.. mas depois eh como fecha a conexao e da a mensagem:

    server2:/etc/init.d# telnet localhost 106
    Trying 127.0.0.1...
    Connected to localhost.
    Escape character is '^]'.
    Connection closed by foreign host.

    O que seria essa ultima linha? :?

    T+ 8)






Tópicos Similares

  1. Problemas com Squirrelmail
    Por juniorr no fórum Servidores de Rede
    Respostas: 6
    Último Post: 26-09-2009, 20:40
  2. Problemas com login no SquirrelMail
    Por golum no fórum Servidores de Rede
    Respostas: 1
    Último Post: 01-12-2005, 17:47
  3. Problemas com Squirrelmail
    Por Ronald Potier no fórum Servidores de Rede
    Respostas: 3
    Último Post: 06-07-2005, 12:05
  4. Problema com o ssh pelo windows !!!
    Por embbr no fórum Servidores de Rede
    Respostas: 1
    Último Post: 01-07-2002, 18:10
  5. problemas com o IMP
    Por marlonfuchs no fórum Servidores de Rede
    Respostas: 0
    Último Post: 27-06-2002, 08:13

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L