+ Responder ao Tópico



  1. #1
    gurco
    Há tempos atrás iniciei este tópico:

    https://under-linux.org/modules.php?...ghlight=bridge

    Comprei esse acess point da D-Link e estou com alguma dúvidas.

    Quero substituir minha placa pci wireless LG por esse AP. Minha placa-mãe é uma MSI K7N2G-L, que permite que eu atribua qualquer mac adress para a rede on-board. Então quero fazer o seguinte: remover a wireless pci LG e atribuir o mac adress dela para a rede on-board. Depois quero ligar a rede on-board ao AP em modo bridge com um cabo cross-over.
    Quero fazer isso porque o mac adress da placa LG já tem permissão de acesso no provedor e eu não queria mudar.

    Minha dúvida é se o modo bridge é apropriado para isso. O ap do provedor é Samsung.

  2. Funciona sim, sem problemas. vai chegar o mac da placa de rede la no provedor.



  3. #3
    gurco
    Configurei no modo cliente mesmo. Não entendo muita coisa mas funcionou no Win XP. Bastou colocar o ap em modo cliente, informar o ssid e o canal. A placa de rede on-board ficou com o mesmo ip, gateway e dns que antes eram usados na LG wireless pci.
    Mantive o ip padrão do ap, que é 192.168.0.50. Pelo que percebi, ele é transparente, ou seja, o provedor me enxerga com o ip da rede on-board.

    Até aí tudo bem.

    O problema começou quando rodei o Kurumin direto do cd. Quando fui configurar a rede, informei o mesmo ip, gateway e dns que funcionam no WinXP e nada. Só fiquei em dúvida com o endereço de broadcast, mas aceitei a sugestão do sistema, que era 192.168.90.255, mas não funcionou.

    Agora instalei o Conectiva 10 e tive o mesmo problema. A diferença foi que o conectiva não pediu o endereço de broadcast, mas no centro de controle tem uma opção avançada em que ele aparece, com um valor padrão atribuído igual ao do Kurumin, 192.168.90.255.

    O que está acontecendo? Comprei o ap justamente para poder usar linux sem ter que me preocupar com drivers, e aparentemente ele só se comunica com o pc com Windows.

    Pela lógica, bastaria configurar a placa de rede do pc igual ao Windows e partir pro abraço.

    O que é que está errado?

  4. Vc configurou o DNS?

    edite esse arquivo e adicione as linhas abaixo nele!!!
    #/etc/resolv.conf

    nameserver 200.xxx.xxx.x19
    nameserver 200.xxx.xxx.x20

    Substitua os 200.xxx.xxx.x?? pelo DNS do seu provedor!
    isso deve fazer funcionar!!

    flow!



  5. #5
    gurco
    É exatamente essa a minha dúvida.

    No windows, a rede funcionada configurada assim:

    ip: 192.168.90.1
    mask: 255.255.255.0
    gateway: 192.168.1.1
    dns: 192.168.1.1

    O endereço do DNS é esse mesmo, válido apenas para a rede interna. Não é necessário o DNS real do provedor, isso no windows.

    Mas no linux deveria ser a mesma coisa. Como eu faço para saber o DNS do provedor sem ter que perguntar para eles?

  6. #6
    marrecotk
    Citação Postado originalmente por gurco
    É exatamente essa a minha dúvida.

    No windows, a rede funcionada configurada assim:

    ip: 192.168.90.1
    mask: 255.255.255.0
    gateway: 192.168.1.1
    dns: 192.168.1.1

    O endereço do DNS é esse mesmo, válido apenas para a rede interna. Não é necessário o DNS real do provedor, isso no windows.

    Mas no linux deveria ser a mesma coisa. Como eu faço para saber o DNS do provedor sem ter que perguntar para eles?
    Só se tu seta o proxy no navegador pra funcionar assim... nao tem como funcionar com o gateway sendo de outra faixa de rede!



  7. Citação Postado originalmente por marrecotk
    Citação Postado originalmente por gurco
    É exatamente essa a minha dúvida.

    No windows, a rede funcionada configurada assim:

    ip: 192.168.90.1
    mask: 255.255.255.0
    gateway: 192.168.1.1
    dns: 192.168.1.1

    O endereço do DNS é esse mesmo, válido apenas para a rede interna. Não é necessário o DNS real do provedor, isso no windows.

    Mas no linux deveria ser a mesma coisa. Como eu faço para saber o DNS do provedor sem ter que perguntar para eles?
    Só se tu seta o proxy no navegador pra funcionar assim... nao tem como funcionar com o gateway sendo de outra faixa de rede!
    Até onde eu sei desde que os aliases sejam da mesma placa de rede do servidor, qualquer IP pode apontar pra qualquer GW que funciona.
    flow!!

  8. Citação Postado originalmente por gurco
    É exatamente essa a minha dúvida.

    No windows, a rede funcionada configurada assim:

    ip: 192.168.90.1
    mask: 255.255.255.0
    gateway: 192.168.1.1
    dns: 192.168.1.1

    O endereço do DNS é esse mesmo, válido apenas para a rede interna. Não é necessário o DNS real do provedor, isso no windows.

    Mas no linux deveria ser a mesma coisa. Como eu faço para saber o DNS do provedor sem ter que perguntar para eles?
    Provavelmente vc aponta pro DNS 192.168.1.1 no seu provedor, e lá esse DNS ta fazendo um Forward pro DNS real que seria no caso pr expl 200.xxx.xxx.xxx isso é apenas pra facilicar a conf pro usuário mais leigo, mas faça o teste adicione no seu arquivo

    /etc/resolv.conf
    nameserver 192.168.1.1
    nameserver 200.223.0.84

    Esse secundario que coloquei é da Telemar ele funciona perfeitamente, mas pode ter um desempenho menos satisfatório em relação o DNS do seu provedor..!!
    floow!!



  9. #9
    gurco
    Citação Postado originalmente por Michael
    Provavelmente vc aponta pro DNS 192.168.1.1 no seu provedor, e lá esse DNS ta fazendo um Forward pro DNS real que seria no caso pr expl 200.xxx.xxx.xxx isso é apenas pra facilicar a conf pro usuário mais leigo, mas faça o teste adicione no seu arquivo

    /etc/resolv.conf
    nameserver 192.168.1.1
    nameserver 200.223.0.84

    Esse secundario que coloquei é da Telemar ele funciona perfeitamente, mas pode ter um desempenho menos satisfatório em relação o DNS do seu provedor..!!
    floow!!
    Tentei sua dica mas não funcionou.

    Acho que o problema não tem nada a ver com o DNS.

    Dei um ping no endereço do gateway, que é o mesmo do dns, 192.168.1.1, e deu a mensagem "network is unreachable"

    Tentei o seguinte comando no terminal como root:

    route add default gw 192.168.1.1 etho e deu a seguinte mensagem:
    a rede está fora de alcance.

    Será que esse Ap só funciona conectado a uma rede windows?

  10. #10
    amoresco
    Estas bridges funcionam com linux sim, elas são um equipamento de rede e independem do sistema.
    O teu problema é simples, lógica de rede:
    se seu ip é 192.168.90.XXX e a mascara de rede é 255.255.255.0, seu gateway terá que ser obrigatóriamente um ip 192.168.90.XXX tambêm.
    o gateway que está colocando (192.168.1.1) é de outra faixa de rede diferente da sua, por isso que esta retornando destino inalcançavel.
    Primeiro tente definir o gateway para 192.168.90.1, mais provável, e tente pingar nele, se reponder, tente pingar em um ip externo, 200.XXX.XXX.XXX, se funcionar siga em frente e tente pingar em um endereço (www.bol.com.br), se aqui não responder seu resolv.conf ta com problemas.



  11. #11
    gurco
    Citação Postado originalmente por amoresco
    O teu problema é simples, lógica de rede:
    se seu ip é 192.168.90.XXX e a mascara de rede é 255.255.255.0, seu gateway terá que ser obrigatóriamente um ip 192.168.90.XXX tambêm.
    o gateway que está colocando (192.168.1.1) é de outra faixa de rede diferente da sua, por isso que esta retornando destino inalcançavel.
    Primeiro tente definir o gateway para 192.168.90.1, mais provável, e tente pingar nele, se reponder, tente pingar em um ip externo, 200.XXX.XXX.XXX, se funcionar siga em frente e tente pingar em um endereço (www.bol.com.br), se aqui não responder seu resolv.conf ta com problemas.
    O problema é que este gateway é definido pelo provedor. Todos os clientes usam ele. Eles não vão querer mudar só por minha causa.

    Mas acho que o problema não é esse porque no Windows XP funciona.






Tópicos Similares

  1. Controlar banda com Mikrotik em modo bridge
    Por fabiocatelani no fórum Redes
    Respostas: 1
    Último Post: 12-03-2007, 21:16
  2. Dlink 502T não fica em modo Bridge
    Por jhonnyp no fórum Redes
    Respostas: 0
    Último Post: 28-02-2007, 13:47
  3. Mk em modo bridge!!!
    Por Good_speed no fórum Redes
    Respostas: 6
    Último Post: 29-01-2007, 21:15
  4. 3 DWL-900AP+ tem como ? BRidge ou repeater
    Por evertonhorst no fórum Redes
    Respostas: 0
    Último Post: 03-08-2005, 23:19
  5. Modem em modo bridge ou router?
    Por mrpicolo no fórum Servidores de Rede
    Respostas: 2
    Último Post: 14-05-2005, 23:33

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L