Página 2 de 2 PrimeiroPrimeiro 12
+ Responder ao Tópico



  1. #21
    tmenace
    Visitante

    Padrão preciso de um squid.conf que funcione

    entaum qual a moral da acl all ?

    enfeite?

    olha a logica foi pro buraco ae, hein?

    mesmo assim, nao fui feliz. :roll:

    como faço para especificar a interface de rede q ele tem q buscar as requisiçoes?

    o access.log continua vazio. tem sera algo especial com minha distro? red hat 9? eh estranho, neh?

  2. #22

    Padrão preciso de um squid.conf que funcione

    Citação Postado originalmente por tmenace
    entaum qual a moral da acl all ?

    enfeite?

    olha a logica foi pro buraco ae, hein?

    mesmo assim, nao fui feliz. :roll:

    como faço para especificar a interface de rede q ele tem q buscar as requisiçoes?

    o access.log continua vazio. tem sera algo especial com minha distro? red hat 9? eh estranho, neh?
    qual a logica da acl all???? eh simples ela eh usada pra bloquear tudo que nao estiver explicitamente como accept na conf, se nao tivesse isso por padrao seu proxy estaria aberto pra qq pc da net conectar nele... (e te ferrar no caso)



  3. #23

    Padrão preciso de um squid.conf que funcione

    Código :
     
    #  TAG: http_port
    #       Usage:  port
    #               hostname:port
    #               1.2.3.4:port
    #
    #       The socket addresses where Squid will listen for HTTP client
    #       requests.  You may specify multiple socket addresses.
    #       There are three forms: port alone, hostname with port, and
    #       IP address with port.  If you specify a hostname or IP
    #       address, then Squid binds the socket to that specific
    #       address.  This replaces the old 'tcp_incoming_address'
    #       option.  Most likely, you do not need to bind to a specific
    #       address, so you can use the port number alone.
    #
    #       The default port number is 3128.

    pra especificar ondele ele vai "ouvir", por padrao em qq interface

  4. #24
    tmenace
    Visitante

    Padrão preciso de um squid.conf que funcione

    por isso mesmo
    se acl all = 0.0.0.0/0.0.0.0 qquer micro pode usar meu proxy.

    so q nem a minha rede local funfa!

    logo, pra inicio, posso deixar assim q teria q funfar sem a minha acl redelocal, pois em all esta todas as faixas permitidas, certo? mas nem assim funciona....



  5. #25

    Padrão preciso de um squid.conf que funcione

    Citação Postado originalmente por tmenace
    por isso mesmo
    se acl all = 0.0.0.0/0.0.0.0 qquer micro pode usar meu proxy.

    so q nem a minha rede local funfa!

    logo, pra inicio, posso deixar assim q teria q funfar sem a minha acl redelocal, pois em all esta todas as faixas permitidas, certo? mas nem assim funciona....

    duh :roll:

    http_access deny all

    ta negando! nao ta como accept, soh funcionaria sem mexer em nada se tivesse accept, mas como eu falei antes isso eh cagada.... vao usar seu proxy pra fazer cagada em outros servers e vai sobrar pra vc


    se vc jah criu a acl de rede como eu falei antes, reinciou e ainda num funfou tem alguma coisa errada acontecendo sim, nao eh possivel nao ter nada nos logs....

  6. #26
    tmenace
    Visitante

    Padrão preciso de um squid.conf que funcione

    no começo dos hhtps_access tem um allow all

    olha como q tah o meu squid.conf agora.

    http_port 3128
    hierarchy_stoplist cgi-bin ?
    acl QUERY urlpath_regex cgi-bin \?
    no_cache deny QUERY
    acl all src 0.0.0.0/0.0.0.0
    acl manager proto cache_object
    acl localhost src 127.0.0.1/255.255.255.255
    acl SSL_ports port 443 563
    acl Safe_ports port 80 # http
    acl Safe_ports port 21 # ftp
    acl Safe_ports port 443 563 # https, snews
    acl Safe_ports port 70 # gopher
    acl Safe_ports port 210 # wais
    acl Safe_ports port 1025-65535 # unregistered ports
    acl Safe_ports port 280 # http-mgmt
    acl Safe_ports port 488 # gss-http
    acl Safe_ports port 591 # filemaker
    acl Safe_ports port 777 # multiling http
    acl minharede src 100.100.100.0/255.255.255.0
    acl CONNECT method CONNECT

    http_access allow manager localhost
    http_access allow all
    http_access deny manager
    http_access deny !Safe_ports
    http_access deny CONNECT !SSL_ports
    http_access allow localhost
    http_access allow minharede
    http_access deny all
    icp_access allow all

    visible_hostname dominio.com.br

    :toim:

    to ateh com vergonha já.



  7. #27

    Padrão preciso de um squid.conf que funcione

    pelo amor de deus e pelo seu servidor tire aquele allow all de lah (a num ser q vc esteja bloqueando via iptables)


    inicia o squid com

    squid -d 6

    tenta acessar o proxy

    e cola tudo q aparecer na tela aki

  8. #28
    tmenace
    Visitante

    Padrão preciso de um squid.conf que funcione

    [[email protected] root]# squid -d 6
    2005/04/14 18:52:52| Starting Squid Cache version 2.4.STABLE7 for i686-pc-linux-gnu...
    2005/04/14 18:52:52| Process ID 7089
    2005/04/14 18:52:52| With 1024 file descriptors available
    2005/04/14 18:52:52| Performing DNS Tests...
    [[email protected] root]# 2005/04/14 18:52:52| Successful DNS name lookup tests...
    2005/04/14 18:52:52| DNS Socket created on FD 4
    2005/04/14 18:52:52| Adding nameserver 200.175.5.139 from /etc/resolv.conf
    2005/04/14 18:52:52| Adding nameserver 200.175.89.139 from /etc/resolv.conf
    2005/04/14 18:52:52| Unlinkd pipe opened on FD 9
    2005/04/14 18:52:52| Swap maxSize 102400 KB, estimated 7876 objects
    2005/04/14 18:52:52| Target number of buckets: 393
    2005/04/14 18:52:52| Using 8192 Store buckets
    2005/04/14 18:52:52| Max Mem size: 8192 KB
    2005/04/14 18:52:52| Max Swap size: 102400 KB
    2005/04/14 18:52:52| Rebuilding storage in /var/spool/squid (CLEAN)
    2005/04/14 18:52:52| Using Least Load store dir selection
    2005/04/14 18:52:52| Set Current Directory to /var/spool/squid
    2005/04/14 18:52:52| Loaded Icons.
    2005/04/14 18:52:52| Accepting HTTP connections at 0.0.0.0, port 3128, FD 10.
    2005/04/14 18:52:52| Accepting ICP messages at 0.0.0.0, port 3130, FD 11.
    2005/04/14 18:52:52| WCCP Disabled.
    2005/04/14 18:52:52| Ready to serve requests.
    2005/04/14 18:52:52| Done scanning /var/spool/squid swaplog (0 entries)
    2005/04/14 18:52:52| Finished rebuilding storage from disk.
    2005/04/14 18:52:52| 0 Entries scanned
    2005/04/14 18:52:52| 0 Invalid entries.
    2005/04/14 18:52:52| 0 With invalid flags.
    2005/04/14 18:52:52| 0 Objects loaded.
    2005/04/14 18:52:52| 0 Objects expired.
    2005/04/14 18:52:52| 0 Objects cancelled.
    2005/04/14 18:52:52| 0 Duplicate URLs purged.
    2005/04/14 18:52:52| 0 Swapfile clashes avoided.
    2005/04/14 18:52:52| Took 0.6 seconds ( 0.0 objects/sec).
    2005/04/14 18:52:52| Beginning Validation Procedure
    2005/04/14 18:52:52| Completed Validation Procedure
    2005/04/14 18:52:52| Validated 0 Entries
    2005/04/14 18:52:52| store_swap_size = 84k
    2005/04/14 18:52:53| storeLateRelease: released 0 objects


    kramba, q dor de kbeça

    :toim:



  9. #29

    Padrão preciso de um squid.conf que funcione

    bom ele ta rodando mesmo:
    2005/04/14 18:52:52| Accepting HTTP connections at 0.0.0.0, port 3128, FD 10.

    agora resta saber pq tua rede nao ta acessando, qdo ocliente tenta acessar num aparace nada no error_log?

    e olha se o fw nao ta bloqueando, se for o fw... :@:

  10. #30
    tmenace
    Visitante

    Padrão preciso de um squid.conf que funcione

    droga, era o firewall. pode ficar puto da kra comigo!


    :good:

    agora vou tentar funfar o proxy transparente. valew!



  11. #31

    Padrão preciso de um squid.conf que funcione

    hahahahahha sabia, sempre acontece essas coisas comigo, ao inves de ir direto no obvio eu olho as outras coisas...
    lei de murphy

  12. #32
    Visitante

    Padrão Squid que nao funciona

    Meu amigo, tudo que se configura com uma simples configuracao CORRETA funciona. Verifica as ACLs e as regras do http_access, uma regra errada pode nao funcionar nada.

    Abraco



  13. #33
    tmenace
    Visitante

    Padrão preciso de um squid.conf que funcione

    melhor, bombei o proxy transparente, o pessoal ta passando agora pelo squid. hehe

    agora, tem como fazer o lance de alguns sites e travar o resto ne? to correndo atraz. valew mesmo!

  14. #34

    Padrão preciso de um squid.conf que funcione

    agora eh facil facil
    eh soh 1 acl q tem q criar, e um arquivo contendo os sites q vc quer bloquear



  15. #35
    tmenace
    Visitante

    Padrão preciso de um squid.conf que funcione

    kra, muito bala!

    coloquei no arquivo coisitas como

    zip, mp3, mpg rar avi e outras cositas mas

    vou matar o pessoal do coraçao amanha. hehe.

    valew mesmo!

    :good:

    e desculpa qualquer coisa. tomara q nosso topico ajude outras pessoas tbm! :clap:

  16. #36
    ksandim
    Visitante

    Padrão Desculpe-me intrometerme mas....

    Estou com o mesmo problema com o comando squid -z ele cria o cache certinhu, depois com squid -D ele starta aparentemente normal e naum reporta nenhum erro. com ./squid ele tambem naum reporta erros.
    Porem ao verificar se ta funfando com por exemplo netstat -nl naum tem nada escutando a porta 3128.
    Se eu der um squid -k reconfigure ele fala q naum é possivel reconfigurar o squid pq ele nuam esta inicializado. Se tentar um killall squid ele fala q o squid naum esta configurado...
    o meu squid ta limpaum, da uma olhada:

    http_port 3128
    icp_port 3130
    hierarchy_stoplist cgi-bin ?
    acl QUERY urlpath_regex cgi-bin \?
    no_cache deny QUERY
    cache_mem 48 MB
    cache_dir ufs /usr/local/squid/cache 100 16 256
    emulate_httpd_log on
    visible_hostname /usr/local/squid/erro.html
    client_netmask 255.255.255.0
    acl all src 0.0.0.0/0.0.0.0
    acl manager proto cache_object
    acl localhost src 10.1.41.0/255.255.255.0
    acl SSL_ports port 443 563
    acl Safe_ports port 80 # http
    acl Safe_ports port 21 # ftp
    acl Safe_ports port 443 563 # https, snews
    acl Safe_ports port 70 # gopher
    acl Safe_ports port 210 # wais
    acl Safe_ports port 1025-65535 # unregistered ports
    acl Safe_ports port 280 # http-mgmt
    acl Safe_ports port 488 # gss-http
    acl Safe_ports port 591 # filemaker
    acl Safe_ports port 777 # multiling http
    acl CONNECT method CONNECT
    http_access deny all
    icp_access allow all
    memory_pools on


    JA pesquisei de tudo na net... naum sei se estou fazendo errado!
    os passos foram um seguinte:
    1° configurei squid.conf
    2° Criei a pasta para o cache
    3° Mudei a permição da pasta para chmod 777
    4° dei o comando /usr/local/squid/bin/./squid -z para criar os arquivos de cache
    5° dei o comando /usr/local/squid/bin/./squid -D para desativar os DNSs
    6° dei o comando /usr/local/squid/bin/./squid para startar o squid.



  17. #37

    Padrão Re: Desculpe-me intrometerme mas....

    Cara me desculpe mas ta tudo errado o q vc ta fazendo !!!

    Ja volto pra corrigir os erros !!!!

  18. #38

    Padrão Re: Desculpe-me intrometerme mas....

    Bem cada um tem uma maneira de trabalhar a dica que eu te dou e a seguinte antes de começar a configurar o squid.conf faça uma copia de backup do arquivo, seguite procure tambem apenas descomentar as linhas e completar o q for necessario, eu particularmente nao gosto de limpar o arquivo mas cada um cada um.

    http_port 192.168.0.1:3128 # mude pro ip da sua maquina
    cache_dir ufs /var/spool/squid 128 16 256
    cache_mem 16 mb # mude de acordo com o desejado
    cache_swap_low 90
    cache_swap_high 95
    maximum_object_size 4096 kb
    minimum_object_size 0 kb

    Agora vc cria uma acl da seguinte maneira:
    acl permitir_rede src 192.168.0.0/255.255.255.0 # Se for a faixa que vc usa deixa assim

    Agora tambem 1 access da seguinte maneira:
    http_access allow permitir_rede
    http_access deny all

    Mais alguma linhas a serem descomentadas:
    icp_access allow all
    miss_access allow all
    cache_effective_user squid
    cache_effective_group squid
    visible_hostname seufirewall.com.br



    httpd_accel_host virtual
    httpd_accel_port 80
    httpd_accel_single_host off
    httpd_accel_with_proxy on
    httpd_accel_uses_host_header on

    Procura por essas linhas e descomenta depois da um start no squid !!!
    Vai nas estaçoes e configura ip e porta no browser e testa !!!

    Valeu mano um abraçao !!!!