+ Responder ao Tópico



  1. #1
    Visitante

    Padrão Segmentation fault

    Quando adiciono a regra

    iptables -A FORWARD -i eth1 -s 192.168.0.0/24 -p tcp -d loginnet.passport.com -j REJECT

    aparece a mensagem:
    664 Segmetation fault iptables -A FORWARD -i eth1 -s 192.168.0.0/24 -p tcp -d loginnet.passport.com -j REJECT

    O que pode ser??

    Obrigado.

  2. #2

    Padrão Segmentation fault

    Sua regra deve estar errada, deveria ser assim:

    iptables -A FORWARD -o eth1 -s 192.168.0.0/24 -p tcp -d loginnet.passport.com -j REJECT

    Falow :good:



  3. #3

    Padrão Segmentation fault

    Vixi, eheh, por mais que a regra esteja errada não deveria dar falha de segmentação :P

    Deve ter alguma coisa ferrada... tenta re-instalar o iptables.

  4. #4
    Visitante

    Padrão Segmentation fault

    ja reinstalei, mas nao funciona!! Dá o mesmo erro!!



  5. #5

    Padrão Segmentation fault

    eh soh pra essa regra q da erro ou qq coisa q vc rode da erro?? tipo um
    iptables -A INPUT -j DROP
    isso da falha de segmentacao tbm?? se sim tem alguma biblioteca bixada (ou desatualizada, ou ainda nova d+ pro iptables)

  6. #6

    Padrão Segmentation fault

    Ja passei por isso uma vez usa o seguinte no seu rc.local e ve se resolve:

    Código :
    echo 1024 > /proc/sys/net/ipv4/neigh/default/gc_thresh1
    echo 2048 > /proc/sys/net/ipv4/neigh/default/gc_thresh2
    echo 4096 > /proc/sys/net/ipv4/neigh/default/gc_thresh3

    Qualquer coisa pergunta ai.



  7. #7
    __FERNANDO__
    Visitante

    Padrão Segmentation fault

    Tô com este problema também... porem começou quando atualizei o iptables... se eu utilizar o iptables-1.2.9 isto não ocorre, mas atualizando para o 1.2.11 ou superior o problema acontece.

    Só se mudou algo no iptables ou sei lá..alguma configuração, mas como disse, com o 1.2.9 isto não ocorre.

    Utilizo um conectiva 10 com iptables 1.2.9

    []'s