Página 2 de 3 PrimeiroPrimeiro 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. #6
    vilma
    colocamos o script mais não adiantou...

  2. Citação Postado originalmente por xstefanox
    Tente adicionar este scriptzinho para iniciar junto com o sistema:

    Código :
    #!/bin/bash
    echo 1 > /proc/sys/net/ipv4/ip_forward
    iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE

    Nota: Estou supondo que a sua interface de saída seja a eth0, caso seja outra, altere o script para isso.
    Faltou a linha:
    modprobe iptable_nat, portanto fica assim:

    modprobe iptable_nat
    echo 1 > /proc/sys/net/ipv4/ip_forward
    iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE

    Pode ser por isso!! :good:



  3. #8
    vilma
    ok funcionou, mas para funcionar eu tive que colocar o ip do servidor como gateway nas minhas máquinas. Porem agora eu tenho um outro problema, porque já utilizo o gateway das máquinas para uma conexão externa com outra empresa do grupo, como fazer agora? criar uma rota? como?

  4. #9
    jedi
    Tenho um problema parecido.
    o que fiz para solucionar em partes foi criar um arquivos chamado hosts no diretorio do windows das maquinas clientes. Neste arquivo fizemos a rota para o servidor de internet.



  5. #10
    b0rin
    Se minha conexão é ppp0 fica assim?

    Código :
    echo 1 > /proc/sys/net/ipv4/ip_forward 
    iptables -t nat -A POSTROUTING -o ppp0 -j MASQUERADE

    ou

    Código :
    echo 1 > /proc/sys/net/ipv4/ip_forward 
    iptables -t nat -A POSTROUTING -o eth1 -j MASQUERADE

    Onde eth1 = minha entrada de internet.

    Obs: Eu to com servidor DHCP , então não tem como eu colocar o gateway o ip do server...



    Valeu






Tópicos Similares

  1. Respostas: 2
    Último Post: 23-12-2010, 12:46
  2. Squid - bloquear anexos web mail Yahoo
    Por prs_linux no fórum Servidores de Rede
    Respostas: 3
    Último Post: 02-03-2007, 13:21
  3. Squid lento...pelo menos eu acho.
    Por meraki no fórum Servidores de Rede
    Respostas: 14
    Último Post: 25-04-2005, 07:42
  4. squid autenticado + Cliente e-mail
    Por Valois no fórum Servidores de Rede
    Respostas: 2
    Último Post: 08-12-2004, 08:13
  5. squid nao navega
    Por rlucatto no fórum Servidores de Rede
    Respostas: 1
    Último Post: 06-08-2003, 08:25

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L