valeu galera! funcionou !
então ficou assim:

./configure --exec-prefix=/usr/local/squid-2.5.STABLE9 --prefix=/usr/local/squid-2.5.STABLE9 --sysconfdir=/usr/local/squid-2.5.STABLE9/etc --bindir=/usr/local/squid-2.5.STABLE9/sbin --sbindir=/usr/local/squid-2.5.STABLE9/sbin --enable-underscores