+ Responder ao Tópico



  1. #1
    whinston
    Visitante

    Padrão sendmail x php

    galera, algo muito estranho acontece.
    qdo eu crio um script php como se fosse um bash, usando o #!/usr/local/bin/php no início dele e rodando via console, eu consigo usar a função MAIL normal

    quando eu uso via PHP rodando via apache, o email não é enviado e tb não aparece nada nos logs. alguem sabe oq pode ser ?

  2. #2

    Padrão sendmail x php

    o PATH dele nao estar no PATH do user que roda o apache, coloque o path completo dele no php.ini e tenta denovo



  3. #3
    whinston
    Visitante

    Padrão certinho

    Citação Postado originalmente por 1c3_m4n
    o PATH dele nao estar no PATH do user que roda o apache, coloque o path completo dele no php.ini e tenta denovo
    então velhinho, ta /usr/sbin/sendmail -t
    creio que seja isto mesmo

    tem + alguma ideia ?

  4. #4

    Padrão sendmail x php

    coloca assim no teu script:

    mail(blabalbala) or die("erro");

    soh pra ver se eh alguma coisa na funcao
    aproveita e jah passa a sintaxe q vc ta usando nela



  5. #5
    whinston
    Visitante

    Padrão erro

    Citação Postado originalmente por 1c3_m4n
    coloca assim no teu script:

    mail(blabalbala) or die("erro");

    soh pra ver se eh alguma coisa na funcao
    aproveita e jah passa a sintaxe q vc ta usando nela
    deu erro meu caro
    alguma dica a mais ?

  6. #6

    Padrão sendmail x php

    deu erro? hmmm entaum tem alguma coisa na sintaxe dela, como vc ta usando?



  7. #7
    whinston
    Visitante

    Padrão exemplo

    Citação Postado originalmente por 1c3_m4n
    deu erro? hmmm entaum tem alguma coisa na sintaxe dela, como vc ta usando?

    mail('[email protected]','teste','teste) or die('erro')

  8. #8

    Padrão sendmail x php

    eu uso assim:

    Código :
    $headers  = "MIME-Version: 1.0\r\n";
    $headers .= "Content-type: text/html; charset=iso-8859-1\r\n";
    $headers .= "From: 1c3_m4n<iceman NOSPAM underlinuix com br>\r\n";
    $mensagem = "teste";
    $titulo="teste de email";
    mail($email,$titulo,$mensagem,$headers) or die("Não enviou");



  9. #9
    whinston
    Visitante

    Padrão eu tb

    Citação Postado originalmente por 1c3_m4n
    eu uso assim:

    Código :
    $headers  = "MIME-Version: 1.0\r\n";
    $headers .= "Content-type: text/html; charset=iso-8859-1\r\n";
    $headers .= "From: 1c3_m4n<iceman NOSPAM underlinuix com br>\r\n";
    $mensagem = "teste";
    $titulo="teste de email";
    mail($email,$titulo,$mensagem,$headers) or die("Não enviou");
    eu tb, mas eu tentei daquela forma simplificado só pra garantir e nada.. pootz, ta muito estranho isto! gozado que pelo bash envia, cuma q pode esta doidera

  10. #10

    Padrão sendmail x php

    num tem nada nos logs mesmo? ta estranho isso...
    tenta aumentar o nivel do log no php.ini pra ver se aparece alguma coisa



  11. #11
    whinston
    Visitante

    Padrão onde ?

    Citação Postado originalmente por 1c3_m4n
    num tem nada nos logs mesmo? ta estranho isso...
    tenta aumentar o nivel do log no php.ini pra ver se aparece alguma coisa
    tava aqui pensando com o tico e teco.. se ele tá dando erro ainda no PHP, quer dizer que ele não chegou a processar a função MAIL, talvez pq não saiba quem é ela, ou onde esteja o sendmail, etc.. ou ele tentou enviar e não conseguiu ?

    nos logs de email não tem nada mesmo
    este tipo de erro era pra tar no apache_error do domínio, correto ?

  12. #12

    Padrão sendmail x php

    eh tinha q estar no error_log do apache, alias qual foi o erro q deu na funcao pelo apache? que a funcao nao existe ou ele soh mostrou a msg de erro do die?

    eu to achando q ele nao conseguindo usar o sendmail...



  13. #13
    whinston
    Visitante

    Padrão erro do die

    Citação Postado originalmente por 1c3_m4n
    eh tinha q estar no error_log do apache, alias qual foi o erro q deu na funcao pelo apache? que a funcao nao existe ou ele soh mostrou a msg de erro do die?

    eu to achando q ele nao conseguindo usar o sendmail...

    mostrou o erro do die

  14. #14
    whinston
    Visitante

    Padrão Re: erro do die

    Citação Postado originalmente por whinston
    Citação Postado originalmente por 1c3_m4n
    eh tinha q estar no error_log do apache, alias qual foi o erro q deu na funcao pelo apache? que a funcao nao existe ou ele soh mostrou a msg de erro do die?

    eu to achando q ele nao conseguindo usar o sendmail...

    mostrou o erro do die

    olha o erro aqui no log do apache
    [client 200.206.251.141] script '/var/www/html/whinston/helpdesk/xenviamail.php' not found or unable to stat



  15. #15

    Padrão sendmail x php

    unable to stat ? :roll:
    estanho.... tenta mudar as permissoes dele pra ver

    alias tem mais alguma outra funcao nesse arquivo sem ser o envio de email?

  16. #16
    whinston
    Visitante

    Padrão tem

    Citação Postado originalmente por 1c3_m4n
    unable to stat ? :roll:
    estanho.... tenta mudar as permissoes dele pra ver

    alias tem mais alguma outra funcao nesse arquivo sem ser o envio de email?
    na verdd no sistema tem varios, mas eu criei um arquivo de teste apenas com a funcao mail, coisa de 3 linhas.