+ Responder ao Tópico



  1. #1
    whinston
    Visitante

    Padrão Debian: fsck.ext3 No such device or address

    Problemas !!!!
    Estou com um HD ATA de 80Gb e um SCSI de 9Gb.
    Não tenho experiência com o Debian e estou instalando pra curtir.

    Quando eu instalo apenas com o HD ATA, vai blz.
    Quando coloco o SCSI na parada, logo após o primeiro boot, ele dá o erro:

    /boot: clean
    fsck.ext3: No surch device or address while trying to open /dev/sda1

    e fica parado na tela de CONTROL-D
    Dicas?

  2. #2

    Padrão Debian: fsck.ext3 No such device or address

    provavelmente o kernel nao ta com suporte a scsi como built-in
    " No surch device"
    ter o scsi soh como modulo num resolve nesse caso :P



  3. #3
    whinston
    Visitante

    Padrão caracas

    caracas.. mas eu to instando o debian do zero..
    ele acha o HD SCSI, eu crio as partições e tal
    ae no primeiro boot, fode tudo

    como resolver a parada ?

  4. #4

    Padrão Debian: fsck.ext3 No such device or address

    faz muuuuito tempo q nao instalo debian, mas se ele reconheceu na instalacao, criou as particoes, e soh ta dando pau agora q vc ta usando o sistema, eh pq ele uso um kernel pra entrar na instalacao e instalou outro kernel na maquina.
    o debian tem a opcao de escolher o kernel no install tb?



  5. #5
    whinston
    Visitante

    Padrão soh pra variar..

    soh pra variar eu axo q fiz merda
    instalei chamando linux26 e depois no boot eu dei enter, sem informar nada, achando que ele já ia iniciar no linux26

    vou dar 1 confirmada se é realmente isto, mas tá com toda pinta

  6. #6
    slice
    Visitante

    Padrão Debian: fsck.ext3 No such device or address

    o debian tem a opção de selecionar o kernel e o suporte que ele proverá, inclusive a versão 'netinst' vc baixa somente o básico pra começar a instalação (108Mb), e neste básico já está incluso o kernel 2.6 também e o restante, vc baixa somente o que realmente vai usar e o melhor disso, é que vc vai baixar tudo atualizado em suas últimas versões...

    Para baixar:

    http://cdimage.debian.org/debian-cd/...86-netinst.iso

    []'s

    Slice



  7. #7
    whinston
    Visitante

    Padrão este mesmo

    e ae grande slice, firmeza?
    então velho, foi exatamente dae mesmo que eu puxei

    eu reparei aki no lilo e ele tá usando o mesmo kernel sim
    tem 2 opções: normal e rescue

    instalei novamente sem o HD SCSI, mas com a controladora e foi normal.
    ae instalei novamente com o HD SCSI e no primeiro boot, mesmo erro.

    num sei q porcaria q pode ta acontecendo, vou escrever o erro todo:

    fsck.ext3: No such device or address while trying to open /dev/sda1
    Possibly non-existent or swap device?

    fsk failed. Please repair manually.

  8. #8
    whinston
    Visitante

    Padrão idéia: e se eu desabilitar?

    tive uma idéia de girico aki..
    e se eu desativar esta checagem do fsck pra ver



  9. #9
    whinston
    Visitante

    Padrão gambiarra

    oia a mutreta..
    instalei com a SCSI, mas sem o disco
    coloquei o disco, montei e boa

    num entendi pq qdo instalo com o disco dá aquele, BUT..

  10. #10
    slice
    Visitante

    Padrão Debian: fsck.ext3 No such device or address

    brother, tenta recompilar o kernel, como o Ice disse, deixando os drivers scsi como built-in, desse jeito as chances de funcionar são maiores... pode ser que o kernel está tentando carregar um drive errado e por isso o seu disco não está sendo reconhecido corretamente...

    nunca trabalhei com discos scsi, mas uma coisa é certa, sempre que instalo alguma máquina, a primeira coisa que faço é recompilar o kernel e arrancar tudo o que não me interessa e compilar o que eu uso de hardware como built-in... isso aumenta e bastante o desempenho da máquina e também torna ela mais segura...



  11. #11
    whinston
    Visitante

    Padrão mas veja só..

    então cara, mas olha o problema:

    * qdo eu instalo com a controladora e o HD ligados, no primeiro boot dá o pau.. ae, mesmo que eu ranque o HD, o sistema não liga, ou seja, num dá pra compilar o kernel

    * qdo eu instalo apenas com o controladora, com o HD desligado, ele entra normalmente. ae desligo, conecto o HD e ligo novamente.. ae é só montar

    achei muito doido isto!!! mas só funcionou assim mesmo.