+ Responder ao Tópico



  1. #1
    micfer
    Visitante

    Padrão PHP não abre paginas

    galera, até ontem meu apache2 + php5 +mysql tava rodando perfeitamente, do nada, paginas escritas em php não abrem, pelo contrário, o navegador quer fazer download delas, já tentei re-compilar o PHP mais de nada adiantou, alguém pode me dar uma luz :cry:

  2. #2

    Padrão PHP não abre paginas

    q erro aparece quando vc manda abrir?

    []'s



  3. #3
    micfer
    Visitante

    Padrão PHP não abre paginas

    não aparece erro, ele tenta fazer download da pagina, abre a janela do gerenciador de download...

  4. #4
    -thiago-
    Visitante

    Padrão PHP não abre paginas

    Já tentou reiniciar o serviço do PHP ?



  5. #5

    Padrão PHP não abre paginas

    edita o conf do apache e acrescenta o as extensões do php...

  6. #6

    Padrão PHP não abre paginas

    confira se o seu httpd.conf esta d acordo com o necessario para o php, segui ndo as dicas em:

    https://under-linux.org/artigos45.html

    []'s



  7. #7
    LenTu
    Visitante

    Padrão PHP não abre paginas

    eh como o camarada esamp flw...

    geralmente issu ocorre qdo naum tem as extensoes php no httpd.conf

    procura por .htm e poe ao lado dele a extensao .php...

    abraços,

    :good:

  8. #8

    Padrão PHP não abre paginas

    na verdade o q falta exatamente no httpd.conf eh:

    AddType application/x-httpd-php .php .phtml
    AddType application/x-httpd-php-source .phps

    e a carga do modulo

    []'s



  9. #9
    micfer
    Visitante

    Padrão PHP não abre paginas

    no httpd.conf já estão as estenções, jah rebootei até a maquina pra ver c era algo q tinha que recarregar, no mozzila ele da ess msg quando tento acessar:

    the file "" is of type aplication/x-http-php, and Mozilla does not know how to handle this file type. This file in located at: http://localhost/painel

  10. #10
    micfer
    Visitante

    Padrão PHP não abre paginas

    Citação Postado originalmente por demiurgo
    na verdade o q falta exatamente no httpd.conf eh:

    AddType application/x-httpd-php .php .phtml
    AddType application/x-httpd-php-source .phps

    e a carga do modulo

    []'s
    pior q jah esta lá no httpd.conf essa configuração, axo estranho parar de funcionar de uma hora pra outra