+ Responder ao Tópico



  1. #1
    X-LOGAN
    Visitante

    Padrão iptables não executa as regras!!!

    Olá pessoal estou na minha luta para poder fazer o Outlook baixar e enviar as mensagens, estou inserindo as seguinte regras no iptables:

    #Primeiro limpo as regras
    iptables -F

    #Depois eu começo a inserir as regras
    modprobe iptable_nat
    iptables -t nat -A POSTROUTING -O eth0 -j MASQUERADE
    iptables -A FORWARD -p tcp --dport 110 -j ACCEPT
    iptables -A FORWARD -p udp --dport 110 -j ACCEPT
    iptables -A FORWARD -p tcp --dport 25 -j ACCEPT
    iptables -A FORWARD -p udp --dport 25 -j ACCEPT
    iptables -A INPUT -i lo -j ACCEPT
    iptables -A OUTPUT -o lo -j ACCEPT
    iptables -A FORWARD -o eth0 -s 100.100.100.0/24 -d 0/0 -j ACCEPT
    echo 1 > /proc/sys/net/ipv4/ip_forward

    #Depois eu listo as regras com
    iptables -L

    elas estão la no iptables mas o Outlook continua não baixando os emails, fica com a mensagem "Localizando host....."!!!!

    Existe algo de errado nas regras do iptables?

    Um abraço

    "NÃO USE DROGAS, USE LINUX"

  2. #2

    Padrão iptables não executa as regras!!!

    Errado >>>
    iptables -t nat -A POSTROUTING -O eth0 -j MASQUERADE

    Certo >>>>
    iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE

    suba tb o modulo ip_conntrack

    e veja nos clientes se ta setado GW default/DNS



  3. #3
    X-LOGAN
    Visitante

    Padrão iptables não executa as regras!!!

    Levantei o outro modulo mas não adiantou e fiz a outra alteração, havia digitado errado (no forum).

    Não entendi o que vc quis dizer com:

    "veja nos clientes se ta setado GW default/DNS"

    Os clientes usam o Outlook!!!
    Obs.: O servidor de e-mail não esta na fábrica esta em uma outra empresa (provedora de internet)


    "NÃO USE DROGAS, USE LINUX"

  4. #4
    X-LOGAN
    Visitante

    Padrão iptables não executa as regras!!!

    Tenho que dar um reboot na máquina para que as regras funcionem?



  5. #5

    Padrão iptables não executa as regras!!!

    GW DEFAULT = gateway default......
    DNS é dns mesmo, tb precisa dele, de preferencia use o mesmo que o seu servidor usa

    se nao tem isso nos clientes como vc espera q ele encontra a rota para o servidor de email? entendeu pq precisa do gw?

  6. #6
    Lion_Black
    Visitante

    Padrão iptables não executa as regras!!!

    Ja fez o teste de cadastrar outra conta de outro provedor para verificar se o problema nao esta com o provedor??





    USE DROGAS E USE LINUX



  7. #7
    X-LOGAN
    Visitante

    Padrão iptables não executa as regras!!!

    DEU CERTO!!!

    Ai pessoal deu certo agora, inseri as regras e ta funcionando legal!!!!
    Na máquina em que estava testando estava sem o gateway padrão, foi só configurar e esta rodando normamente.
    Obrigado pela ajuda

    Agora pretendo montar um artigo e enviar ao underlinux contando a minha experiencia!!!!!