+ Responder ao Tópico



  1. #1
    felipeasc
    Boa tarde.
    Estou tentando compilar o 'Kernel 2.6.12.1' num 'SLACKWARE 10.1' com controladora SCSI.
    Deixei a opção desta controladora como BUILT IN. Compilou direitinho, porém ao iniciar a máquina dá a maldita mensagem:

    Kernel Panic: Unable to mount root fs on .................

    Enfim, consegui compilar este kernel para rodar em outra máquina com hd IDE e funcionou normalmente...só que em máquinas com HD SCSI, não vai de jeito nenhum.

    Já tentei o comando: 'lilo -r /' , após fazer a configuração do Lilo para este Kernel.
    O Lilo está corretamente configurado, mas não funciona.

    O sistema de arquivos que uso é 'ext3'

    Alguém sabe se tem algum "truque" para que funcione???

    Muito obrigado
    Felipe

  2. verifica se os modulos do ext3 estão nativos no kernel !!!!!!!!! e tenta revisar a configuração do lilo .... qualquer coisa joga ai mais informações de comandos de compilação e em ultimo caso o conf do kernel


    falow



  3. #3
    Eu tinha deixado todas as opções de EXT3 como BUILT IN, assim como a opção da minha controladora SCSI...o Lilo está certinho.

    Para compilar o Kernel faço o seguinte:
    Após ter colocado o arquivo .tar dentro de /usr/src/ e digitado tar -xv -f "arquivo.tar", faço o seguinte:
    Crio o link simbólico para esta pasta;
    Digito: make mrproper, make clean, make menuconfig e escolho as opções desejadas. Depois digito make bzImage, make modules, make modules_install (apenas de não costumar deixar nada em módulo...tudo como built in)

    Vai abaixo a configuração do Lilo e da parte do conf do Kernel que mostra o File System e SCSI

    # LILO configuration file
    # generated by 'liloconfig'
    #
    # Start LILO global section
    boot = /dev/sda
    message = /boot/boot_message.txt
    prompt
    timeout = 120
    # Override dangerous defaults that rewrite the partition table:
    change-rules
    reset
    # VESA framebuffer console @ 1024x768x256
    vga = 773
    # End LILO global section
    # Linux bootable partition config begins
    image = /boot/vmlinuz
    root = /dev/sda4
    label = Linux
    read-only
    #
    image = /boot/vmlinuz-2.6.12.1
    root = /dev/sda4
    label = Linux-2.6.12.1
    read-only
    # Linux bootable partition config ends



    Agora o kernel:
    # File systems
    #
    # CONFIG_EXT2_FS is not set
    CONFIG_EXT3_FS=y
    CONFIG_EXT3_FS_XATTR=y
    CONFIG_EXT3_FS_POSIX_ACL=y
    CONFIG_EXT3_FS_SECURITY=y
    CONFIG_JBD=y
    CONFIG_JBD_DEBUG=y
    CONFIG_FS_MBCACHE=y
    # CONFIG_REISERFS_FS is not set
    # CONFIG_JFS_FS is not set
    CONFIG_FS_POSIX_ACL=y


    # SCSI device support
    #
    CONFIG_SCSI=y
    CONFIG_SCSI_PROC_FS=y

    #
    # SCSI support type (disk, tape, CD-ROM)
    #
    CONFIG_BLK_DEV_SD=y
    # CONFIG_CHR_DEV_ST is not set
    # CONFIG_CHR_DEV_OSST is not set
    # CONFIG_BLK_DEV_SR is not set
    CONFIG_CHR_DEV_SG=y


    # SCSI low-level drivers
    #
    # CONFIG_BLK_DEV_3W_XXXX_RAID is not set
    # CONFIG_SCSI_3W_9XXX is not set
    # CONFIG_SCSI_7000FASST is not set
    # CONFIG_SCSI_ACARD is not set
    # CONFIG_SCSI_AHA152X is not set
    # CONFIG_SCSI_AHA1542 is not set
    # CONFIG_SCSI_AACRAID is not set
    # CONFIG_SCSI_AIC7XXX is not set
    # CONFIG_SCSI_AIC7XXX_OLD is not set
    # CONFIG_SCSI_AIC79XX is not set
    CONFIG_SCSI_DPT_I2O=y
    # CONFIG_SCSI_IN2000 is not set
    # CONFIG_MEGARAID_NEWGEN is not set
    # CONFIG_MEGARAID_LEGACY is not set
    CONFIG_SCSI_SATA=y
    # CONFIG_SCSI_SATA_AHCI is not set
    # CONFIG_SCSI_SATA_SVW is not set
    CONFIG_SCSI_ATA_PIIX=y
    # CONFIG_SCSI_SATA_NV is not set
    # CONFIG_SCSI_SATA_PROMISE is not set
    # CONFIG_SCSI_SATA_QSTOR is not set
    # CONFIG_SCSI_SATA_SX4 is not set
    # CONFIG_SCSI_SATA_SIL is not set
    CONFIG_SCSI_SATA_SIS=y
    # CONFIG_SCSI_SATA_ULI is not set
    # CONFIG_SCSI_SATA_VIA is not set
    # CONFIG_SCSI_SATA_VITESSE is not set
    # CONFIG_SCSI_BUSLOGIC is not set
    # CONFIG_SCSI_DMX3191D is not set
    # CONFIG_SCSI_DTC3280 is not set
    # CONFIG_SCSI_EATA is not set
    # CONFIG_SCSI_FUTURE_DOMAIN is not set
    # CONFIG_SCSI_GDTH is not set
    CONFIG_SCSI_GENERIC_NCR5380=y
    CONFIG_SCSI_GENERIC_NCR5380_MMIO=y
    CONFIG_SCSI_GENERIC_NCR53C400=y
    # CONFIG_SCSI_IPS is not set
    # CONFIG_SCSI_INITIO is not set
    # CONFIG_SCSI_INIA100 is not set
    # CONFIG_SCSI_PPA is not set
    # CONFIG_SCSI_IMM is not set
    # CONFIG_SCSI_NCR53C406A is not set
    # CONFIG_SCSI_SYM53C8XX_2 is not set
    # CONFIG_SCSI_IPR is not set
    # CONFIG_SCSI_PAS16 is not set
    # CONFIG_SCSI_PSI240I is not set
    # CONFIG_SCSI_QLOGIC_FAS is not set
    # CONFIG_SCSI_QLOGIC_FC is not set
    # CONFIG_SCSI_QLOGIC_1280 is not set
    CONFIG_SCSI_QLA2XXX=y
    # CONFIG_SCSI_QLA21XX is not set
    # CONFIG_SCSI_QLA22XX is not set
    # CONFIG_SCSI_QLA2300 is not set
    # CONFIG_SCSI_QLA2322 is not set
    # CONFIG_SCSI_QLA6312 is not set
    # CONFIG_SCSI_LPFC is not set
    # CONFIG_SCSI_SYM53C416 is not set
    # CONFIG_SCSI_DC395x is not set
    # CONFIG_SCSI_DC390T is not set
    # CONFIG_SCSI_T128 is not set
    # CONFIG_SCSI_U14_34F is not set
    # CONFIG_SCSI_ULTRASTOR is not set
    # CONFIG_SCSI_NSP32 is not set

    a minha controladora está em negrito.....
    o resto das controladoras está como "not set".

    Por favor, me ajudem.

  4. Quando vc executa o comando lilo ele não da um erro de que o arquivos esta muito grande ????



  5. #5
    felipeasc
    Não...não dá nenhum erro.
    No post anterior, eu coloquei a configuração do LILO e algumas partes do conf do Kernel.






Tópicos Similares

  1. Compilando Kernel com Layer7
    Por marcoaurelio no fórum Servidores de Rede
    Respostas: 6
    Último Post: 30-11-2006, 17:23
  2. APÓS COMPILAR KERNEL COM HD SCSI, NÃO DETECTA AS IDE
    Por edgarjr no fórum Servidores de Rede
    Respostas: 2
    Último Post: 22-05-2006, 14:58
  3. APÓS COMPILAR KERNEL COM HD SCSI, NÃO DETECTA AS IDE
    Por edgarjr no fórum Sistemas Operacionais
    Respostas: 0
    Último Post: 22-05-2006, 14:42
  4. Slackware 10.1 não reconhece kernel para controladora SCSI
    Por roge no fórum Sistemas Operacionais
    Respostas: 2
    Último Post: 28-06-2005, 10:49
  5. Atualizaçao kernel com (grub)
    Por no fórum Servidores de Rede
    Respostas: 3
    Último Post: 27-11-2002, 19:17

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L