+ Responder ao Tópico



  1. #1
    pensador-ce
    Visitante

    Padrão apache não lê php

    e ai galera, blz? seguinte tô com um pro bobo aqui mais naum sei como consertar. instalei o slackware 10 aqui e ta rodando blz o apache só q ele naum lê paginas em php, ja fui no apache e coloquei a linha:
    <IfModule mod_dir.c>
    DirectoryIndex index.php index.htm
    </IfModule>
    mais naum funiconou coloquei no arquivo mod_php.conf a seguinte linha:
    LoadModule php4_module libexec/apache/libphp4.so
    AddType application/x-httpd-php .php
    AddType application/x-httpd-php-source .phps
    e nada. :roll: o q vcs acham q deve ser?

  2. #2
    pensador-ce
    Visitante

    Padrão apache não lê php

    ????



  3. #3
    Aff
    Visitante

    Padrão Re: apache não lê php

    Citação Postado originalmente por pensador-ce
    e ai galera, blz? seguinte tô com um pro bobo aqui mais naum sei como consertar. instalei o slackware 10 aqui e ta rodando blz o apache só q ele naum lê paginas em php, ja fui no apache e coloquei a linha:
    <IfModule mod_dir.c>
    DirectoryIndex index.php index.htm
    </IfModule>
    mais naum funiconou coloquei no arquivo mod_php.conf a seguinte linha:
    LoadModule php4_module libexec/apache/libphp4.so
    AddType application/x-httpd-php .php
    AddType application/x-httpd-php-source .phps
    e nada. :roll: o q vcs acham q deve ser?



    Cara se você da uma olhada nalinha 1065 do seu httpd.conf(isso se você estiver com o apache da instalação do Slack)

  4. #4
    pensador-ce
    Visitante

    Padrão apache não lê php

    a linha q vc fala é esta? Include /etc/apache/mod_php.conf
    ja descomentei, mais agora ele ta fazendo o download do arquivo, antes ele mostrava o conteúdo



  5. #5
    Visitante

    Padrão apache não lê php

    Citação Postado originalmente por pensador-ce
    a linha q vc fala é esta? Include /etc/apache/mod_php.conf
    ja descomentei, mais agora ele ta fazendo o download do arquivo, antes ele mostrava o conteúdo
    Ja restartou o Apache?
    Você ja viu o arquivo /etc/apache/mod_php.conf também, está tudo OK??

  6. #6
    pensador-ce
    Visitante

    Padrão apache não lê php

    blz, resolvi.
    descomentei a linha
    Include /etc/apache/mod_php.conf no httpd.conf e no mod_php.conf descomentei a 1 linha destas abaixo, deu blz, valeu a ajuda.
    LoadModule php4_module libexec/apache/libphp4.so
    AddType application/x-httpd-php .php phtml
    AddType application/x-httpd-php-source .phps



  7. #7
    Visitante

    Padrão apache não lê php

    Citação Postado originalmente por pensador-ce
    blz, resolvi.
    descomentei a linha
    Include /etc/apache/mod_php.conf no httpd.conf e no mod_php.conf descomentei a 1 linha destas abaixo, deu blz, valeu a ajuda.
    LoadModule php4_module libexec/apache/libphp4.so
    AddType application/x-httpd-php .php phtml
    AddType application/x-httpd-php-source .phps
    Ok Cara agora funfou??