+ Responder ao Tópico



  1. #6
    jabsnet2
    fiz tudo certim colokei o kernel 2.4.27 com os modulos setados quando vai iniciar o shaper dah isso:

    Starting CBQ traffic shaping: RTNETLINK answers: No such file or directory
    RTNETLINK answers: No such file or directory


    o que eh?

    jah mudei ate o cbq.ini e nada....
    aparentemente ele parece que cria...
    mas na pratica nao tah controlando a banda....

  2. Tenho amigos q usam Debian seguiram está receitinha e deu certinho
    http://www.vivaolinux.com.br/artigos...=1016&pagina=1
    Abraço



  3. #8
    jabsnet2
    ola amigo jah tinha tentado esse seu artigo do VOL mas o problema nao eh as regras.... o que vc exlica lah funciona direitinho no conectiva, redhat mas no debian nao vai.... pq em primeiro tiver que recompilar o kernel jah tah tudo feito e kdo vc dah apt-get install shaper ele instala o iproute e todas as dependencias.. o problema eh kdo ele inicia dah o erro que falei logo atras...

    ativei o debug ele dah o erro quando executa essa linha

    tc qdisc del dev eth0 root

    aew dah o erro......

    e aew como posso corrigir?

  4. Qual linha vc usa pra startar o cbq ???

    Depois que vc instala o shaper ele cria algum script como o cbq.init como no redhat e seus derivados ???

    Pergunto isso por que to testando o cbq e o htb no debian sarg e nao to seguindo esses seus passos, mesmo por que o sarg ja tem suporte ao controle de banda nao tendo a necessidade de recompilar kernel,

    Eu queria entender melhor o que vc ta fazendo em relaçao ao kernel 2.4 posta ai sua estrutura !!!


    Valeu !!!



  5. #10
    jabsnet2
    eu fiz a instalacao padrao do debian... a 3.1
    tudo estable e atualizado bonitinho...

    como verifiquei bastava soh instalar o shaper

    apt-get install shaper

    mas apos issu nao funcionou... diz que nao havia suporte no kernel
    puxei o 2.4.27 recompilei e blz...

    dai mais uma vez dava um erro ao iniciar o shaper

    na linha que falei acima...

    verifiquei exaustivamente na net e na verdade nao erra um erro que
    nao controlava a banda.. e sim um erro do script tentando excluir a interface onde ela nao existia de fato...

    retirei essa linha do script e pronto.... tah controlando bonitinho e sem dar erros....

    outro problema eh no stop.. tive que incluir um grep eth para evitar de pegar o loopback... desativei ele tmb.. agorah sim tanto o start como o stop faz de acordo e sem erros....

    agorah quero saber como ativa a marca de pacotes no iptables do debian
    pq o cbq nao controla upload devido ao mascaramento apenas pela marca de pacotes....






Tópicos Similares

  1. Como instalar o cbq no slackware 10.1
    Por rfm no fórum Servidores de Rede
    Respostas: 22
    Último Post: 20-06-2005, 11:20
  2. Como recuperar o lilo no Debian?
    Por Mandrake no fórum Servidores de Rede
    Respostas: 1
    Último Post: 15-03-2004, 14:57
  3. cbq no debian 3 ?
    Por spycrash1 no fórum Servidores de Rede
    Respostas: 0
    Último Post: 14-02-2004, 23:28
  4. como instalar o openoffice no conectiva 8.0??????
    Por no fórum Servidores de Rede
    Respostas: 6
    Último Post: 23-10-2003, 11:01
  5. Como instalar e configurar o Debian em uma máquina Dell Optp
    Por luccosta no fórum Servidores de Rede
    Respostas: 0
    Último Post: 20-08-2003, 07:46

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L