+ Responder ao Tópico



  1. #1
    spadinha
    ola.

    estou com um problema serio de conexao com um NAT. implementei um modulo em FlagShip integrado com GCC para conexao e envio de mensagens via Socket Stream. Testando em uma rede local . a comunicacao entre cliente e servidor foi legal . porem ao configurar um redirecionamento para protocolos TCP e UDP na porta 5631 tive problemas ao se comunicar com o servidor .. a mensagem do socket naum chega ao servidor, tive problemas apenas com a comunicacao externa se alguem puder me ajudar

    Obrigado.

    Spadinha...®
    [/u]

  2. #2
    rodrigopc-rj
    vc fez nat... e as regras de filtragem, vc criou para permitir o tráfego até o seu servidor dessas portas?, para testar o nat é simples...
    certifique-se de que não há regras de filtragem. externamente a sua rede, de um "telnet xxx.xxx.xxx.xxx 5631" caso haja resposta, o seu nat está perfeito, e se o tcp está respondendo não tem porque o udp não responder... caso tudo esteja OK, crie as regras de filtragem.



  3. #3
    spadinha
    sim fiz os testes mais o servidor naum responde... o telnet fica TENTANDO conectar com o servidor... porem naum consegue... e meu sistema fica travado... ao tentar se conectar pela rede interna funciona corretamente....

    obrigado pela ajuda... mais jah tinha feito isso ....


    Spadinha...®

  4. #4
    rodrigopc-rj
    Por um acaso o ip nateado está configurado no placa de rede?
    ex:
    eth0=200.200.200.200
    eth1=192.168.1.1

    caso a regra seja para um outro ip 200, vc deve configurar uma subinterface com o ipdesejado, pois senão o nat não funciona mesmo.

    eth0=200.200.200.200
    eth0:1=200.200.200.201
    eth1=192.168.1.1
    eu aconcelharia...
    iptables -t nat -A PREROUTING -p "protocolo" -i "interface_entrada" -s 0.0.0.0/0 -d "ip_nat" --dport "porta" -j DNAT --to-destination "ip_real"



  5. #5
    spadinha
    ow valew mais eu jah tinha conseguido aki...
    tah funcionando corretamente


    o meu problema era bem isso mesmo problema na identificacao da placa... eu jah tinha encontrado...


    mais valew de qualquer jeito


    falow

    spadinha...®






Tópicos Similares

  1. Respostas: 3
    Último Post: 17-03-2015, 17:49
  2. Emule e Firewall/NAT Linux
    Por aleckmorpheus no fórum Servidores de Rede
    Respostas: 0
    Último Post: 17-02-2004, 10:17
  3. proxy/nat/firewall :-(
    Por inare no fórum Servidores de Rede
    Respostas: 5
    Último Post: 04-11-2002, 23:36
  4. Vejam esse script firewall/nat, aonde tá o erro?
    Por no fórum Servidores de Rede
    Respostas: 5
    Último Post: 02-11-2002, 21:47
  5. Firewall + NAT
    Por rastaman no fórum Servidores de Rede
    Respostas: 5
    Último Post: 03-09-2002, 12:17

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L