+ Responder ao Tópico



  1. #1

    Padrão MOD_MONO aps.net Apache

    salve salve a todos


    galera, alguem ai já implementou o mod_mono e o xsp para rodar paginas em asp.net no apache ??

    Tipo, eu até consegui configurar, eu acho, mas não abre a maldita pagina..... se puderem me dar um help...

    eu recebo um Error Message: HTTP 500 . e não estou conseguindo ativar um log de erros nesse treco...

  2. #2

    Padrão MOD_MONO aps.net Apache

    Putz... nada q eu tento fazer ta resolvendo aqui... esse é o erro q está me retornando e eu não ot entendo nada:

    Código :
    Stack Trace:
     
    System.InvalidOperationException: Process has not been started.
    in <0x0003b> System.Diagnostics.Process:get_ExitCode ()
    in <0x00050> (wrapper remoting-invoke-with-check) System.Diagnostics.Process:get_ExitCode ()
    in <0x002bd> Mono.CSharp.CSharpCodeCompiler:CompileAssemblyFromFileBatch (System.CodeDom.Compiler.CompilerParameters,string[])
    in <0x0044a> Mono.CSharp.CSharpCodeCompiler:CompileAssemblyFromDomBatch (System.CodeDom.Compiler.CompilerParameters,System.CodeDom.CodeCompileUnit[])
    in <0x00050> Mono.CSharp.CSharpCodeCompiler:CompileAssemblyFromDom (System.CodeDom.Compiler.CompilerParameters,System.CodeDom.CodeCompileUnit)
    in <0x00171> System.Web.Compilation.CachingCompiler:Compile (System.Web.Compilation.BaseCompiler)
    in <0x002ea> System.Web.Compilation.BaseCompiler:GetCompiledType ()
    in <0x00251> System.Web.Compilation.AspGenerator:GetCompiledType ()
    in <0x00070> System.Web.UI.ApplicationFileParser:GetCompiledApplicationType (string,System.Web.HttpContext)
    in <0x00047> System.Web.HttpApplicationFactory:CompileApp (System.Web.HttpContext)
    in <0x00032> System.Web.HttpApplicationFactory:InitializeFactory (System.Web.HttpContext)
    in <0x0007a> System.Web.HttpApplicationFactory:GetInstance (System.Web.HttpContext)
    in <0x0010a> System.Web.HttpRuntime:InternalExecuteRequest (System.Web.HttpWorkerRequest)

    Niguem ai implementou isso ainda ??

    Ou se alguem souber algum modo de fazer a primeiro momento o apache reber a requisição e repassar para o IIS eu agradeço. Eu já uso mod_proxy, mas ele não está funcionando legal tb... não abre as imanges da pagina asp



  3. #3

    Padrão MOD_MONO aps.net Apache

    O apache iniciou sem problemas ?? não conheço muito de asp ou mesmo programação de paginas web... mas qual a ext. do index?

    mtec

  4. #4

    Padrão MOD_MONO aps.net Apache

    Sim, ele inicaliza normal ... esse modulo é apenas para o apache interpretar codigos asp, o ele não faz por padrao pelo q eu vi


    as extensões são aspx


    Eu tb não sei nada de aps e desenvolvimento web... tenho apenas q disponibilizar os recursos


    Vlw pela atenção



  5. #5

    Padrão MOD_MONO aps.net Apache

    Mas por exemplo : a página é index.aspx ??

    mtec

  6. #6

    Padrão MOD_MONO aps.net Apache

    sim, index.aspx



  7. #7

    Padrão MOD_MONO aps.net Apache

    pode parecer besteira e derrepente vc já até deu uma olhada... Mas vc acrescentou o index.aspx no http.conf??

    Pera ser mais exato na opção abaixo (dentro arquivo):

    <IfModule mod_dir.c>
    DirectoryIndex index.html index.htm index.php index.aspx
    </IfModule>

    Até :good: :good: :good:

  8. #8

    Padrão MOD_MONO aps.net Apache

    adicionei, mas não nessa mesma linha, adicionei na parte onde eu chamo o modulo



  9. #9

    Padrão MOD_MONO aps.net Apache

    Alem do modulo... é necessario incluir o index.aspx naquele setor do http.conf para que o apache ofereça suporte a estas páginas. Tente apenas por desencargo... Localize no http.conf e faça o teste !!

    Até

    :good: :good: :good:

  10. #10

    Padrão MOD_MONO aps.net Apache

    Eu tenho o conf separado pelo modulo, eu tenho essa linha para no conf do php e no conf do mod_mono ... o php está funcionando maravilha... só o mono q não... mas vou alterar de todo jeito...


    obrigado



  11. #11

    Padrão MOD_MONO aps.net Apache

    Flw...

    Se funcionar, não esqueça de postar !!!

    Até :good: :good: :good:

    mtec

  12. #12

    Padrão MOD_MONO aps.net Apache

    Como previa, alterei e sem sucesso....


    isso me parece alguma conf do modulo.... pois a pagina de erro já parece de paginas asp... ele aparente não estra interpretando os codigos....



  13. #13

    Padrão MOD_MONO aps.net Apache

    Bom... vlw pelo esforço. Com certeza já foge do meu entendimento...

    Boa sorte !!

    :good:

    mtec

  14. #14

    Padrão MOD_MONO aps.net Apache

    Bom galera, to me matando aqui ainda e não consigo fazer esse raio de mod_mono funcionar.. não acho onde estou errando....

    Tipo, consegui fazer o XSP (um web server escrito em C# para roda aplicações asp.net) funcionar. Aplicações em asp.net locais no meu server funcionam .

    Alguem tem algum bom material, link, apostila, vizinho, sogra, papagaio q possa ajudar em como colocar o Apache como uma especie de gateway para aplicações web ??

    (Lembrando, já uso mod_proxy mas ele não está funcionando com aplicações asp.net, só janelinha dos infernos pra fazer uma coisa dessas)



  15. #15

    Padrão MOD_MONO aps.net Apache

    Ae, essa é a pagina de teste que vem com o XSP.

    Isso é uma aplicação em aspx hospedada e rodando no meu server apache em uma maquina linux

    http://www.zenisys.com.br/imagens/gk...-05_103612.jpg

  16. #16

    Padrão MOD_MONO aps.net Apache

    Da uma olhada nesse link: http://www.linuxit.com.br/modules.ph...icle&artid=425

    Vê se te ajuda em alguma coisa !!

    mtec
    :good: :good: :good: