Amigo,

Como o outro disse, atualizar a glibc é meio arriscado, em caso de erro pode ir tudo pro espaço, quando tentar atualizar alguma dessas libs do sistema, recomendo formente que você faça uma backup antes. Assim se der algum problema você terá como restaurar o seu sistema.

No caso dos arquivos de sistema, o melhor é procurar na página da distribuição ou outra qualquer com pacotes prontos, pois eles já estão configurados para a distribuição desejada (refiro-me ao "./configure" e outros parâmetros setados direitinho de acordo com a organização das bibliotecas na determinada distribuição, pois existem inúmeros links que podem estar apontando para elas e instalar no local errado pode ocasionar o não funcionamento do sistema).

Uma boa também é estudar o pacote da versão anterior, para saber quais configurações foram aplicadas (me refiro ao "./configure" e seus parâmetros) e apartir dele gerar um pacote atualizado.

Veja este site de pacotes, de uma olhada, segue o link abaixo: