+ Responder ao Tópico



  1. #1
    max_mori
    Visitante

    Padrão apache não dá sinal de vida

    apache não dá sinal de vida

    o comando acionado

    apachectl restart

    e
    httpd restart

    e o apache está acionado mas
    no prompt do navegador não dá sem sinal de vida

    digito o ip da maquina e nada

    engraçado se eu desligar o iptables o navegador não funciona!!?!?!?!?



    Max_mori

  2. #2
    azanelato
    Visitante

    Padrão apache não dá sinal de vida

    Precisava de mais detalhes para poder ver o problema.

    Como está a configuração do seu Apache?

    Que linhas vc modificou e como elas ficaram?

    Alexandre Zanelato - azanelato



  3. #3
    max_mori
    Visitante

    Padrão apache não dá sinal de vida

    hosts

    127.0.0.1 localhost
    127.0.0.1 athlon2000
    127.0.0.1 athlon2000.com.br
    192.168.0.250 athlon2000.com.br
    192.168.0.250 athlon2000



    IfDefine APACHEPROXIED>
    Port 8080
    Listen 80
    Listen 192.168.0.250:8080
    </IfDefine>



    NameVirtualHost *

    <VirtualHost *>
    ServerAdmin [email protected]
    DocumentRoot /usr/local/sagu/html
    ServerName www.athlon2000.com.br
    ServerAlias athlon2000.com.br
    Options Indexes FollowSymLinks Includes
    #AllowOverride None
    #Order allow,deny
    #Allow from all
    # ErrorLog logs/host.some_domain.com-error_log
    # CustomLog logs/host.some_domain.com-access_log common
    </VirtualHost>

    NameVirtualHost athlon2000.com.br

    <VirtualHost athlon2000.com.br>
    ServerAdmin [email protected]
    DocumentRoot /usr/local/sagu/html
    ServerName athlon2000.com.br
    ServerAlias www.athlon2000.com.br
    # ErrorLog logs/host.some_domain.com-error_log
    # CustomLog logs/host.some_domain.com-access_log common
    </VirtualHost>

    NameVirtualHost *

    <VirtualHost *>

    ServerAdmin [email protected]
    DocumentRoot /usr/local/miolo/html
    ServerName localhost
    ErrorLog logs/miolo.develop.error_log
    CustomLog logs/miolo.develop.access_log common

    <Directory "/usr/local/miolo/html">
    Options FollowSymLinks
    AllowOverride All
    Order allow,deny
    Allow from all
    </Directory>

    </VirtualHost>


    apachectl restart
    Shutting down httpd2: [ OK ]
    Starting httpd2: httpd2: Could not determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
    [Tue Nov 22 18:33:10 2005] [error] VirtualHost _default_:443 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
    [Tue Nov 22 18:33:10 2005] [warn] NameVirtualHost *:0 has no VirtualHosts
    (98)Address already in use: make_sock: could not bind to address [::]:443
    no listening sockets available, shutting down
    Unable to open logs
    [FALHOU]

    httpd restart
    [Tue Nov 22 18:37:42 2005] [alert] httpd: Could not determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
    [Tue Nov 22 18:37:42 2005] [warn] NameVirtualHost *:0 has no VirtualHosts

  4. #4
    max_mori
    Visitante

    Padrão apache não dá sinal de vida

    Forbidden

    You don't have permission to access / on this server.

    Apache-AdvancedExtranetServer/1.3.33 Server at athlon2000.com.br Port 80


    mensagem do navegador quando coloco o endereco do ip da maquina



  5. #5
    max_mori
    Visitante

    Padrão apache não dá sinal de vida

    httpd -S
    [Tue Nov 22 19:17:09 2005] [alert] httpd: Could not determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
    [Tue Nov 22 19:17:09 2005] [warn] NameVirtualHost *:0 has no VirtualHosts
    VirtualHost configuration:
    127.0.0.1:* is a NameVirtualHost
    default server athlon2000.com.br (/etc/httpd/conf/vhosts/Vhosts.conf:72)
    port * namevhost athlon2000.com.br (/etc/httpd/conf/vhosts/Vhosts.conf:72)
    192.168.0.250:* is a NameVirtualHost
    default server athlon2000.com.br (/etc/httpd/conf/vhosts/Vhosts.conf:72)
    port * namevhost athlon2000.com.br (/etc/httpd/conf/vhosts/Vhosts.conf:72)
    wildcard NameVirtualHosts and _default_ servers:
    *:* is a NameVirtualHost
    default server www.athlon2000.com.br (/etc/httpd/conf/vhosts/Vhosts.conf:57)
    port * namevhost www.athlon2000.com.br (/etc/httpd/conf/vhosts/Vhosts.conf:57)
    port * namevhost localhost (/etc/httpd/conf/vhosts/Vhosts.conf:83)

  6. #6
    azanelato
    Visitante

    Padrão apache não dá sinal de vida

    Acho melhor colocar o Hosts assim:

    hosts

    127.0.0.1 localhost
    192.168.0.250 athlon2000.com.br
    192.168.0.250 athlon2000
    ---------------------------------------------------------------
    Listen - Acho melhor usar quando tiver mais de 1 placa de rede
    para acesso, se vc quiser trocar a porta de acesso, faça a
    mudança via iptables.

    #iptables -t nat -A PREROUTING -i eth0 -p tcp --dport 80 -j REDIRECT --to-port 8080
    ---------------------------------------------------------------
    Este NameVirtualHost abaixo deve ficar sem ação

    #NameVirtualHost *

    ou muda-lo para

    NameVirtualHost 192.168.0.250 #coloque o IP não o nome
    ---------------------------------------------------------------
    Na opção

    <VirtualHost>

    colocar o IP, ficando como abaixo

    <VirtualHost 192.168.0.250>
    ---------------------------------------------------------------
    Faça estas mudanças e depois teste, talvez dará outros erros,
    se der me envie os erros.

    Alexandre Zanelato - azanelato



  7. #7
    max_mori
    Visitante

    Padrão apache não dá sinal de vida

    deu +- certo

    quando coloco somente o ip

    ele abre um texto de php


    mas quando coloco
    192.168.0.250/athlon2000.com.br

    dá errado

    fala que não tenho direito ao acesso a está pasta

  8. #8
    azanelato
    Visitante

    Padrão apache não dá sinal de vida

    Vc tem DNS configurado neste servidor????

    E, aonde vc esta colocando esta linha - 192.168.0.250/athlon2000.com.br

    Acho que se vc colocar assim não vai funcionar mesmo.

    Que página de PHP abre???

    Meu e-mail é [email protected]
    me envie seu arquivo para eu poder ve-lo.

    Alexandre Zanelato - azanelato



  9. #9
    max_mori
    Visitante

    Padrão apache não dá sinal de vida

    como assim??

    configurei o etc/hosts

    coloquei conforme acima

    eu acho que não consegui ativar o module_php4

    ele está dando erro ao chamar o apachectl restart ou start
    o apache reclama que não pode ler o modulo no AddModule php4

  10. #10

    Padrão apache não dá sinal de vida

    E se voce colocar só athlon2000.com.br abre alguma coisa?

    Cara acho que você deveria dar uma olhada como é o funcionamento do servidor apache, por que parece que você não entende nada.


    Voce disse que quando digita somente o ip abre uma página com código php, posta o conteúdo dessa página aí.



  11. #11
    max_mori
    Visitante

    Padrão apache não dá sinal de vida

    realmente não entendo nada,
    mas estou lendo os manuais que encontro

    quando se le é uma coisa na prática não funciona 100%

    consequi ativar o miolo programa qua acompanha o sagu
    mas o php3 não está sendo ativado

    no momento estou em semana de teste na facul
    semana que vem vou rever os manuais

  12. #12
    max_mori
    Visitante

    Padrão apache não dá sinal de vida

    O miolo funciona bem mas quando chamo o saguteste.com.br não sobe

    NameVirtualHost 192.168.0.250

    <VirtualHost 192.168.0.250>
    ServerAdmin [email protected]
    DocumentRoot /usr/local/miolo/html
    ServerName www.miolo.br
    ServerAlias miolo.br
    DirectoryIndex index.html
    #ErrorLog logs/miolo.develop.error_log
    #CustomLog logs/miolo.develop.access_log common

    <Directory /usr/local/miolo/html>
    Options FollowSymLinks
    #AllowOverride All
    Order allow,deny
    Allow from 192.168.0.250 192.168.0.254 192.168.0.1 192.168.0.2 192.168.0.3
    </Directory>

    </VirtualHost>



    <VirtualHost 192.168.0.250>
    ServerAdmin [email protected]
    ServerPath /html
    DocumentRoot /usr/local/sagu/html
    ServerName www.saguteste.com.br
    ServerAlias saguteste.com.br
    DirectoryIndex index.php3
    # ErrorLog logs/host.some_domain.com-error_log
    # CustomLog logs/host.some_domain.com-access_log common

    <Directory /usr/local/sagu/html>
    Options Indexes Includes FollowSymLinks
    #Options FollowSymLinks
    AllowOverride None
    #All
    Order allow,deny
    Allow from 192.168.0.250 192.168.0.254 192.168.0.1 192.168.0.2 192.168.0.3
    </Directory>


    </VirtualHost>



    tem algum script de php simples para teste??



  13. #13
    max_mori
    Visitante

    Padrão apache não dá sinal de vida


  14. #14
    max_mori
    Visitante

    Padrão apache não dá sinal de vida

    agora quando digito o ip da minha maquina consigo ver o diretório e o conteudo e abrir o arquivo como texto ( quando clico em um arquivo index.php3) o que pode ser??

    MAS QUANDO CLICO NO PHPINFO.PHP ABRE NORMALMENTE.



  15. #15
    max_mori
    Visitante

    Padrão apache não dá sinal de vida

    php informações

    HTTP Headers Information

    HTTP Request Headers
    HTTP Request GET /phpinfo.php HTTP/1.1
    Connection close
    User-Agent Mozilla/5.0 (compatible; Konqueror/3.3; Linux) KHTML/3.3.2 (like Gecko)
    Referer http://192.168.y.xx/
    Accept text/html, image/jpeg, image/png, text/*, image/*, */*
    Accept-Encoding x-gzip, x-deflate, gzip, deflate
    Accept-Charset iso-8859-1, utf-8;q=0.5, *;q=0.5
    Accept-Language pt, en
    Host 192.168.y.xx

    HTTP Response Headers

    X-Powered-By PHP/4.3.10
    Connection close
    Transfer-Encoding chunked
    Content-Type text/html

  16. #16
    max_mori
    Visitante

    Padrão apache não dá sinal de vida

    Apache Environment

    Variable Value


    HTTP_CONNECTION close

    Como consigo abrir a conecção ??