+ Responder ao Tópico



  1. #1

    Padrão Bind nao resolve alguns sites.

    Ola,
    utilizo esse server a uns anos e o Linux instalado é o Suse 7.3 e a versao do Bind a 8.2, nele tenho uma conexao PPP c/ ip 200.232.71.XX, realmente eh antiga a versao do Bind. Mas aki vem funcionando muito bem e nao tenho tido problemas, até uns dias atraz. Alguns clientes comecaram a reclamar q nao conseguiam acessar alguns sites.

    Acontece q esse nao resolve alguns dominios, especificamente esses: sorocred.com.br, fadi.br e albaadesivos.com.br. Tenho um adsl e consigo obter o ip desse sites e fazendo um trace no meu server vejo q nao ha problemas de roteamento.

    A questão eh mesmo pra resolver esses dominios, resolvi entao atualizar o arquivo root.hint, atravez do site internic.net. Mas mesmo assim o problema persisti.

    Conto com a costumeira atençao do amigos e de suas experiencias pra me ajudarem a resolver esse problema.

  2. #2

    Padrão Bind nao resolve alguns sites.

    estranho, isso, né? bem, vamos tentar analisar com as ferramentinhas que dispomos. Usando o dig:

    dig dominio.pesquisado.esquisito

    se houver uma resposta, então seu servidor estará ok (isto é, se estiver mencionado no /etc/resolv.conf).

    não tendo havido resposta, use outro servidor:

    dig @200.227.128.20 mesmo.dominio.anterior

    êsse ip aí é da embratel então, supostamente, deveremos ter resposta, agora.

    não sei pq tenho um problema similar acontecendo em um FreeBSD 5.21-RC, mas como vou trocar pelo 5.4, não estou me preocupando muito. A sugestão é vc REALMENTE substituir o bind pelo 9.xx. Uma outra coisa que vc pode fazer é acrescentar êsse servidor aí (embratel) no forward do seu bind. Pode ser que o seu forward atual não esteja mais com vontade de responder (experimente-o, também, com o dig).

    bem.. divirta-se.



    :twisted:



  3. #3

    Padrão Bind nao resolve alguns sites.

    Valeu irado, agora deu pra confirmar q o problema eh aki com esse meu dns.

    Tem como acompanhar os logs das consultas q sao realizadas no meu bind?

    Será que nao tem uma explicacao?

  4. #4

    Padrão Bind nao resolve alguns sites.

    "Tem como acompanhar os logs das consultas q sao realizadas no meu bind?"

    hmmm.. francametne.. não lembro bem. Quem sabe um

    tail -f /var/log/named.log (acho que é êsse)

    "Será que nao tem uma explicacao?"

    deve ter. Eu não fui atrás, na verdade.

    :twisted:



  5. #5

    Padrão Bind nao resolve alguns sites.

    cara...

    já tive problema desse tipo, e percebi q envolvia o pppoe, DNS, /etc/resolv.conf e Squid...

    tipo...

    qdo conectava o adsl mudava os endereços do resolv.conf, então o squid pegava estes endereços, ae dava problema no DNS..

    então resolvi o problema de qdo o pppoe conectar não alterar os endereços e o problema se resolveu...

  6. #6
    alex_sorocaba
    Visitante

    Padrão Bind nao resolve alguns sites.

    seu bind antigo vai funcionando bem até o dia que alguém rootiar seu server