Página 6 de 6 PrimeiroPrimeiro ... 23456
+ Responder ao Tópico



  1. #26
    bob_linux
    Citação Postado originalmente por x-fabio-x
    bob, voce rodou algum pppoeconf? pois no debian existe o pppoeconf, no conectiva nao me lembro... esse pppoeconf acho que ele ja define as rotas para voce... para tu nao precisar dar route del default e route add ....


    ?????
    fabio em conectiva estou começando agora não se existe esse arquivo tb...

  2. #27
    bob_linux
    consegui resolver o problema, era os cabos de rede invertidos, aparentemente era isso...!!

    valeu galera..



  3. olá..karo colega....to com um link da BrasilTelecom num slack10.2 com proxy cache..ae vai a conf q usei...flws...


    /etc/rc.d/rc.local

    #Modulo Placa de Rede
    echo "Modulo Placa De Rede"
    /sbin/modprobe 3c59x
    #
    #
    #Regras de NAT
    echo "Regras de NAT"
    iptables -t nat -A POSTROUTING -o ppp0 -s 192.168.0.0/24 -j MASQUERADE
    #Regra para Squid Transparente
    iptables -t nat -A PREROUTING -i eth0 -p tcp --dport 80 -j REDIRECT --to-port 3128
    #
    #
    #Conectando ADSL
    echo "Conectando ADSL"
    /usr/sbin/adsl-start
    #
    #
    #Rodando DDClient
    echo "Iniciando DDClient"
    /usr/sbin/ddclient
    #
    #
    #Iniciando Squid Transparente
    echo "Rodando Squid"
    /usr/local/squid/sbin/squid -D
    #
    #
    #Rodando CBQ
    echo "Rodando CBQ"
    /sbin/cbq start





    /etc/rc.d/rc.inet1

    # Config information for eth0:
    IPADDR[0]="192.168.0.1"
    NETMASK[0]="255.255.255.0"
    USE_DHCP[0]=""
    DHCP_HOSTNAME[0]=""

    # Config information for eth1:
    IPADDR[1]=""
    NETMASK[1]=""
    USE_DHCP[1]=""
    DHCP_HOSTNAME[1]=""



    /etc/ppp/pppoe.conf

    ETH='eth1'
    USER='vsf@zipfoz.com'
    DEMAND=no
    DNSTYPE=SPECIFY
    PEERDNS=no
    DNS1=200.203.207.71
    DNS2=200.199.201.24
    DEFAULTROUTE=yes
    CONNECT_TIMEOUT=30
    CONNECT_POLL=2
    FIREWALL=MASQUERADE
    PPPOE_TIMEOUT=80

    o resto deixa padrão do arquivo pppoe.conf





    /usr/local/squid/etc/squid.conf

    acl all src 0.0.0.0/0.0.0.0
    acl manager proto cache_object
    acl localhost src 127.0.0.1/255.255.255.255
    acl SSL_ports port 443 563
    acl Safe_ports port 80 # http
    acl Safe_ports port 21 # ftp
    acl Safe_ports port 443 563 # https, snews
    acl Safe_ports port 70 # gopher
    acl Safe_ports port 210 # wais
    acl Safe_ports port 1025-65535 # unregistered ports
    acl Safe_ports port 280 # http-mgmt
    acl Safe_ports port 488 # gss-http
    acl Safe_ports port 591 # filemaker
    acl Safe_ports port 777 # multiling http
    acl Safe_ports port 901 # SWAT
    acl purge method PURGE
    acl CONNECT method CONNECT

    http_access allow manager localhost
    http_access deny manager
    http_access allow purge localhost
    http_access deny purge
    http_access deny !Safe_ports
    http_access deny CONNECT !SSL_ports

    # Filtros por palavras e por dominios
    acl proibidos dstdom_regex "/usr/local/squid/etc/proibidas"
    http_access deny proibidos
    #acl bloqueados dstdomain orkut.com www.orkut.com playboy.abril.com.br
    #http_access deny bloqueados

    # Libera para a rede local
    acl redelocal src 192.168.0.0/24
    http_access allow localhost
    http_access allow redelocal
    # Bloqueia acessos externos
    http_access deny all

    # Proxy transparente
    httpd_accel_host virtual
    httpd_accel_port 80
    httpd_accel_with_proxy on
    httpd_accel_uses_host_header on

    cache_mem 128 MB
    cache_swap_low 85
    cache_swap_high 90
    ipcache_size 1024
    ipcache_low 90
    ipcache_high 95
    fqdncache_size 1024
    cache_dir ufs /usr/local/squid/cache 15000 16 256

    cache_effective_user nobody
    cache_effective_group nogroup


    ifconfig

    eth0 Link encap:Ethernet HWaddr 00:50:04:A4:F3:F1
    inet addr:192.168.0.1 Bcast:192.168.0.255 Mask:255.255.255.0
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:2101123 errors:0 dropped:0 overruns:0 frame:0
    TX packets:2226916 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:851372975 (811.9 Mb) TX bytes:1573068270
    Interrupt:5 Base address:0x9400

    eth1 Link encap:Ethernet HWaddr 00:50:04:EE:7F:B1
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:2334981 errors:0 dropped:0 overruns:0 frame:0
    TX packets:2146552 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:1637356211 (1561.5 Mb) TX bytes:865239716
    Interrupt:10 Base address:0x9000

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:12 errors:0 dropped:0 overruns:0 frame:0
    TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:600 (600.0 b) TX bytes:600 (600.0 b)

    ppp0 Link encap:Point-to-Point Protocol
    inet addr:201.10.70.56 P-t-P:201.14.31.254 Mask:255.255.255.255
    UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1492 Metric:1
    RX packets:2331768 errors:0 dropped:0 overruns:0 frame:0
    TX packets:2143341 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:3
    RX bytes:1584620245 (1511.2 Mb) TX bytes:817737103

    qualquer coisa posta ae...



    Citação Postado originalmente por bob_linux
    Olá Pessoal estou com algumas duvidas estou começando agora a trabalhar com linux e já logo de cara peguei dois serviços bem complicados, mas estou lutando para adquirir novos conhecimentos.
    a primeira duvida eh a seguinte, estou montando um servidor de internet adsl (speedy home), e preciso distribuir o sinal da net para as demais maquinas windows, porém o meu servidor conecta, mas não consigo navegar e muito menos distribuir o sinal da net para as demais, mas se eu pingar nas duas placas de rede a partir de qq maquina, elas me retornam sem erros, não sei aonde estou errando, ou se falta mais alguma coisa para funcionar essa rede!
    a configuração da minhas placas de rede são essa

    Realteck
    device = eth0
    IPADDR= 192.168.1.254
    NETMASK=255.255.255.0
    HOSTNAME= SERVIDOR
    DOMAIN = CENTER


    VIA
    DEVICE = ETH1
    ONBOOT = YES
    BOOTPRO= STATIC
    IPADDR= 192.168.1.1
    NETMASK = 255.255.255.0
    GATEWAY = 192.168.1.100

    no
    # vi /etc/resolv.conf
    nameserver: coloquei o dns do meu provedor, mas não sei se eh correto

    no /etc/hosts coloquei o IP do meu servidor,
    mas mesmo assim nada acontece, aonde estou errando?
    por favor preciso de um HELP..


    a segunda duvida eh q peguei um serviço em andamento e a pessoa q tinha a senha morreu! resultado levou a senha com ele, e preciso quebrar a senha de tudo qto eh jeito! ja tentei usando o CD do kurumin mas ele não deixa eu alterar !!
    a maquina eh um pentium 100mhz com 32mb, que linux instalaria nela se fosse o caso?

  4. Bom, vamos parar de discutir e nos concentrar em resolver o problema do cara.

    Como ele disse em sua primeira mensagem, ele está usando um Speedy Home. Supondo que o modelo dele seja de 3 anos pra cá (O que é muito provável), ele vai utilizar PPPoE. Modelos PPPoA estão quase extintos.

    Ele também perguntou "Qual Linux usar?". Então, pela trilhonésima vez, nós vamos responder que o melhor GNU/Linux é aquele que ele se sentir mais à vontade. Entretanto, como é uma máquina mais antiga, eu sugiro que ele utilize uma distribuição leve, como Debian ou Slackware.

    Se ele utilizar Debian, ele só vai precisar adicionar no arquivo /etc/network/interfaces a segunda placa de rede dele (Estou supondo que ele configurou a primeira na instalação, então ela já deve estar disponível no arquivo), da seguinte maneira:

    Código :
    auto eth1
    iface eth1 inet static
            address 192.168.1.1
            netmask 255.255.255.0
            network 192.168.1.0
            broadcast 192.168.1.255

    Depois ele deve rodar o utilitário pppoeconf. Este utilitário é responsável pela configuração de ADSL em máquina Debian, criando um device específico, chamado ppp0.

    Depois ele pode só rodar este scriptzinho:

    Código :
    #!/bin/bash
    route del default
    route add default dev ppp0
    echo 1 > /proc/sys/net/ipv4/ip_forward
    iptables -t nat -A POSTROUTING -o ppp0 -j MASQUERADE

    Depois ele pode jogar isso na inicialização do servidor, configurar o gateway das máquinas e pronto. Está mastigado, mas se ele quiser saber mais sobre o assunto, o problema é dele. Afinal de contas, isso que define o tipo de profissional que ele é.

    Abraços, e eu também espero que ninguém fique chateado comigo não...






Tópicos Similares

  1. Dúvidas ao usar o Firebird no Linux.
    Por Bit no fórum Servidores de Rede
    Respostas: 5
    Último Post: 29-06-2005, 11:03
  2. Respostas: 7
    Último Post: 27-06-2005, 13:39
  3. servidor de internet Linux
    Por reyero no fórum Servidores de Rede
    Respostas: 5
    Último Post: 22-12-2004, 21:15
  4. Servidor de Internet Linux
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 06-05-2003, 19:28
  5. Servidor de Internet Linux
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 10-04-2003, 13:44

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L