+ Responder ao Tópico



  1. #61

    Padrão Estou perdida!!!

    Citação Postado originalmente por natascha
    iptables: bad built-in chain name
    num acontece nada disso qdo vc tenta criar o masquerade ou qq outra regra?
    ta estranho issu, por acaso vc nao recompilou o kernel não neh?
    Citação Postado originalmente por natascha
    nas estações windows é só colocar em "gateway padrão" o ip do servidor firewaal, não é?
    issu, e configurar o dns neles tb

  2. #62



  3. #63
    Visitante

    Padrão Estou perdida!!!

    putz...já se discutiu tanto sobre "respostas google" e ainda aparece......

    se eu coloquei o problema aqui é pq não estou achando a solução nas respostas dos sites de busca

    se a resposta estivesse 100% no google, não existira fórum né...

  4. #64



  5. #65

    Padrão Estou perdida!!!

    Triste...

    Mas isso é só pra aparecer...

    Se incomoda tanto, pra que ter o trabalho de procurar no google... e ainda postar aqui ?

    Acho que quem incomoda mais são essas pessoas.

  6. #66

    Padrão Estou perdida!!!

    sem rodeios , 4 posts que nao ajudam mto... sigh... aparanemente o problema dela nao é tao usual, got it?

    seguinte, sei que é o padrao mas tente ai e ve se o dao mesmo erro:

    iptables -t filter -P FORWARD ACCEPT
    iptables -L -n



  7. #67

    Padrão Estou perdida!!!

    [email protected]:~# iptables -P forward DROP
    iptables: Bad built-in chain name
    [email protected]:~# iptables -A forward -s 192.168.1.0/24 -j MASQUERADE
    iptables: No chain/target/match by that name
    outra coisa que eu percebi olhando nos forums e na google é que quando voce digita o nome de uma chain de maneira errada da isso, isos é facilmente notado pelo exemplo acima.


    como voce esta digitando?

    e outra: mostre o resultado do
    lsmod


    é isso por enqto.

  8. #68

    Padrão Estou perdida!!!

    iptables -t filter -P FORWARD ACCEPT

    -nada acontece, não dá erro

    iptables -L -n

    Chain INPUT (Policy accept)
    target opt prod source destination

    Chain FORWARD (Policy accept)
    target opt prod source destination

    Chain OUTPUT (Policy accept)
    target opt prod source destination


    lsmod

    - exibe uma grande lista de módulos, como os das placas, ipt_MASQUERADE, ip_tables, iptables_nat, iptables_filter


    é realmente necessário recompilar o kernel? o processo para isso é o mesmo independente da distro?

    thanks



  9. #69

    Padrão Estou perdida!!!

    Não precisa recompilar o kernel nao, eh q se tinha dado aquele erro e a regra tinha sido digitada corretamente, provavelmente seria algo relativo a versao iptables+kernel.Bom essa possibilidade já foi descartada.

    Você não ta conseguindo navegar ainda pela rede neh, nos clientes vc jah tentou dar ping,traceroute,etc. pra ver oq acontece?

  10. #70

    Padrão Estou perdida!!!

    Citação Postado originalmente por natascha
    iptables -P FORWARD ACCEPT
    iptables -P OUTPUT ACCEPT


    resposta dos comandos acima:

    iptables: bad built-in chain name

    nas estações windows é só colocar em "gateway padrão" o ip do servidor firewaal, não é?
    natascha, Se possível, me retonar a saida desses comando

    digita os comandos:

    iptables -L -v
    iptables -L -v -t nat

    route

    cat /etc/resolv.conf



  11. #71
    frpaes
    Visitante

    Padrão Estou perdida!!!

    Citação Postado originalmente por Marcio68Almeida
    Citação Postado originalmente por frpaes
    Manda o teu msn que eu te ajudo !

    o meu e: [email protected]
    Não tem jeito... a gente cansa de dizer para ajudar por aqui mas sempre tem gente a fim de fazer isso de forma particular...
    Como o grupo pode crescer se as soluções são feitas de modo reservado ???
    :@:
    Pois parece que o grupo e inoperante a a Natasha ta meio desesperada para funcionar. logo, assim que ela chegasse a uma solucao, a mesma seria postada para os outros.

  12. #72

    Padrão Estou perdida!!!

    aparentemente voce ta ok, de modulos, politicas default (td aberto mas de comeco ta ok), o ip forward, e no iptables -t nat ... da erro ou funciona redondo? e quanto a acessar internet do firewall, eh possivel? ou jah funcionou? resolveu? hehe

    teoricamente parece nao ter mais problemas, pois o par iptables/kernel parece ok! mas se vc jah fez tudo isso e ainda assim nao deu certo... eh bom partir para o teste de recompilar kernel + iptables (ultima solucao) caso voce nao tenha conseguindo.
    outra saida se estiver com hd dando sopa ai eh instalar outra distro e testar para ver se nao eh algum bug chato q veio nessa, falando nisso qual eh a distro q vc ta usando?



  13. #73
    Visitante
    Visitante

    Padrão Engracado

    CARACA ACHO QUE EU NUNCA VI ISSO NO FORUM ... 5 PAGINAS PARA TIRAR DUVIDAS, SE FOSSE DE UM CUECA O CARA TAVA FU... MAS ACHO QUE ESTA CERTINHO TEMOS QUE INCENTIVAR A MULHERADA...

  14. #74
    felco
    Visitante

    Padrão Estou perdida!!!

    bah

    voce ligo o redirecionamento de pacotes?
    # echo 1 > /proc/sys/net/ipv4/ip_forward



  15. #75

    Padrão Estou perdida!!!

    Com os comandos

    iptables -L -v

    lista muuuita coisa

    iptables -L -v -t nat

    Chain INPUT (policy ACCEPT 842 packets, 9523 bytes)
    pkts bytes target prot opt in out source destination

    Chain FORWARD (policy ACCEPT 0 packets, 0 bytes)
    pkts bytes target prot opt in out source destination
    10 614 MASQUERADE all -- any eth1 anywhere anywhere



    Chain OUTPUT (policy ACCEPT 5 packets, 409 bytes)
    pkts bytes target prot opt in out source destination


    já coloquei o comando

    echo 1 > /proc/sys/net/ipv4/ip_forward

    zilhões de vezes, ele retorna 1.


    na máquina em que está ligado o roteador, a internet funciona. as estações é que não acessam...mudei o gateway..o dns...e nada

  16. #76

    Padrão Estou perdida!!!

    EEEE!!! Descobri o que acontecia...estava fazendo a configuração nas estações igual a servidor windows, colocando ip da máquina em gateway e em dns. a minha companheira de cpd achou um arquivo explicando essa parte e coloquei o dns nas estações tbm, não o ip e funcionou :clap:

    bom...agora vou partir para as regras do firewall. valeu pelos auxílios pessoal!

    ula:



  17. #77

    Padrão Estou perdida!!!

    Aeeee


    6 páginas depois conseguiu \o/

    agora as regras de firewall é algom bem "pessoal" que voce tem que cria-las de acordo com seu ambiente... voce concerteza vai achar varios scripts prontos por ae, use-os para tirar base para montar o seu



    Boa Sorte

  18. #78
    cyber_stroke
    Visitante

    Padrão Já conseguiu Natascha ?

    Voce já conseguiu Natascha ?



  19. #79

    Padrão Estou perdida!!!

    Eu segui o livro da Conectiva e coloquei alguns comandos do iptables...depois fiz o teste da Symantec e deu que está tudo seguro, portas fechadas ou ocultas. Ainda vou estudar um pouco as regras, pois apenas coloquei os comandos, preciso saber qual a função de cada letrinha

    mas o compartilhamento, está ok. o problema é que estava configurando as estações da mesma maneira que servidor windows, depois descobri que é diferente....=]

    obrigada!

  20. #80
    marcelofelipe
    Visitante

    Padrão Estou perdida!!!

    Natascha,

    Como vc. já configurou o sevidor Samba , creio que vc. não vai ter muita dificuldade de configurar a Internet.
    Primeiro , eu começaria configurando o Firewall como Gateway da rede .
    Tenha em mãos as configurações da conexão externa, tais como IP e Gateway
    Alguns roteadores já configuram automaticamente por dhcp, caso não seja o teu caso
    precisaremos configurar manualmente. Faz algum tempo que não uso o Conectiva,
    por isso não me lembro quais arquivos devemos alterar, porém para efeito de testes, faça o seguinte , como root :

    ifconfig

    Mostra a configuração das Interfaces de rede ) no caso eth0 e eth1 )

    Como padrão costumo colocar a Internet na eth0

    ifconfig eth0 ip_externo

    Se o modulo da placa de rede estiver carregado , isso fará com que o
    assuma o ip da rede externa.

    Agora precisamos definir uma rota padrão para o acesso à Internet :

    route add -net 0/0 gw ip_do_gateway

    Agora precisamos habilitar o roteamento da Rede Interna

    echo "1" > /proc/sys/net/ipv4/ip_forward

    Normalmente este Flag está em "0", com este comando ele passa para '1"

    Agora precisamos configurar o DNS

    vi /etc/resolv.conf
    nameserver ip_servidor_dns ( fornecido pelo Provedor )

    Você também pode ativar o serviço de DNS local ( bind ) e substituir o ip_servidor_dns
    por 127.0.0.1

    Se a conexão estiver ok, vc vai conseguir pingar para a Internet .

    ping www.terra.com.br

    Se não funcionar , tente inverter os cabos de rede ( vc já está com as duas placas de rede instaladas )

    Configure agora a Rede Interna :

    ifconfig eth1 ip_interno

    Agora tente pingar uma máquina da sua rede interna .

    Se deu certo agora provavelmente as máquinas da tua rede estáo navegando .
    É preciso apenas configurar o ip do gateway nas configurações da rede do windows e o
    Servidor de DNS . O mesmo do teu provedor ou o ip do gateway caso vc. tenha ativado o bind.

    Tente navegar pelo ruwindows .

    Esta configuração não é segura pois vc. está acessando a Internet sem firewall.

    Aqui entra o iptables , além disso vc pode usar o squid para definir regras de acesso, bloquear sites, etc.
    Agora creio que vai ficar mais fácil configurar o Firewall .

    Espero ter ajudado

    Marcelo Felipe