+ Responder ao Tópico



  1. #1

    Padrão Roteador Cisco1600

    Pessoal,

    Tenho um roteador Cisco1600 em meu provedor. Raras foram as vezes que tive que mexer nele por qualquer motivo e por isso nunca lembro os comandos de cabeça.

    A situação é a seguinte:

    WAN: IP DA OPERADORA
    Porta LAN: 200.163.208.0/25 & 200.140.222.128/25

    Além disso a rede 200.163.208.0/25 é subdividida e enviada para outro servidor pelas rotas do Cisco, ou seja, a rede é separada e os pacotes enviados para 200.163.208.64/26 são enviados para o gateway 200.163.208.3 que faz o caminho para ela.

    O que preciso é fazer com que a rede 200.140.222.128/25 seja direcionada para esse mesmo 200.163.208.3.

    Que comando devo usar?

  2. #2

    Padrão Re: Roteador Cisco1600

    moleza, basicamente assim:

    > enable
    # conf term
    (conf)# ip route 200.140.222.128 0.0.0.127 200.163.208.3
    ^Z
    #

    e voiola... ai é so dar um: "copy run start" (ou write memory, dpendendo da versao do IOS) para na hora do reload ele nao perder as configs, teste aí e veja se ta tudo ok



  3. #3

    Padrão Re: Roteador Cisco1600

    Com certeza comando ip route:

    sintaxe: ip route rede mascara gateway

    Abraço

  4. #4

    Padrão Re: Roteador Cisco1600

    mascara = mascara coringa, mais conhecida como wildcards, ACL's da Cisco so trabalham com wildcards e nao netmasks. So cuidado com isso.



  5. #5

    Padrão Re: Roteador Cisco1600

    Citação Postado originalmente por mistymst
    moleza, basicamente assim:

    > enable
    # conf term
    (conf)# ip route 200.140.222.128 0.0.0.127 200.163.208.3
    ^Z
    #

    e voiola... ai é so dar um: "copy run start" (ou write memory, dpendendo da versao do IOS) para na hora do reload ele nao perder as configs, teste aí e veja se ta tudo ok
    myst,

    Eu fiz assim:

    cybernet(config)#ip route 200.140.222.128 0.0.0.127 200.163.208.3
    %Inconsistent address and mask

    Retornou esse erro.

    Dai tentei assim:

    cybernet(config)#ip route 200.140.222.128 255.255.255.128 200.163.208.3


    Não retornou nenhum erro e ficou assim a listagem de rotas:

    cybernet#show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
    U - per-user static route, o - ODR

    Gateway of last resort is 200.181.225.25 to network 0.0.0.0

    200.140.222.0/25 is subnetted, 1 subnets
    S 200.140.222.128 is directly connected, Ethernet0
    is directly connected
    200.163.208.0/26 is subnetted, 2 subnets
    C 200.163.208.0 is directly connected, Ethernet0
    S 200.163.208.64 [1/0] via 200.163.208.3
    200.181.225.0/24 is variably subnetted, 2 subnets, 2 masks
    C 200.181.225.24/30 is directly connected, Serial0
    C 200.181.225.25/32 is directly connected, Serial0
    S* 0.0.0.0/0 [1/0] via 200.181.225.25

    Mas não está funcionando ainda...

    Quando eu fiz a rota em negrito eu usei um comando estranho que não me lembro mais...

  6. #6

    Padrão Re: Roteador Cisco1600

    Sequelas no dia, maldita gripes... calculando wildcard para ip route, sniff, bom deixa eu da uma lida...

    bom nao parece muito ok ainda, faz o seguinte:

    manda o teu show running-config tirando a parte da senhas para eu dar uma analisada legal, o show ip route jah temos, ai so falta isso para analisar, pq ele nao criou legal a rota nao... essa em negrito ta como se a rede fosse /26 e nao /25, de repente pode ser um comandinho que ta faltando, por isso preciso ver o teu show run



  7. #7

    Padrão Re: Roteador Cisco1600

    mist,

    Desculpe a demora mas está uma correria absurda aqui na empresa. Vamos lá, eu rodei o running conf e resultou nisso:

    Código :
    cybernet#show running-config
    Building configuration...
     
    Current configuration:
    !
    version 12.0
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname cybernet
    !
    enable secret 5 ?????
    enable password ?????
    !
    username ??????
    ip subnet-zero
    !
    !
    !
    interface Ethernet0
     ip address 200.163.208.1 255.255.255.192
     no ip directed-broadcast
    !
    interface Serial0
     ip address 200.181.225.26 255.255.255.252
     no ip directed-broadcast
     encapsulation ppp
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 200.181.225.25
    ip route 200.140.222.128 255.255.255.128 Ethernet0
    ip route 200.140.222.128 255.255.255.128 200.163.208.3
    ip route 200.163.208.64 255.255.255.192 200.163.208.3
    !
    snmp-server community public RO
    banner login ^CC
     
       ###### #  # ###### ##### #####
       #   ## # #    #   #
      #   # # # ###   #   #
      #   # ## #    #   #
     ###### #  # ######  #   #
     
        C Y B E R N E T T
      Powered by Brasil Telecom
     
    ^C
    !
    line con 0
     password ?????
     login
     transport input none
    line vty 0 4
     password ???????
     login
    !
    end

    Espero que consiga me ajudar...

  8. #8

    Padrão Re: Roteador Cisco1600

    opa da sim, o problema é o seguinte:

    ip route 0.0.0.0 0.0.0.0 200.181.225.25
    ip route 200.140.222.128 255.255.255.128 Ethernet0
    ip route 200.140.222.128 255.255.255.128 200.163.208.3
    ip route 200.163.208.64 255.255.255.192 200.163.208.3

    se tu fores ver tem 2 rotas para a mesma rede:

    ip route 200.140.222.128 255.255.255.128 Ethernet0
    ip route 200.140.222.128 255.255.255.128 200.163.208.3

    vamos ajeitar isso, eu normalmente nao gosto de fazer o rotas dizendo a interface para sair, isso nem sempre funciona decentemente, inclusive quando sao jogadas em redes que nao sao ponto a ponto, jah nos enlances seriais nao tem tanta dor de cabeca, mas jah ocorrerao problemas com essa utlilizacao em alguns IOS (mesmo que esteja correto), entao prefiro sempre deixar o ip do proximo salto.

    vamos o seguinte, tire a seguinte rota:

    #conf term
    (conf)# no ip route 200.140.222.128 255.255.255.128 Ethernet0
    ^Z

    e verifica tua tabela de roteamento novamente e ve se a rota esta adicionanda corretamente

    Acredito que seja so esse o problema, analisando seu running-config so vejo esse problema testa e me fala.



  9. #9

    Padrão Re: Roteador Cisco1600

    Meu amigo Myst,

    Funcionou perfeitamente bem... Agora sim meus clientes PPPoE terão IP roteável...