+ Responder ao Tópico



  1. #1
    omaximo
    Visitante

    Padrão PHP Não utilizando php.ini

    Olá pessoal!!

    Instalei o php 5.0.4 em um Conectiva 10 e está acontecendo o seguinte:
    O apache está interagindo normalmente com o php, porém, quando efetuo alteração no arquivo php.ini (/etc) e restarto o serviço do apache nada muda, ou seja, a alteração parece ser ignorada ou parece não estar usando o php.ini.
    Já procurei por arquivos php.ini em outros diretórios e não existe nenhum.
    A função phpinfo() mostra que o php está buscando o arquivo php.ini no diretório /etc.

    Na verdade a alteração que preciso é setar a variável register_globals para on.

    Qualquer ajuda agradeço.

  2. #2

    Padrão Re: PHP Não utilizando php.ini

    provavelmente vc tem + de 1 php.ini na tua maquina e vc ta alterando o errado...

    find / -name php.ini



  3. #3
    omaximo
    Visitante

    Padrão Re: PHP Não utilizando php.ini

    Infelizmente não tenho mais nenhum arquivo não, como já coloquei no tópico principal, só existe este.
    Outro teste que já executei foi renomear o arquivo (ficando assim o servidor sem um arquivo php.ini) e mesmo assim as configurações permanecem inalteradas, ou seja, o apache/php não utiliza o arquivo php.ini.

  4. #4

    Padrão Re: PHP Não utilizando php.ini

    o php nao vai funcionar sem o arquivo de conf dele, ou ele ta usando arquivo com nome diferente, ou vc nao fez a busca?



  5. #5
    fnegreiros
    Visitante

    Padrão Re: PHP Não utilizando php.ini

    Verifique se vc. possui mais de uma instalação de PHP atuando na máquina e veja se realmente em "/etc" não existe o INI. Sua PHP foi compilado e instalado ou foi adicionado durante a instalação do S.O. ?


    Fabiano Negreiros

  6. #6

    Padrão Re: PHP Não utilizando php.ini

    Se o seu PHP foi compilado, tu tem que dar uma olhada no que você apontou como diretório de localização do php.ini na hora da compilação.


    Abraços!