+ Responder ao Tópico



  1. #1
    ferreiralinux
    Bom dia

    Galera tenho o squid, sarg e apache instalado, onde dar para ver os relatorios do sarg via browser, mas estava querendo colocar senha para entrar no relat, achei um artigo com os seguinte dizeres abaixo, mas quando digito service apache star. da o seguinte erro:


    Desligando apache: Syntax error on line 367 of /etc/apache/conf/httpd.conf: AuthName not allowed here [FALHOU]

    Alguem pode mim ajudar.


    Apache: Servidor web quebrando um galhão
    Foi fácil demais... :-p
    # apt-get install apache
    # vi /etc/apache/httpd.conf
    Nem precisa mudar muita coisa... só uma alteraçãozinha para não mostrar a versão do mesmo, para dificultar um pouco o povo que gosta de invadir os servidores por ae: :-)
    Se sua porta 80 estiver bloqueada (speed home) terá que usar outra...
    Port 80
    ServerSignature Off
    ServerTokens Prod
    Iniciando...
    # /etc/init.d/apache start
    Agora sim! De qualquer lugar, digitando http://ip.do.server eu chego nos tão esperados relatórios de acesso a internet!
    Como um ótimo complemento, vou deixar aqui a dica de outro usuário do site, o Guilherme Straioto:
    " Use o apache com autenticação de usuário, para apenas o pessoal da TI poder ver os relatórios como aqui na empresa... abaixo como fiz, senão você sabe vira festa:
    No httpd.conf, edite as tag DocumentRoot e Directory :
    DocumentRoot "/var/www/squid-reports/"
    e logo abaixo:

    AuthName "Area restrita, para Sarg"
    AuthType Basic
    AuthUserFile /etc/.htpasswd
    require valid-user
    Options Indexes FollowSymLinks
    AllowOverride None
    Order allow,deny
    Allow from all


    # AuthUserFile: é onde esta o arquivo de senha e usuário
    # require valid-user: aqui pedirá a tela de autenticação qdo solicitado



  2. #2
    Flux
    Bom dia, cara aqui na empresa tenho um ambiente parecido com o seu e está tudo funcionando, configurei da seguinte forma:

    Adicionei as seguintes linhas no httpd.conf
    /etc/httpd/conf/httpd.conf

    # Pasta raíz dos relatórios
    <Directory /var/www/html/relatorios_proxy>
    AllowOverride AuthConfig
    Allow from all
    </Directory>

    Criei o arquivo .htaccess na pasta dos relatórios, com o seguinte conteúdo:

    # Arquivo que com os usuários e senhas para autentição (vc tb tem que criar este arquivo)
    AuthUserFile /etc/httpd/passwd
    # Tipo da autenticação
    AuthType Basic
    # Mensagem que irá aparecer na janela de login
    AuthName 'Mensagem da janela de senha'
    # Nome do usuário requerido para autenticar (admin)
    Require user admin

    Agora criei o usuário admin e defini uma senha para o mesmo
    htpasswd /etc/httpd/passwd admin

    De um reload no apache e pronto, é só tentar acessar o pasta via browser.

    Um abraço e boa sorte.

    Flux






Tópicos Similares

  1. Preciso Script para compactar relatorios do sarg!!!
    Por analistaslack no fórum Servidores de Rede
    Respostas: 5
    Último Post: 03-01-2007, 09:37
  2. Incluir códigos nos Relatórios do SARG
    Por sxenM no fórum Servidores de Rede
    Respostas: 3
    Último Post: 10-08-2006, 19:18
  3. Falha no Relatorio do SARG
    Por melandroso no fórum Servidores de Rede
    Respostas: 2
    Último Post: 14-12-2005, 17:38
  4. Pequena dúvida no relatório do Sarg.
    Por lacierdias no fórum Servidores de Rede
    Respostas: 1
    Último Post: 09-03-2005, 09:20
  5. Logotipo nos relatórios do SARG.
    Por __FERNANDO__ no fórum Servidores de Rede
    Respostas: 1
    Último Post: 20-09-2004, 17:27

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L