+ Responder ao Tópico



  1. #1

    Padrão Crontab não tá funcionando

    Agendei para que uma determinada estação se desligasse todos os dias as 17:00, mas não sei porque não está funcionando. O que será que pode está dando errado.

    No crontab com -e inclui a seguinte linha:

    00 17 * * * /sbin/poweroff (linha atual que não funciona).

    Já tentei também:

    00 17 * * * poweroff (não funciona)

    00 17 * * * shutdown -h now (não funciona)

    Estou utilizando o Debian 3.1.

    Obrigado e espero qualquer tipo de ajuda.

  2. #2

    Padrão Re: Crontab não tá funcionando

    Citação Postado originalmente por aprendiz_ce
    Agendei para que uma determinada estação se desligasse todos os dias as 17:00, mas não sei porque não está funcionando. O que será que pode está dando errado.

    No crontab com -e inclui a seguinte linha:

    00 17 * * * /sbin/poweroff (linha atual que não funciona).

    Já tentei também:

    00 17 * * * poweroff (não funciona)

    00 17 * * * shutdown -h now (não funciona)

    Estou utilizando o Debian 3.1.

    Obrigado e espero qualquer tipo de ajuda.
    Tenta assim

    00 17 * * * /sbin/shutdown -h now

    ou

    dá uma olhada aqui ...

    http://www.infowester.com/linuxcron.php
    http://www.vivaolinux.com.br/artigos...=2237&pagina=2

    Espero ter ajudado ...
    valew ...




  3. #3
    regiscechet
    Visitante

    Padrão Re: Crontab não tá funcionando

    Amigo, acho que esta faltando o usuario que ira executar a tarefa.
    Tente assim:
    01 17 * * * root poweroff

    Isso é só um exemplo, no lugar do root, você coloca o usuario que vai estar logado.
    Valew!!
    Espero ter ajudado.

  4. #4
    D4rk_Sl4ck
    Visitante

    Padrão Re: Crontab não tá funcionando

    Citação Postado originalmente por rootmaster
    Citação Postado originalmente por aprendiz_ce
    Agendei para que uma determinada estação se desligasse todos os dias as 17:00, mas não sei porque não está funcionando. O que será que pode está dando errado.

    No crontab com -e inclui a seguinte linha:

    00 17 * * * /sbin/poweroff (linha atual que não funciona).

    Já tentei também:

    00 17 * * * poweroff (não funciona)

    00 17 * * * shutdown -h now (não funciona)

    Estou utilizando o Debian 3.1.

    Obrigado e espero qualquer tipo de ajuda.
    Tenta assim

    00 17 * * * /sbin/shutdown -h now

    ou

    dá uma olhada aqui ...

    http://www.infowester.com/linuxcron.php
    http://www.vivaolinux.com.br/artigos...=2237&pagina=2

    Espero ter ajudado ...
    valew ...

    Faltou o user que vai rodar esse comando... acredito que o certo seria:
    00 17 * * * root /sbin/shutdown -h now



  5. #5

    Padrão Re: Crontab não tá funcionando

    Citação Postado originalmente por D4rk_Sl4ck
    Citação Postado originalmente por rootmaster
    Citação Postado originalmente por aprendiz_ce
    Agendei para que uma determinada estação se desligasse todos os dias as 17:00, mas não sei porque não está funcionando. O que será que pode está dando errado.

    No crontab com -e inclui a seguinte linha:

    00 17 * * * /sbin/poweroff (linha atual que não funciona).

    Já tentei também:

    00 17 * * * poweroff (não funciona)

    00 17 * * * shutdown -h now (não funciona)

    Estou utilizando o Debian 3.1.

    Obrigado e espero qualquer tipo de ajuda.
    Tenta assim

    00 17 * * * /sbin/shutdown -h now

    ou

    dá uma olhada aqui ...

    http://www.infowester.com/linuxcron.php
    http://www.vivaolinux.com.br/artigos...=2237&pagina=2

    Espero ter ajudado ...
    valew ...

    Faltou o user que vai rodar esse comando... acredito que o certo seria:
    00 17 * * * root /sbin/shutdown -h now
    OK! Já tinha tentado assim também, mas sem sucesso.

    Obrigado e qualquer novidade me avise, por favor.

  6. #6

    Padrão Re: Crontab não tá funcionando

    Citação Postado originalmente por rootmaster
    Citação Postado originalmente por aprendiz_ce
    Agendei para que uma determinada estação se desligasse todos os dias as 17:00, mas não sei porque não está funcionando. O que será que pode está dando errado.

    No crontab com -e inclui a seguinte linha:

    00 17 * * * /sbin/poweroff (linha atual que não funciona).

    Já tentei também:

    00 17 * * * poweroff (não funciona)

    00 17 * * * shutdown -h now (não funciona)

    Estou utilizando o Debian 3.1.

    Obrigado e espero qualquer tipo de ajuda.
    Tenta assim

    00 17 * * * /sbin/shutdown -h now

    ou

    dá uma olhada aqui ...

    http://www.infowester.com/linuxcron.php
    http://www.vivaolinux.com.br/artigos...=2237&pagina=2

    Espero ter ajudado ...
    valew ...


    OK! Esqueci de mensionar, mas já tinha tentado assim também e sem sucesso.

    Obrigado e qualquer novidade me avise, por favor.



  7. #7

    Padrão Re: Crontab não tá funcionando


    faz assim

    00 17 * * * /sbin/halt


    ok??
    flw

  8. #8

    Padrão Re: Crontab não tá funcionando

    Boa tarde.

    So para tentar entender melhor o problema.

    O crontab esta funcionando e na hora de executar o comando da erro ou não chega nem a executar o comando?




  9. #9

    Padrão Re: Crontab não tá funcionando

    Citação Postado originalmente por doliveira
    Boa tarde.

    So para tentar entender melhor o problema.

    O crontab esta funcionando e na hora de executar o comando da erro ou não chega nem a executar o comando?

    Olá,

    o serviço tá levantado, o agendamento está inserido (crontab -e), mas na hora marcada não acontece nada... nem erro!

    Obrigado.

  10. #10

    Padrão Re: Crontab não tá funcionando

    Citação Postado originalmente por aprendiz_ce


    Olá,

    o serviço tá levantado, o agendamento está inserido (crontab -e), mas na hora marcada não acontece nada... nem erro!

    Obrigado.

    ja tentou usar o halt ???



  11. #11

    Padrão Re: Crontab não tá funcionando

    outra curiosidade
    se fez o crontab -e como root neh ?

    funfa sim! aqui funfo pelo menos

  12. #12

    Padrão Re: Crontab não tá funcionando

    Olha posso estar falando borracha mas parece que o comando não esta sendo executado. Faça um teste para ter certeza.
    Ex.:
    00 17 * * * root echo "Comando executado com sucesso" > /teste.txt

    obs.: o horario vc coloca de acordo com o horario em q vc esta fazendo o teste.

    Uma dica é: as vezes costumo editar o arquivo /etc/crontab, e colocar o comando direto nele, tb funciona.

    T+



  13. #13

    Padrão Re: Crontab não tá funcionando

    Citação Postado originalmente por gar0t0
    outra curiosidade
    se fez o crontab -e como root neh ?

    funfa sim! aqui funfo pelo menos
    Correto! foi o que eu fiz.

  14. #14

    Padrão Re: Crontab não tá funcionando

    Citação Postado originalmente por doliveira
    Olha posso estar falando borracha mas parece que o comando não esta sendo executado. Faça um teste para ter certeza.
    Ex.:
    00 17 * * * root echo "Comando executado com sucesso" > /teste.txt

    obs.: o horario vc coloca de acordo com o horario em q vc esta fazendo o teste.

    Uma dica é: as vezes costumo editar o arquivo /etc/crontab, e colocar o comando direto nele, tb funciona.

    T+
    Beleza!

    Essa sua dica é bem legal. Vou testar e dou retorno assim que possível.

    Obrigado.



  15. #15

    Padrão Re: Crontab não tá funcionando

    Olá.

    Cara, eu vi em algum lugar, infelizmente não me lembro onde... que é preciso adicionar mais uma linha no final do arquivo, isto é, depois de colocar o comando, no final do arquivo dê um enter, vai ficar uma linha a mais em branco. Depois testa o seu crontab.

    Ab, :-)

  16. #16

    Padrão Re: Crontab não tá funcionando

    Citação Postado originalmente por Duca
    Olá.

    Cara, eu vi em algum lugar, infelizmente não me lembro onde... que é preciso adicionar mais uma linha no final do arquivo, isto é, depois de colocar o comando, no final do arquivo dê um enter, vai ficar uma linha a mais em branco. Depois testa o seu crontab.

    Ab, :-)
    Beleza!

    Eu acredito nessa coisas...

    vou tentar ainda hoje e dou retorno.

    Obrigado.



  17. #17

    Padrão Re: Crontab não tá funcionando

    Tentei todos os comandos que me foram recomendados, mas nenhum funcionou. Verifiquei no LOG do sistema e o comando é executado na hora certinha, mas a máquina não desliga. E aí o que pode ser?

    Obrigado a tods os colegas e fico aguardando qualquer ajuda.

  18. #18

    Padrão Re: Crontab não tá funcionando

    O "bicho" começou a funcionar....

    dexei a seguinte linha agendada:

    00 17 * * * /sbin/shutdown -h now

    mas mesmo assim não funcionava, só que de uma hora pra outra o crontab começou a funcionar.

    Ainda tô sem entender.

    Obrigado a todos pela atenção e até mais.