+ Responder ao Tópico



  1. #1

    Padrão não acessa terminal tty1 com ctrl+alt+f1

    fala galera, como estão as coisas??

    pessoal, tenho aqui instalado o Debian Sarge 3.1r1, e estava instalado também o XFree86 4.3, mas ontem eu mudei para o X.org 6.8.3, só que agora não consigo mais ir para o terminal texto tty1, pressionando as teclas CTRL + ALT + F1 não acontece nada...

    alguém sabe como resolver este porém??

    valeu

  2. #2
    gsteixei
    Visitante

    Padrão Re: não acessa terminal tty1 com ctrl+alt+f1

    Ja tentou Ctrl+ALT+F6 ???
    no meu slack é assim, qdo vc abre um terminal com o F6 os outros ficam habilitados...



  3. #3

    Padrão Re: não acessa terminal tty1 com ctrl+alt+f1

    rapaiz...

    aqui só vai pro console se eu abrir um xterm e digitar "init 2", q é o runlevel somente texto aqui..

  4. #4

    Padrão Re: não acessa terminal tty1 com ctrl+alt+f1

    caramba...

    será q ninguém sabe resolver? :/



  5. #5
    gsteixei
    Visitante

    Padrão Re: não acessa terminal tty1 com ctrl+alt+f1

    Só uma dica, talvez nao tenha nada a ver, mas pode ser possivel
    no arquivo /etc/inittab vc pode desabilitar os outros terminais, entao, va la e da uma olhada se as seguintes linhas nao estao comentadas ou faltando:

    # These are the standard console login getties in multiuser mode:
    c1:1235:respawn:/sbin/agetty 38400 tty1 linux
    c2:1235:respawn:/sbin/agetty 38400 tty2 linux
    c3:1235:respawn:/sbin/agetty 38400 tty3 linux
    c4:1235:respawn:/sbin/agetty 38400 tty4 linux
    c5:1235:respawn:/sbin/agetty 38400 tty5 linux
    c6:12345:respawn:/sbin/agetty 38400 tty6 linux

    desabilitar uma linha dessas, eh desabilitar um terminal.... da uma olhada nisso..
    abraço.

  6. #6

    Padrão Re: não acessa terminal tty1 com ctrl+alt+f1

    cara...

    com relação a essas linhas do terminal no inittab está tudo beleza...

    o problema começou a acontecer depois q eu passei de xfree86 pra x.org...

    acredito q seja configuração no x.org, mas o problema é saber "qual configuração?"

    valeu



  7. #7

    Padrão Re: não acessa terminal tty1 com ctrl+alt+f1

    Olá!

    Dá uma olhada no arquivo xorg.conf, e verifica se tem a seguinte configuração:

    Section "ServerFlags"
    Option "DontVTSwitch"
    Option "DontZap"
    EndSection

    Se tiver, comenta, e reinicia o X. Creio que deve funcionar.

    8-)
    []'s
    Cléoson.

  8. #8

    Padrão Re: não acessa terminal tty1 com ctrl+alt+f1

    cara..

    não tem isso não..

    nem a sessão ServerFlags tem...

    mas o estranho é q qdo era o xfree86 funcionava belezudo...

    eu percebi q é alguma coisa com o xorg, pq no ubuntu e no slack, q é xorg, também não funciona ir pro terminal qdo está no servidor X...

    pelo menos comigo ão funciona.. :/