Página 2 de 2 PrimeiroPrimeiro 12
+ Responder ao Tópico



  1. #21

    Padrão

    Acredito que tenha outro problema no meu servidor.

    Outros plugins aparecem normalmente lá (calendário, notes).
    Peguei inclusive um left_main.php original (de outro provedor onde estava funcionando, e não deu).

    Troquei também para o quota_usage ao invés do check_quota e não funcionou também.

    Apesar de ter certeza que o sistema utiliza quota em IMAP e não em usuário Linux, creio que seja algum problema no serviço do IMAP mesmo.

    Vou pesquisar mais para ver

  2. #22

    Padrão

    Para quem acompanhou esse tópico, perceberam que tive muitos problemas para conseguir implantar a quota (plugin).


    Já havia desistido na verdade, mas como temos inúmeros domíniios e contas de email cadastradas, durante os testes em um determinado usuário simplesmente apareceu.
    Vou verificar que na pasta /home dele a única coisa diferente é um arquivo que o sistema criou (maildirsize).

    Se retirar esse arquivo não aparece a quota.
    Nesse arquivo consta, na primeira linha o valor da quota do cliente, e na segunda linha a quantidade de Mbs já ocupado pelo cliente (ainda na segunda linha aparece outro número que acredito ser a quantidade de mensagens na pasta inbox)
    Aparece também uma terceira linha com outros números que não consegui identificar a que se referem.

    Teoricamente nesse meu sistema, para funcionar o quota, preciso ter esse arquivo na pasta de cada usuário. O problema que não sei como esse simplesmente apareceu, e porque os demais não tem esse arquivo.

    Até posso criar o arquivo na mão na pasta de cada um, mas não teria como eu implementar a 2ª e 3ª linha desse arquivo.
    Tentei criar o arquivo vazio, para ver se ao logar o sistema completaria o restante das informaçoes, mas não fez.

    Por que os outros usuários não tem esse arquivo?
    Como fazer para que o sistema automaticamente crie esse arquivo em todos os usuários com as informações já corretas de cada um?



  3. #23
    carlosjardim
    Visitante

    Padrão

    Hummmm...

    Qual é o imap server que voce esta usando?? Courier?

    Creio que isso deve ser configuracao dentro do plugin, no proprio squirrelmail voce conseguiu fazer ele funcionar?

    att.


    Citação Postado originalmente por liandrocarniel Ver Post
    Para quem acompanhou esse tópico, perceberam que tive muitos problemas para conseguir implantar a quota (plugin).


    Já havia desistido na verdade, mas como temos inúmeros domíniios e contas de email cadastradas, durante os testes em um determinado usuário simplesmente apareceu.
    Vou verificar que na pasta /home dele a única coisa diferente é um arquivo que o sistema criou (maildirsize).

    Se retirar esse arquivo não aparece a quota.
    Nesse arquivo consta, na primeira linha o valor da quota do cliente, e na segunda linha a quantidade de Mbs já ocupado pelo cliente (ainda na segunda linha aparece outro número que acredito ser a quantidade de mensagens na pasta inbox)
    Aparece também uma terceira linha com outros números que não consegui identificar a que se referem.

    Teoricamente nesse meu sistema, para funcionar o quota, preciso ter esse arquivo na pasta de cada usuário. O problema que não sei como esse simplesmente apareceu, e porque os demais não tem esse arquivo.

    Até posso criar o arquivo na mão na pasta de cada um, mas não teria como eu implementar a 2ª e 3ª linha desse arquivo.
    Tentei criar o arquivo vazio, para ver se ao logar o sistema completaria o restante das informaçoes, mas não fez.

    Por que os outros usuários não tem esse arquivo?
    Como fazer para que o sistema automaticamente crie esse arquivo em todos os usuários com as informações já corretas de cada um?

  4. #24

    Padrão

    Peguei a versão squirreloutlook-1.0.3.tar.gz e tive problemas com o left_main.php. Ao abrir o Webmail não aparece nada, onde deveria mostrar as insformações do arquivo. Alguém sabe como resolver?



  5. #25
    carlosjardim
    Visitante

    Padrão

    Ola MacVitor,

    Acho que o problema esta no php que deve ser alterado dentro do php para a opcao:

    error_reporting = E_ALL & ~E_NOTICE

    Desta forma o seu left_main.php sera exibido.

    Att.

  6. #26

    Padrão

    não, Carlos.

    Consegui resolver daquela forma que comentei com vc no outro post. Alterei as caixas para INBOX.Trash, INBOX.Sent e INBOX.Drafts.

    Valeu!



  7. #27

    Unhappy Como aplicar o outlook theme tendo já o squirrel a rodar?

    Caro Carlos Jardim,

    Achei o vosso desenvolvimento bastante interessante.

    Eu tenho uma dúvida. Já rodo o squirrelmail 1.4.4-10 numa máquina Debian Sarge, e gostaria de aplicar o outlook theme. Como poddo fazer isso sem "desmontar" o meu squirrelmail??

  8. #28
    carlosjardim
    Visitante

    Padrão

    O SquirrelOutlook é o mesmo source do SquirrelMail porem somente o layout é alterado.

    Se voce ja tiver algum squirrelmail configurado e ativo é necessário destiva-lo a ativar o SquirrelOutlook.

    Qualquer duvida é soh entrar em contato.

    Att.



  9. #29

    Padrão

    Desculpe a minha ignorância.... como faço essa operação?.....

  10. #30
    carlosjardim
    Visitante

    Padrão

    Use as informacoes abaixo como exemplo:

    1 - Descompacte o arquivo onde achar necessario
    tar -zxvf arquivo.tar.gz

    2 - Adicione as linhas abaixo no seu httpd.conf (exemplo)

    <VirtualHost *>
    DocumentRoot /websites/outlook.dominio.com.br
    ServerName outlook.dominio.com.br
    CustomLog /var/log/apache/outlook_access.log combined
    ErrorLog /var/log/apache/outlook_error.log

    php_value session.auto_start 1

    <Directory "/websites/outlook.dominio.com.br">
    Options Indexes MultiViews
    AllowOverride None
    Order allow,deny
    Allow from all
    </Directory>
    </VirtualHost>

    3 - Reinicie seu apache


    4 - Configure o squirrelmail outlook theme (/pastasquirrel/config/) usando o comando ./conf.pl

    4.1 - Altere se necessário o a linguagem (funciona em pt_BR)
    4.2 - Altere as configuracoes para seu IMAP
    4.3 - etc..etc..etc..

    Att.



  11. #31

    Padrão Funcionou perfeitamente

    Cara ficou Show de bola, funcionou perfeitamente, tive que fazer poucas alterações pois apresentou uma mensagem de erro que foram contornadas copiando o arquivo configure.

    Meus parabéns, excelente trabalho!!!!