+ Responder ao Tópico



  1. #1
    _Dr4k0_
    Visitante

    Padrão Problema com conexão Slack 10.2

    Olá pessoal,sou novo aqui e já vim tirar uma dúvida.

    Já andei "googlando" bastante e vi muitos fóruns achei esse o melhor e espero que resolva minha dúvida..

    O meu problema é o seguinte sou iniciante em linux..intalei um Slack 10.2 aqui com o kernel 2.4.x,minha placa de rede é a Realtek 8139D sobre ela li pessimos comentáriosi e algumas pessoas falaram que não conseguiram e que compraram outra,etc,etc..eu digito mii-tool,lspci | grep Ether,dmesg | grep eth, e nada não encontram a placa de rede..andei no IRC pedi ajuda.. falaram que era só eu baixar o kernel novo ,então lá fui eu baxei o kernel 2.6.13 e instalei porém agora estou sem internet e sem o mouse funcionar =/,

    antigamente eu rodava o modprobe 8139too e dava erros..agora executo o comando e não aprece nada nenhum erro nem nada..mais como sou iniciante em linux não sei se aparece uma msg de exito ou é normal..
    estou aguardando sugestões espero que com vcs eu consigo encontrar uma saída..

    Espero não receber sugestões inúteis como,essa placa é horrível troque-a,compre outro,coisas do genero..espero uma solução sem trocar a placa e que eu comece a usar o linux logo

    obrigado

  2. #2

    Padrão

    Até onde eu li, o módulo 8139too suporta todos os modelos da Realtek 8139. Dá pra copiar e colar aqui os erros que você recebe quando tenta carregar o módulo?



  3. #3

    Padrão

    Kra pode parecer ridículo + eu tive um problema desse uma vex e depois de muito pesquisar descobri que a placa era falsa.... Pra vc ter ideia nem o WinDOSE reconheceu ela... ai eu comprei outra 8139D e funfou legal...

  4. #4

    Padrão

    uso pequenos servidores com esta placa e funcionam perfeitamente.

    O que pode estar acontecendo é o que foi mencionado pelos colegas acima: a placa pode ser falsa!!

    O kernel 2.6.13, preparado pela própira distro, encontra-se no CD 2 (dir. linux), com test26.s

    Att,

    mtec



  5. #5

    Padrão

    Primeiramente, pq vc já não instalou logo o Slackware 11?

    O que eu sugiro vc a fazer é instalar o Slack 11. (se assim quiser é claro..)
    Depois vc procura o kernel (NO CD DO SLACK), entra na pasta e da upgrade em tudo

    Código :
    upgradepkg --install-new *.tgz

    Feito isso, vc vai certificar que o grub ou lilo está apontando para a imagem certa do kernel... e depois reboota a máquina.

    Pra ver se o módulo correto foi carregado, use lsmod e veja se aparece o módulo da sua 8139..

    PS**
    * recomendo o kernel huge26 que vem acho que no terceiro cd do Slack.
    ** se tiver usando reiserfs como sistema de arquivos vai ter que criar um initrd (qualquer dúvida tamo aqui)


    Ab e bom trabalho

  6. #6
    _Dr4k0_
    Visitante

    Padrão

    Pessoal troquei minha placa de rede..

    Agora estou tendo outros problemas =//

    troquei por uma CNET200, tipo o Slack já esta reconhecendo ,slack10.2 kernel 2.4.x..o meu slack 10.2 é em dvd.. poderiam me passar o diretório pra fazer o upgrade?eu tinha atualizado o kernel porém meu mouse parou de funcionar e reconfigurei o xorg mesmo assim não funcionou tive que reinstalar o linux..

    agora voltando ao problema da internet essa placa é reconhecida e tudo agora como eu faço pra congiurar a internet não estou conseguindo =// já tentei netconfig,ifconfig,etc..

    Aqui em casa no Windows utilizo
    IP: 10.1.1.2
    NetMask: 255.0.0.0
    Gateway : 10.1.1.1
    DNS 201.10.128.3
    2º: 201.10.1.2

    espero respostas..

    vlw ae pelas dicas pessoal!



  7. #7

    Padrão

    Pra configurar a rede, se a placa tiver sido reconhecida e os devidos módulos estiverem carregados, basta vc rodar netconfig e restartar a interface de rede.

    Código :
    /etc/rc.d/rc.inet1 restart

    O arquivo de configuração é /etc/rc.d/rc.inet1.conf

  8. #8

    Padrão

    Ah, baixa todos os .tgz`s dessa pasta, salva em outra pasta ai no seu pc....

    ftp://ftp.slackware-brasil.com.br/sl...inux-2.6.17.13

    depois, como root, entra na pasta e dá

    Código :
    upgradepkg --install-new *.tgz

    depois disso, verifique o lilo se está ok e se vc estiver usando reiserfs...
    vais ter que gerar um initrd

    Ab



  9. #9
    _Dr4k0_
    Visitante

    Padrão

    Citação Postado originalmente por samuelstj Ver Post
    Ah, baixa todos os .tgz`s dessa pasta, salva em outra pasta ai no seu pc....

    ftp://ftp.slackware-brasil.com.br/sl...inux-2.6.17.13

    depois, como root, entra na pasta e dá

    Código :
    upgradepkg --install-new *.tgz

    depois disso, verifique o lilo se está ok e se vc estiver usando reiserfs...
    vais ter que gerar um initrd

    Ab
    vc teria um tutorial ensinando a criar esse Initrd??
    acho que esses conteúdos já tem no meu DVD do Slack 10.2

    e o que faço para o linux enxergar minhas partições NTFS?

    E mais uma coisa apenas..sou iniciante em linux..qual o módulo para uma CNET200?
    Última edição por _Dr4k0_; 11-12-2006 às 22:21.

  10. #10

    Padrão

    Amigo, o initrd é mesmo só se vc estiver usando reiserfs.
    no diretorio que eu te passei, tem um arquivo ensinando como criá-lo.

    dê uma lida lá de qualquer forma. Mas vou de dar um adiantamendo.

    entre no /boot e siga os passos..

    Código :
    cd /boot
    mkinitrd -c -k 2.6.17.13 -m reiserfs

    Com isso ele vai gerá-lo, depois basta vc mandar o lilo carregar.
    A seção do lilo fica mais ou menos assim:

    Código :
    # Linux bootable partition config begins
    [B]image = /boot/vmlinuz-generic-2.6.17.13
      [/B][B]initrd = /boot/initrd.gz[/B]
      root = /dev/hdax
      label = Slaxkware
      read-only
    # Linux bootable partition config ends

    lembrando que depois de editar o arquivo de configuração do lilo, vc precisa rodar o lilo.

    Ab



  11. #11

  12. #12

    Padrão

    Só para lembrar que se o seu sistema de arquivos for ext3 os parâmetros mudam:
    # mkinitrd -c -k 2.6.14.6 -m jbd:ext3 -f ext3 -r /dev/hda1



  13. #13